Crashing emClient

Hi,

I am a long time eM Client user and was pretty happy with the product (currently 9.2.2258 (7080479).

Unfortunately, there have been some issues with it lately. Sometimes it just crashes when opening a window for a new email. When I click Backup, it is not doing it.

When Windows is starting, eM Client starts up, but it always has to do a database consistency check. Luckily, so far, it has been able to start.

But, when I close it and start it manually, nothing is happening. I have to restart the system so eM Client can start by itself. And most of the time it starts successfully.

I am looking at the logging directory and the cef.log file reports this error message

[0515/203353.403:ERROR:viz_main_impl.cc(169)] Exiting GPU process due to errors during initialization

The system runs perfectly fine, only eM Client is giving me some issues.

Can anybody give me a hand with this?

Thanks in advance,

Jan

Sometimes it just crashes when opening a window for a new email. When I click Backup, it is not doing it

Sounds like you may have a possible eM Client local database error if all your other programs are ok.

So If you have prior recent eM Client backups “that did backup ok”, and you have an eg: IMAP, Exchange, Office 365 or iCloud (non pop account), then click “Menu / File / Restore” (Pc) or "“File / Restore” (Mac) and try restoring a recent backup. Any new mail etc since the backup will then update when eM Client next connects.

You can see / view any eM Client backups by default in the “Documents / eM Client” folder. They will be dated backup.zip files.

Now if you don’t have any recent eM Client backups or your backups didn’t restore, then you could try manually repairing eM Client via the following.

(Repair eM Client database manually for Windows)

“Close eM Client and open a Windows Command Prompt. Not a powershell, but a command prompt”.

Paste in this command:
“C:\Program Files (x86)\eM Client\MailClient.exe” /dbrepair

Then reopen eM Client and see if that fixed the problem

(Repair eM Client database manually for Mac)

Close eM Client and then “open the Terminal app via either Launchpad or Utilities” on the Mac. Then Paste and run the following command.

/Applications/eM\ Client.app/Contents/MacOS/eM\ Client /dbrepair

Then reopen eM Client and see if that fixed the problem

Now if manually repairing eM Client still doesn’t work, then try uninstalling eM Client (and if you have Windows) "don’t delete the database when asked on the uninstall wizard and then reinstall the same V9.2.2258 version via the release history page.

Lastly if still the same problem, you might then need to remove your accounts and setup as new again.

Thanks for your answer, really appreciate it.

When I close the database manually and execute

“C:\Program Files (x86)\eM Client\MailClient.exe” /dbrepair

it cannot repair it and gives an error

==== BEGIN SNIP ====
MailClient.Storage.Data.DatabaseCorruptedException (0x80004005): SQLite Error 11: ‘database disk image is malformed’.
Line: 7
DELETE FROM MailItems WHERE (SELECT COUNT(*) FROM “MailAddresses” WHERE parentId=MailItems.id AND “type” <= 3) <> 3;
at MailClient.Storage.Data.DbRepository1.ImportFromResource(IDbConnection connection, Stream myStream, CancellationToken token) at MailClient.Storage.Data.DbRepository1.ImportFromManifestResource(String resourceName, CancellationToken token)
at MailClient.Storage.Data.DbRepository1.Repair(RepairMode mode, CancellationToken token) at MailClient.Accounts.ItemRepositories.Repair(RepairMode mode, CancellationToken token) at MailClient.DbRepair.ConsistencyChecker.CheckConsistencyForAccount(String accountDirectory, RepairMode mode, CancellationToken token) at MailClient.DbRepair.ConsistencyChecker.<>c__DisplayClass2_0.<Check>b__0(String p) at MailClient.DbRepair.PerAccountExecutor.Execute(String dataStoreLocation, Func2 action)
at MailClient.DbRepair.ConsistencyChecker.Check(RepairMode mode, CancellationToken token)
at MailClient.DbRepair.CheckingProcess.Check(CancellationToken token)
Data:
ResourceName: MailClient.Storage.Mail.Data.DbMailRepository.consistency.sql
DatastoreLocation: C:\Users\Jan\AppData\Roaming\eM Client
==== END SNIP ====

Looks like closing it manually does not correctly close the databse.

Now, I need to reboot the machine. On reboot, it will do a dbrepair by itself, and up to now, it can repair it and start eM Client.

What I think is the problem is in the cef.log file that is the source of my problems.

[0516/084820.456:ERROR:viz_main_impl.cc(169)] Exiting GPU process due to errors during initialization

I am running an Intel I9 13900KS 3200 1700 BOX processor with an integrated GPU.

Previously eM Client was running fine. Yesterday I have tried emclient-v9.2.2157 and 10.0.2382.0 and they have the same issue now.

Anybody?

This means that the database is corrupted.

Some users have found that restarting Windows, or restarting eM Client a few times resolves the issue, but otherwise:

  1. If you have a recent backup, you can delete the current eM Client database, then restore the backup and eM Client should start working again without any problems.

  2. If you don’t have a backup, but all your data is synced with servers, then you can delete the database and start over. After adding your accounts, eM Client will resync with the server.

Your database is the C:\Users\Jan\AppData\Roaming\eM Client\ folder. You may have to enable hidden items in Windows Explorer to get there.

Thanks for getting back to me.

The question remains.

If I manually close the database, why does it get corrupted?

I have tried different versions now, all same behavior.

I don’t think this is some sort of bug, but there is something wrong with my machine.

Just run memory diagnostics and CPU diagnostics, no problem found.

And howcome this error message keeps showing up in my cef.log file.

0516/125549.257:ERROR:viz_main_impl.cc(169)] Exiting GPU process due to errors during initialization

If the database is corrupt, reinstalling or installing another version won’t make any difference as the database is separate from the application. You will still have the same corrupt database.

You need to follow the instructions I gave previously. There is no other solution.

I have completely removed eM client from my computer.

Also deleted the database.

I have completely removed .Net in reinstalled the latest version.

Now installed the latest version 10.0.2382.0.

When I install eM Client it immediately crashes after the installation. This is the error I find in the Windows Event log.

==== BEGIN SNIP ====
Application: MailClient.exe
CoreCLR Version: 8.0.424.16909
.NET Version: 8.0.4
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeInitializationException: The type initializer for ‘MailClient.Common.UI.Themes.DefaultColorTheme’ threw an exception.
—> System.ArgumentException: Value of ‘121839976’ is not valid for ‘green’. ‘green’ should be greater than or equal to 0 and less than or equal to 255.
at System.Drawing.Color.g__ThrowOutOfByteRange|327_0(Int32 v, String n)
at System.Drawing.Color.FromArgb(Int32 alpha, Int32 red, Int32 green, Int32 blue)
at System.Drawing.Color.FromArgb(Int32 red, Int32 green, Int32 blue)
at MailClient.Common.UI.Themes.CalendarColors.SystemCalendarColors…ctor()
at MailClient.Common.UI.Themes.SystemColorTheme…ctor()
at MailClient.Common.UI.Themes.DefaultColorTheme…ctor()
at MailClient.Common.UI.Themes.DefaultColorTheme…cctor()
— End of inner exception stack trace —
at MailClient.Common.UI.Themes.DefaultColorTheme.get_Instance()
at MailClient.BrandingUtils.GetDefaultColorTheme()
at MailClient.Program.Main(String[] args)
==== END SNIP ====

And this one.
==== BEGIN SNIP ====
Faulting application name: MailClient.exe, version: 10.0.2382.0, time stamp: 0x65f90000
Faulting module name: KERNELBASE.dll, version: 10.0.19041.4412, time stamp: 0x6d8c3da8
Exception code: 0xe0434352
Fault offset: 0x00140b82
Faulting process id: 0x8cc
Faulting application start time: 0x01daa78fd9aa1731
Faulting application path: C:\Program Files (x86)\eM Client\MailClient.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: 61e68164-10ce-4041-a8ac-24d1376f36f7
Faulting package full name:
Faulting package-relative application ID:
==== END SNIP ====

You have installed a beta version. If you have any issues while testing the beta version, please report them to [email protected]

Ok, removed eM Client again and installed version v9.2.2258.

I now get this error.

=== BEGIN SNIP ===
Application: MailClient.exe
CoreCLR Version: 6.0.2924.17105
.NET Version: 6.0.29
Description: The process was terminated due to an internal error in the .NET Runtime at IP 702EAAA3 (70140000) with exit code c0000005.
=== END SNIP ===

And this one

=== BEGIN SNIP ===
Product: eM Client – Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action MailClientRunAfterStartup, location: C:\Program Files (x86)\eM Client\MailClient.exe, command: /registerstartup
=== END SNIP ===

I think I will reinstall windows tonight and see what happens after that.

I have reinstalled Windows 10 and tried eM Client on an empty box, same result.

And it becomes even weirder, I also installed Windows 11, with the same result.

This made me thinking something is broken in my machine.

But, now I tried eM Client on Windows 11 in Safe Mode.

What do you think? It works perfectly.

So concluding so far is that my machine is fine and it is most likely not a bug in eM Client.

What I still find interesting is this error message in the Event Viewer.

=== BEGIN SNIP ===
Application: MailClient.exe
CoreCLR Version: 6.0.2924.17105
.NET Version: 6.0.29
Description: The process was terminated due to an internal error in the .NET Runtime at IP 702EAAA3 (70140000) with exit code c0000005.
=== END SNIP ===

Exit code c0000005 indicates the app is using memory outside of what it is allowed to. How come, this does not happen in Safe Mode and does happen in Normal Mode?

Anybody?

I will get to the bottom of this.

Exit code c0000005 indicates the app is using memory outside of what it is allowed to. How come, this does not happen in Safe Mode and does happen in Normal Mode?

Windows runs different drivers etc on normal startup compared to safe mode, which access memory differently, so if there is a corrupted driver or problem with a driver or optional program installed on startup you can sometimes get exception errors.

You can also get those type of errors when eg: a ram stick is starting to go faulty as programs can use all different parts of memory and if there is a fault in the ram stick it could also also exception errors.

So first thing, open a admin dos prompt and type the following & enter to see if that finds any problems with drivers etc. If there is a problem sometimes this command can fix it. Reboot after running the below.

sfc /scannow

Also make sure all your motherboard and any other optional hardware installed items are up to date. As if there is an eg: outdated hardware driver that could cause issues in memory & get exception errors.

Apart from that, try “disabling all background programs on startup” other than the basic Windows OS and then see if it will run in Normal mode without exception errors. If it then does work ok, enable the background programs one at a time and reboot till you find which program is causing it.

If you are still getting exception errors on a clean Windows 10 & Windows 11 and all drivers are up to date, then you could have a hardware problems.

So if you are running a desktop PC with removable ram sticks, suggest to have your ram sticks tested to make sure they are 100% ok and not faulty somewhere. If you have any spare ram sticks, try switching them out and see if that makes any difference. If you don’t have any spare ram or your ram sticks are not removable, you might then need to see a hardware tech or shop to test your ram etc.

For me, emClient started crashing on 4 different machines recently, maybe 2-3 months ago. It is implausible that this is related to the simultaneous corruption of databases on the different machines. The crashes became so disruptive that I may be spending more time waiting for emClient to complete checking the databases after the subsequent crash than actually using the program. If this continues, I may need to move on to different software. The only distinguishing feature of my mail is that it is pretty bulky, in tens of GB, combining many server accounts and local folders.

As you have a Pro license, open a support ticket with us (Menu > Help > Get VIP Support) and give the mail address you enter in the crash report popup. We can look at the crash report and see why it happens.

Thanks, Gary; I will do that, though it will involve jumping over some hurdles: 1) A pop-up is generated only once every few crashes. 2) I am on a trip with the new 4th computer few days only into operation, for which I have not yet gotten a Pro license. I have remote access to a couple of those with licenses, but I cannot systematically monitor the emClient crashes there. With time I should catch some pop-up there though.

I have now installed Windows 11 on my PC, which will be the OS I will be using from now.

Over the weekend I have tested my memory, no errors there.

I used to install my drivers with ‘Armoury Crate’ software provided by Asus to automatically update the drivers. Now I have installed them all manually.

And the result seems positive, it seems to work for now.

I will do more testing on it and keep you updated in the coming days.

Promised to keep you up to date.

Not sure why I was thinking it worked, but it does not.

I found other applications who must have the same issue, because they crash immediately after starting as well, one of them is WhatsApp. Two weeks ago this was certainly not happening. These applications work fine on my laptop.

But I made images during my installation, so I can roll back to anytime I want. If there is something automatically updating on my PC I will find it.

I am at the bottom of this; finally, somebody should be paying me for all my efforts.

This is my hardware

ProArt Z790-CREATOR WIFI BIOS ver. 2202
13th Gen Intel(r) Core™ I9-13900KS

I have tested all the hardware rigorously and there are no issues. Not on the board, not in the CPU and not in the memory.

This system is by default running on 3GHz, but it can boost to 6GHz when required. This happens when it becomes under heavy load, also when applications are starting.

Now there is a setting in the BIOS in

Advanced\CPU Configuration\CPU - Power Management Control called Turbo Mode.

This setting allows the CPU to push to 6GHz. It is now set to Disabled, leaving the CPU stuck under 3GHz. Now eM Client starts without problem. Tested it a couple of hundred times and this fixes the crashing app.

Obviously, I did not buy this expensive system to maximize it at half it’s maximum speed.

I still find it peculiar that I have been running this system for over a year without any problem and out of a sudden eM Client start crashing on me and I have to limit the CPU speed.

ProArt Z790-CREATOR WIFI BIOS ver. 2202
13th Gen Intel(r) Core™ I9-13900KS

There is a setting that allows the CPU to push to 6GHz. It is now set to Disabled, leaving the CPU stuck under 3GHz

When CPUs are overclocked, that can cause instability and crashing “in any type of program” due to eg: program timings etc.

You would normally only over clock a cpu for eg: gaming. It’s not recommended though as is risky due to the extreme heat that happens overclocking.

Intel also recently had issues with crashing with pretty much all the i9-13900K series cpus. Intel were apparently investigating this issue as the crashing was also happening with the i9-14900K cpu.

There are also many websites and YouTube videos that talk about that specific issue currently. So you might need a “firmware bios” update" on your motherboard to fix that as well from Asus.

Yes, thanks, I will.

I did upgrade the BIOS last week, but this did not solve my problem.

I find some more info here

https://www.reddit.com/r/overclocking/comments/1axepvu/optimizing_stability_for_intel_13900k_and_14900k/

and here

https://www.reddit.com/r/intel/comments/1awpon0/is_your_intel_core_i913900k_crashing_in_games/

I did upgrade the BIOS last week, but this did not solve my problem.

I would contact Asus support as they would be aware of this crashing issue with your i9 CPU, and ask them if there is going to be any further bios updates for your motherboard, and tell them you had to reduce the cpu to 3ghz to stop the crashing.

Sometimes too after updating a new bios you have to eg: reset the bios to defaults. So try that

Also test with different Windows resolutions.

Make sure as well you have the latest Windows 11 updates as alot have been pushed lately.

1 Like