Connection Failed :(

Hello,

I went to open my email this morning and am getting a little red triangle and an error message saying “Connection failed. An attempt to connect to xxxxxxxx@xxxxxxxxxxxx.com failed. This could be caused by temporary server unavailability or incorrect settings. Please check the settings or click on the warning symbol to try connecting again.”

(My actual email address shows in the error message, just didn’t want that publicly showing. I’ve checked all settings and have tried clicking the warning symbol many times but to no avail. Could someone please help asap?

Things to try, in no particular order:

(1) Stop your anti-virus app
(2) Stop your VPN or change server
(3) Re-Boot your computer
(4) Try using your email server host web mail to see if there is an issue with their system.

I have tried all of your suggestions but they sadly did not work.
I logged into the web mail version just fine and do not have issues there, so it is an eM Client issue.

If you are using an IMAP account, you can try removing the account and adding it back…

So this worked temporarily, but approximately 15-20 minutes later I’m getting the same error as I did in the beginning.

It could be a server fault. Have you contacted the email provider?

There are other possibilities, like a router fault.
Without changing anything on the computer, restart the router and see if there is any difference.
If eM Client connects, then after some it stops, restart the router again. Does it connect again after the router restart?

I suspect as @Gary advised that it could be possible your remote mail server issue or some connection issue between you & them along the way being that it worked again after removing and re-adding the account for 15-20 mins.

Are you using any alt DNS like Cloud Fare or Google or any other optional DNS servers ?.

If you are try going back to your default ISP auto assigned DNS servers.

Also try resetting your TCP/IP stack in your OS and then reboot incase its partially corrupted.

To reset TCP/IP stack in Windows 10/11

Open an “elevated admin command prompt”, and type the following and hit Enter:

If you use IPv4, type the following and hit Enter:
netsh int ipv4 reset

If you use IPv6, type the following and hit Enter:
netsh int ipv6 reset

To reset TCP/IP on Mac OS

Click on Apple icon in the top left corner and then select “System Preferences”

Then open the “Network” icon.

Next click on "Internet connection with “Status Connected” on the left and click the “Advanced button” in the bottom right corner.

Finally click the “TCP/IP tab” along the top and click “Renew DHCP Lease”. Then click “Ok” and close and reboot your Mac.

I’m evaluating eM Client on Windows 10 and am experiencing the same thing today. I have a non-Gmail email server with several email addresses for the same domain and most of them are fine but three of them show the triangle warning. Since there are multiple email accounts but it’s the same three accounts repeatedly that have a problem, I agree with Nichole_H that it’s an eM Client issue, not a server issue–they’re all three configured the same (IMAP) connecting to the same server.

Furthermore, I’m using Thunderbird on a different machine and Edison Email on my phone and those work just fine. Finally, I can login to the server and use the web-based email to check messages without any hint of a server problem.

One more thing: I went into the Account Settings for the three problematic accounts, switched to the Diagnostics tab, enabled diagnostic logs for both IMAP and SMTP, and clicked Diagnose. At first, it told me there were problems but I noticed it had switched the IMAP port from 993 to 143, after clicking Fix, it fixed everything and said it was OK, so I hit Save only to get the triangle error again.

Yesterday, I used eM Client to transfer thousands of emails off several Google GMail accounts and it all worked well but today, I keep getting these errors and new messages are not showing up.

I’m suspecting there is some new email that has come in that is tripping it up somewhere. How do I get to that diagnostic data?

I have a non-Gmail email server with several email addresses for the same domain and most of them are fine but three of them show the triangle warning

If you have already tried rebooting your computer, then if you have any optionally installed, eg: Firewalls or Security programs, Antivirus email scanning programs, or VPNs etc, try completely disabling them to test to see if that fixes the red triangle errors on your IMAP accounts.

At first, it told me there were problems but I noticed it had switched the IMAP port from 993 to 143,

For IMAP server accounts you normally either use one of the following.

Port 993 = Use SSL/TLS on special port (legacy)
Port 143 = Use SSL/TLS if available

If still not working, I would contact your specific mail server technical support to see if they have any issues their end. Also double check the Mail Client server settings with your Mailbox support.

Lastly as long as you are using the latest eM Client V8 or V9 for PC or Mac they have no issues I am currently aware of, and will be another issue causing this problem you are experiencing.

eM Client version history releases for PC and Mac.

Note: If you do update to a later eM Client version, backup first via “Menu / Backup”. Then close eM Client and install the update.

Right. This server specifically uses 993 for SSL/TLS.

I found the logs and am going through them. It looks like one of the folders/emails I had uploaded might have had an invalid character in it. It goes through several folders just fine but then shows this:

A6 BAD Error in IMAP command APPEND: Invalid characters in atom…

I’m checking through the emails on the server. I wonder if this is the same issue in the other accounts…

I just downloaded eM Client three days ago (I’m still evaluating it) so have the latest version, 9.0.1361 on Windows 10.

Remember, I said there are two other email clients on different computers (Thunderbird and Edison Email) that are hooked up to the SAME email accounts, also using IMAP to pull the SAME emails and folders and they do not have a problem. So troubleshooting a potential server issue is pointless.

Remember, I said there are two other email clients on different computers.

Yes I understand that which then could be something eg: optionally installed on your first computer which has eM Client 9.0 causing the triangle errors if you have the same IMAP settings as Thunderbird & Edison mailers.

Or you might need to try removing those failed IMAP accounts from eM Client and re-add them via the automatic email wizard or manual setup depending on if your mail servers support OAuth or not.

Note: If you do remove and re-add any IMAP account, remember to backup first via “Menu / Backup” in eM Client.

Same issue here with att.net (yahoo-based server). I could send and receive with no issues on v8. v9 upgrade worked for about a day then the red triangle. I did a little research and decided to create the Oauth security key and put that in the emclient account password and viola, works perfectly.

Suggestion for emclient team … might want to suggest this as a solution to folks having this issue.

Love the program by the way. Keep up the good work.

2 Likes

i am getting error

Same problem here, i try all ways and nothing, i make right now export emails and contatcs and make donwngrade to V8

I have the same problem, that started after my last version update. I have two email accounts with two different service providers, and both started failing at the same time. I can connect to both servers from the same network using other equipment, so it has to be something with the latest version of eM Client. The first time I had the problem, I noticed that the counter at the top of the screen (between my email address and “eM Client” was moving very slowly.

After using this client for long time, it is sad that this problem affecting a lot of people is not being taken with enough concern.

1 Like

You are dead right, but emClient still trying to blame peoples servers. I have the same problem. I even loaded v8 onto another computer, and it works fine, and like you, my phone is fine, Thunderbird is fine.

I have found, and other people have found, send an email to yourself, and then it starts working again.

1 Like

I started a separate thread and listed lots of diagnostic log information. I finally got a useful work around in the form of an “advanced parameter” from @Gary but I still don’t know why I had to do that.

Yes, this is most definitely a problem with eM Client–I wish they would admit it and get a fix for it.

You have been claiming to have the exact same problem as many here now, yet you’re using IMAP, the screenshot above lists EWS, and other have had trouble with POP3 or SMTP …
Maybe it’s the same core issue/bug, somehow, I wouldn’t know … But I bet you don’t either … :man_shrugging:

(My eM Client v9 is connected to 7 different servers/accounts. And I have seen no such problem. Maybe the issue is not that the devs ain’t taking the issue seriously, but that it’s complex and/or more than one issue.)

Looks like it might be a conflict between emClient and AVG. We have a process from AVG which we are trying today.

1 Like