Can't edit draft email when selected from Drafts folder

Same here.  But  I am also noticing that it saves drafts of the same email.  I sometimes have to walk away to do something and may come back a few times to complete one email, and I see multiple drafts, each with a different amount of info so it appears that instead of appending to the existing draft, it creates a new draft of the same email, just with more detail than the last!

This is because of the auto save feature, which defaults to saving a version every 3 minutes.  Those multiple drafts will be deleted when the message is sent.  You can turn this feature off or change the save interval by going to menu/tools/settings/mail/compose.

Thanks Jay.  But I am also noticing that even after I send the email, the remaining drafts do not delete so I sometimes have to go in and just make sure I see the email in the sent folder before I delete those rogue drafts…I still think that it should autosave to the same draft and not create multiple drafts every 3 minutes. 

Agreed with Ed on both points. And you shouldn’t have to turn off “Automatically save drafts” to work around this. That’s very dangerous.

This isn’t hard. Gmail works correctly. em Client can easily imitate that behavior for the correct implementation. 

When you turn it off, eM Client doesn’t create a draft “folder” item unless you close the email prior to it being sent, then it prompts you if you want to save the draft.  Gmail, on the other hand, creates the draft item and does not prompt you if you close it prior to sending and the draft will stay there until you do something about it.  In this case, I think the eM Client handling is better and just as safe.

Also, eM Client keeps (temporarily) changes made to the document, so you can revert back to a previous draft if you so desire.

You don’t have to turn it off, just change the interval.  I use eM Client gmail and I never have a problem with drafts-- they always delete themselves appropriately.

Jay, I’m glad it works for you. I still cannot edit a draft in em if it was started in gmail. I’m not willing to use the “Forward as Original” and re-address, and so far it hasn’t shown evidence that it will clean up the intermediate drafts automatically. And I also don’t want to be prompted to save a draft. 

It sounds like we favor different approaches. eM Client’s is not for me. Again, it’s too bad, because so much else about the program is excellent! But this is something I bump into dozens of times a day.


  • Jason

Only been trialling eM Client for a short while but not being able to finish an email on my laptop, which I started on my phone (gmail app) is a real pain. It’s disappointing to see it hasn’t been resolved after a few years. 

On the other item noted, I have sent emails and still seen multiple draft versions left behind, which is really a disconcerting mess.

I think this is a common error, that the user assumes they could edit the draft in the preview pane. You need to double-click on the draft to open it in an editable window.

These multiple drafts seem to appear with GMail more often than other email providers, but only with a few users.

I tried to reproduce it recently on IMAP accounts with GMail, and GMX. These were all new accounts with default server settings. I was not able to reproduce it. Sorry, Angie, I know that doesn’t help you. :frowning:

Thanks Gary.

The ability to edit drafts is really the most annoying thing.

Then again,  selecting “forward” to edit, the old “draft”, or any lingering undeleted drafts, appear in the conversation thread, causing confusion (and sometimes alarm!), so guess that can be just as annoying :slight_smile:

5 years later and the issue is still here. I just installed the program and have the same issue. On 1 gmail account it’s fine. On the other, drafts are not editable. In fact, I have a draft that in EM client shows up as sent and is in my sent folder, while if I log into gmail the draft is not sent, not in sent folder. Not a good experience so far which is disappointing. I guess I’ll keep looking for a good Windows email program

If it matters, the 1 gmail account which is fine is just a normal gmail account, while the 1 with the issue is a google suite business account

I think that the issue might be the GMail implementation in eM Client, and not eM Client in general. With my provider (not GMail) I do not have this issue. :slight_smile:

That may well be, but for a product that touts itself as having “Support for Gmail, Exchange and others” on its overview page and “Full Gmail Sync” on its comparison page, and in general marketing itself as “Best Email Client for Gmail”, I think we should expect better!

I am a Gmail user and I didn’t see this issue.  For many released, the draft feature has worked just fine.

I tried an experiment:

1.  I created an email in eM Client and saved it as a draft.
2.  Opened the email from the drafts folder in eM Client and it was editable
3.  I opened the draft in the gmail web client, it was editable and I made changes.
4.  I then opened the email in eM Client and changes were there and it was editable.

So, it appears that all is working OK…  Then it got weird.

The next time I went into the drafts folder in eM Client, the draft WAS NO LONGER EDITABLE???  Huh???  It is still editable in the web client. This is new behavior.  I will open a support ticket on it.

OK, I submitted the ticket, I’ll let you know.

Strangely the issue fixed itself as I was following instructions from Support for gathering logs. They had me repair the All mail folder in the affected account, which resynced everything and seemed to have fixed it. You right click on All Mail, properties, then repair. We’ll see if the issue resurfaces

I have a draft and I have double-clicked the word draft.  When the draft comes out I have double-clicked it. Still it does not come out to be edited. It does ask me if I want to delete the message. Outlook was so much easier.

Any news on this issue? It’s been a few years

If it is for a Yahoo! account, it is actually a server problem. I gave the solution in another post, so check that out. It should work for other providers as well, if they incorrectly remove the draft flag from the messages in that folder.

Thanx for the answer, it worked! In this case it isn’t for a yahoo server, but for Microsoft exchange which my Godaddy account recently made everyone switch to. So your solution seems pretty solid. Given that this issue might be widespread, maybe the em Client folks might add a check box or something to the settings that accomplishes this bit of text.

1 Like