Cannot sync with Google

This has happened several times over the past couple of years where all of a sudden my emClient no longer syncs with Google in either direction. This applies to email, contacts, tasks, and calendar.

I am using version 8.2.1473 (04b618f), and everything has been working fine except for this intermittent issue of failure to sync.

I have rebooted my PC, and that fixed it one other time, but this time it has no effect.

I know I could upgrade emClient, but every time I upgrade I run into new problems. It has been working fine with this version, except for this new event of failure to sync.

Is this a POP or IMAP Google account?

It’s IMAP. I just checked again. I can send an email to Gmail and then send one from Gmail and they both show up in emClient. Contacts and Calendar do not sync, however.

I would suggest to then first “Close eM Client” and then go to your Google account / Security" “Third party apps access” section online near the bottom and “Remove your eM Client OAuth token / program”. So in my example screenshot below, I would remove both eM Client OAuth tokens.

Then reopen eM Client and you will get a Google message popup in your browser to "Re-Allow eM Client access again to your Google account. Click allow & should then fix that problem.

Failing that remove and re-add your Google IMAP account in eM Client which will then also normally fix the issue.

If you do have to remove and re-add your Google account in eM Client, it will take time to re-read all your emails again depending on the size of your mailbox till they are locally cached.

Also before removing and re-adding your Google account, backup eM Client via “Menu / Backup” and you can see when it’s backed up via “Menu / Operations”.

1 Like

Well, this didn’t go so well. I followed the directions to remove eM Client under Security. When I reopened eM Client, I did not get any message popup in my browser. I went back to Google, and it does not show eM Client anymore, and I don’t see any way to add it back again.

I closed and reopened my browser, and then I got the message popup. I said to allow eM Client, and then I got a popup in eM Client with the heading, " Password required for my Gmail address." Then right under that the message, “This operation may take quite a while to complete. Please be patient.” What is their definition of “quite a while?” At what point do I cancel?

I did not remove my Google IMAP account. All I did was take away access and then allow it again.

“This operation may take quite a while to complete. Please be patient.” What is their definition of “quite a while?” At what point do I cancel?

Try setting “a different browser” as the default and try again. Check as well that the browser is not in the background so toggle around to check its not asking you something else as well which can be why it’s not working when you click allow. Also reboot your computer after changing your default browser incase it’s an os issue.

Failing that if changing to a different browser still won’t work which normally does, then you have some sort of computer issue doing it that way, so will need to then do the other option of removing and re-adding your Google account.

I downloaded the Chrome browser and used that and it’s working again. I had preferred Firefox, but I’ll keep Chrome for eM Client.

Thank you so much for your help!

It is only needed for the account authentication after removing the third party access permissions, as it may have something to do with your browser settings in Firefox. Once everything is working, you can go back to your preferred browser.

oh, good to know. This has happened quite a few times where eM Client stops syncing with Google, but usually if I reboot my computer it fixes it. Just this time it didn’t, but changing the browser worked a charm. Thanks again!

1 Like

Changing browsers didn’t make any difference, nor did I think it would. I have already added 18 accounts using my default browser, Chrome, before trying to add another Gmail account today. But, for the sake of argument, I set Edge as my default, then tried Firefox, results the same, so browser is not the definite answer.

Also tried to uninstall and reinstall eM, that didn’t help either and now I’m stuck and unable to add any emails, so I went to the backup.

Also uninstalled my anti-spyware and disabled Windows Defender and made sure there are rules in my firewall to allow all connections from eM, although this is a useless because as I mentioned, I already had 18 accounts I successfully added manually.

Okay, so it’s almost a month later, and the same thing has happened–eM Client has stopped syncing with Google. Do I have to go through that whole thing again by removing account access? I had already switched to Chrome as the default browser, so I’m not sure what to do at this point. It’s so frustrating that this keeps happening.

1 Like

I have the same issue today Jean. Frustrating it is. I am on Chrome, have always been, but never had the issue before. The only thing that has happened this morning was my AVG Free updated.

Completely disable AVG and see if there is any difference.

Gary, I’m sorry you’re also experiencing this frustrating glitch! I don’t have AVG, but I disabled Norton 360, refreshed eM Client, but still no sync. I then completely shut down my PC (that had worked in the past), rebooted, left Norton disabled, but still no sync. Let me know if you can think of anything else to fix this. Thanks!

Mine is working again:

  1. Removed eM Client access to Google
  2. Changed default back to Firefox from Chrome - allowed access to eM Client
  3. Rebooted computer
  4. Sync did not work
  5. Removed eMClient access to Google
  6. Changed default browser to Chrome
  7. Launched eM Client. Allowed access to eM Client
  8. Sync worked one way–I could enter event in eM Client and it synced to Google calendar, but event entered into Google calendar did not show up in eM Client.
  9. Tried rebooting again. eM Client syncs both ways with Google calendar again.

Thank you Gary, apologies been out with family whilst waiting for my weekly scan to finish.
I disabled AVG, closed eMClient, reopened it, refreshed sync, all working spot on.
I then enabled AVG again, and lo and behold, all working and syncing as it should.
Thank you and appreciated for your help.

Well done Jean, good to hear and well done, as Leader Gary suggested, I disabled AVG, closed and re-opened eMClient, sync worked on refresh, now still working even though enabled again. Thank you.

I am so frustrated with eM Client right now! Just 19 days ago I had this same problem, and here it is again. My Google calendar is not syncing with eM Client. It keeps happening over and over again. I removed permissions, changed my browser, re-allowed permissions, rebooted, and still no sync of my calendar. I have already missed an appointment because it wasn’t syncing. Is there anything that will permanently fix this problem?

Last time I had the issue, changing to a different browser worked, but this time it did not, and I can’t get my Google calendar to sync no matter what I do.


My Google calendar is not syncing with eM Client.

Try repairing Google Calendar as per my post at the end of the following Thread.

Sync gmail calendar - em Client - eM Client