Cannot connect to exchange server

Hi, after installing new version of eM Client, I am still unable to use my exchange account. I am now able to set up exchange account(which was not possible in previous version due to connection check) but eM Client has problems connecting to it. Windows 8 mail client works just fine with minimal configuration required. Any suggestions what might be causing this? Thanks.

1 Like

Hi, how did you try to setup the account? Did you use the automatic setup?
Can you try setting up the account manually by switching from the automatic setup tab to the mail tab and selecting exchange while setting up a new account?

Thank you,
Paul.

Hi, I used Tools/Accounts menu and entered info manually as you can see in screenshots. I was not using automatic setup.

Hi, can you please go to Tools > Settings > Advanced, and turn on Exchange Web Services logging for the account?

Save the settings, restart the application and when you receive the error again, can you please go back to the advanced settings window and click on “Send Logs”, please add my email as a copy (mcgregor@emclient.com) and add a reference link to this forum topic.

Thank you,
Paul.

I just did it as you instructed, hope it helps… Thank you

I have exactly the same story as Mr. Fiala, above. I hoped the new version (6.0.20514.0) would let me connect to my company’s Exchange 2007/No Service Pack system, but so far no luck. I wonder if em Client still depends on finding “Autodiscover”, which my company’s Exchange version does not support?

The relevant part of the Operations log is:

5:39:58 PM Sabre Mail 3 [Exchange Web Services] MailExceptions.ConnectionException: Couldn’t get server version.
5:39:58 PM at MailClient.Protocols.Exchange.ExchangeFolderSynchronizer.b__0(WorkerStatus param0, CancellationToken param1)
5:39:58 PM at MailClient.Protocols.Exchange.ExchangeGenericCommand.Execute(WorkerStatus status)
5:39:58 PM at MailClient.Protocols.Exchange.ExchangeGenericCommand.Execute(WorkerStatus status)

I note that the standard Android mail client on my tablet connected to this server easily, within seconds. Any suggestions will be appreciated! Thanks.

Hi, if you have trouble using the autodiscover feature with your exchange account you can try setting up the account “manually”, just switch from the automatic setup tab to the mail tab in the new account setup window, and click on the exchange option, then proceed with the steps, maybe it’ll help, let me know if it does.

Thank you,
Paul.

Now I just found out that message containing logs is still sitting in my Outbox. No idea how to send it, should I report another problém for this? I am sending you the log files from webmail for now.

At the risk of wasting space and your time, I have 2 things to say:

  1. I WAS using manual setup, giving it the same server address and other parameters that work in other mail clients.

  2. However, today I find that the Exchange server is having problems of its own, and other clients don’t connect either. So, I cannot say for sure that I have given em Client a fair test, and I withdraw my original comment until further notice!!

Thanks for taking the time to reply.

Hi, ok let me know if your client works when the server issue is considered fixed, or if not we can take a further look at the issue.

Thank you,
Paul.

Hi. I have exactly the same problem than Patrik. When I configure my Exchange account in Android or Windows is working perfectly (by the way, in these cases I enter also “domain” in the configuration),

Hi, I think you could use the “manual” setup for your Exchange account.
To do so, please create a new account, but instead of using the automatic account click on the mail tab under the automatic setup window and select Exchange, proceed with the steps.

This way, you should be able to enter the domain etc.

Thank you, hope this helps,
Paul.

Hi Paul, thanks for your answer. Unfortunately, I alredy used “manual” setup as you suggest and there is no way to enter domain, what I  could see.

“GENERAL”

  • Account name
  • User information: name, email
  • Authentication: Login name, password

“MAIL, CALENDAR, CONTACTS”

  • Server
  • Authentication: use identity credentails, Use these credentials (User name, password)
  • Delegation

Some more ideas? As I said, I do not have any problem with Windows 8 neither with Android when configurating my Exchange account.

Thank you!

Hi, these settings (that you mentioned) are visible after the setup, the option to enter domain is when you setup your account from scratch using the Exchange setup under mail tab, without using the manual setup.

Can you please check if you’ve setup the account this way?
Thank you,
Paul.

Hello, I have tried again to connect manually to an Exchange server that is known to be working.  I use the same server address and other information that work immediately in other clients including e.g. the standard Android 4.2 mail client on my tablet.  The connection consistently fails with the operations log saying:

1:00:26 PM Sabre Mail [Exchange Web Services]  MailExceptions.ConnectionException: Couldn’t get server version.

The mail server is running Exchange 2007 with no service packs.  I am on eM Client version 6.0.20154.0, running Windows 7 Ultimate 64 bit.

Any suggestions will be appreciated, thanks.

For what it’s worth, I solved the problem today using the webmail access URL as the server address.

I had this problem all night last night, using all the standard settings. This morning, I looked through all the account settings in Outlook, trying different servers. In the end, using the WEB ACCESS URL (in my case mailXX.myoutlookonline.com, where XX is 2 digits) worked. That is the same address I use to log into my webmail, and using it as the server address in eM Client is works. eM Client automatically added /EWS/Exchange.asmx to the server address.

In Outlook, go to Account Settings, select the Exchange Account, then Change > More Settings > Connection > Exchange Proxy Settings, and find it under “Use this URL to connect to my proxy server for Exchange:”

Good luck.

I’m really enjoying eM Client now that it works, but almost gave up on it permanently because of this problem.

Thanks for the input.  Unfortunately, not working for me.  This is an old-school Exchange server version and setup, no mention of Outlook.  Web access is through “OWA” and the server address that works in other clients beside eM Client is "https://owa.XXX.com/exchange/".

For interest I tried manually setting up an “Outlook” account, instead of an “Exchange” account, but no joy whatsoever.

Technically, that’s the same as my webmail url (owaXX… and mailXX… go to the same place).
Have you tried “owa.XXX.com” without adding /exchange/ at the back-end? I assume you have, but just in case.

I think I had tried that, but just tried again using only “owa.XXX.com” and also “owa.XXX.com/owa/”.  Always fails with:

“3:41:55 PM XXX Mail [Exchange Web Services]  MailExceptions.ConnectionException: Couldn’t get server version.”

I know practically nothing about this, but my suspicion is that eM Client is relying on using EWS functionality, and that is not present on this server?  I know that an Exchange interface applet I have previously used successfully (Davmail) will use EWS or some other method, whichever it finds available.

Thanks again for being helpful, I appreciate it!

Hi, unfortunately we only support Exchange server with Service Pack 1 and later, so that’s probably the reason behind your issues.

I’m sorry I couldn’t be more helpful,
Paul.