Cannot add/change Mail Signature

Hello there!

I don’t know if I run into this error since the last emClient update or the Windows Update (we can blame them if you’d like) but I cannot change or add a signature anymore.

In Settings > Email > Templates and Signatures (translated from German) when I click on Signatures… I see my Signature but when I click to edit it (or add a new one) the programme crashes.

Anyone else run into this problem (maybe try it out on your computer) or know any fixes for this?

Thanks already!

I don’t have this problem with eM Client 8.0.3385.0 (German) and Windows 10 Pro version 2004, build 19041.450. If you can’t add or edit the signature, can you delete it, save/quit, and then add it again? Maybe there is something strange in the signature itself? Just a guess.

Well, not so great. Against my better instinct I tried that, was able to delete my ‘old’ signature and now cannot add a new one - emClient still crashed everytime I do it. I have Windows 10 Home edition (where do I find the build?) and em Client 8.0.3318 (1a4785e) (German).

You can find the Windows build in settings, system, info. What if you install the latest eM Client version 8.0.3385.0 from here:
Maybe the eM Client update fixes the problem.

I just updated it - unfortunately no luck!

I found out that emClient doesn’t totally crash, so when I press Alt+F4 I can access the programme again and close the options. However, I still cannot add a signature.

I tried turning off my Firewall/Defender because I thought maybe my system blocks a pop-up but that didn’t do anything…

My Windows build seems to be 19041.450

I hesitate to give your more advice now; don’t want to make things worse. :thinking:
I only found this: cannot modify signature
Maybe there is something strange in the window position/setting and you can make it work as described in the linked post using the keyboard.

Do you have any errors recorded? menu /operation/errors?

Hey, wel, it’s definitely the same thing as described in the other post. However, pushing alt+arrow down+arrowf left+enter doesn’t seem to do anything on my system… so I really don’t know how to make that 'hidden_ window appear. Hmm…

I wanted to check that but my emClient is in German and I clicked through everything in the Menu and just couldn’t find the ‘Operations’…

It will be the fourth item from the top in the main menu (Operationen …).

Ah thank you! (That has a very different name in German haha). It says that there are no errors detected…

I believe it might have something to do with me usually having two screens connected and the window still being on the second screen I don’t have anymore :confused:

Strange! So, with one monitor connected to your PC, does the problem go away?

Was the second monitor a wireless display?

Try going to Windows/system/display and check the settings.

No, the error doesn’t go away. I just believe that because of what the other guy wrote in this thread: cannot modify signature

Problem is I have my second monitor, non-wireless, at home and will not get to connect it in a month

However, the trouble shooting in that thread (pressing alt + arrow down/left + enter) doesn’t work for me.

The settings in the display menu all seem to be OK… THere’s no other monitor available.

The “pressing alt + arrow down/left + enter” may be a red herring! Shortcuts depend on how your KB is set up and won’t necessarily be the same for yours.

I’m surprised that eMC crashes but doesn’t leave any errors!
What happens if you restore eMC? I assume you’ve backed-up at some time?
*Menu > File > Restore


Start with a new database. Turn eM Client off and rename the “eM Client” database folder (default location is in hidden folders AppData\Roaming , the whole path is usually C:\Users\username\AppData\Roaming\eM Client ) to e.g. ‘eM Client old database’. Please note that eM Client must stay turned off during this process.

n.b. Check for eM Client or mailclient.exe in the Task Manager (right-click on windows logo bottom left) and if you see a process with either of these names, end it before you proceed.

Haha yeah I wish I had a backup. I don’t dare to do the Restore…

What happens if I start with a new database? Will it delete some of my files or mails/contacts…?

I just wish there was an option to set back all of the options because I feel that’s where the error is coming from :confused:

I’m not sure how many choices you have left to be honest, especially if you say eMC doesn’t set any errors.

Most of the settings have a button to reset them back to default values if you think that could be the problem otherwise I’ve run out of suggestions other than above - sorry!