Calender Event/Meeting Time Zone Wrong

I know this is a little bit of a repeat, but I think it needs its own topic as it’s mixed in with other topics.

When receive a new meeting request, the meeting is set to the wrong Time Zone.

I’m In Pacific Time Zone (GMT -8) and the meeting always set’s to Chihuahua Time Zone (GMT -7). This has actually been happening for a while now.

I have the latest Version of em client.
I’ve check my PC settings
I’ve check my mobile settings

My email/calendar is set to my business email which runs on Google Apps (gmail / google calendar).
My phone is a Android, set to my account.

Is there a fix for this? Is this a Google issue?

Hi, what version of eM client are you using? (Can you tell me the exact version number from Help > About),
can you please also go to Tools > Settings > Advanced, and turn on Gdata logging for the account?

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    When the issue occurs go back to the advanced settings and click on “Send Logs”, and send the logs to mcgregor@emclient.com with a reference link to this forum topic.

Also can you send me the exported event that has this issue? Or do all of your events have the same issue or just events you’re invited to?

Thank you,
Paul.

What was the resolution?  I’m experiencing something similar.  Accept ics invitation and it is put on my eM calendar off by +1 hour.  Saves to my iCloud and iPhone with the correct time.

Hi Jim, please see my answer below your topic. This issue has not been resolved yet.

Thank you,
Paul.

I’ve got the same (or almost the same) Problem. Whenever I create a new Meeting, I set the times, which are in the correct time Zone (+1). Once I saved the Meeting, I can watch the times Change automatically to UTC. My Computer is set to the correct Zone.

I tried to follow the steps mentioned above, but cannot find the gdata logging in Settings > advanced.

I’m using Version 6.0.20648.0 (when checking updates, there are None available) in German.

Please help me with the issue, for I have already missed a meeting because of this.

Thank you

Hi Maria, please do not submit any data before previously discussing the issue with our tech support line.
What type of account are you using (are you using a google account)? Are you seeing any errors?
Are you sure you have the timezone setup correctly on your server?

Thank you,
Paul.

I’m having a similar problem whenever I import a .ics file. The time zone is set to UTC default, and I have to fix it everytime.

Hi, what version of eM Client are you currently using? Are you sure the events you’re importing aren’t originally setup in the UTC timezone?

Thank you,
Paul.

Using client version 6.0.20899. I’m importing the calendar files from a web site called workmarket.com.

It’s hard for me to tell if they were originally setup in the UTC timezone or not. I can ask their support desk if that would help.

Can you please send me one of the downloaded .ics files to my email with a reference link to this forum topic?
Please send the .ics file attached to mcgregor@emclient.com

Thank you,
Paul.

Email with requested attachment sent.

Hi again, thank you for the received data, the event you sent me should be set in UTC time zone and should start at 21pm, if I import this event into my calendar it is correctly assigned based on my TimeZone, when does the event appear in your calendar and what timezone are you based in?

Thank you,
Paul.

I am in the Pacific -8 time zone. The event appears on my calendar on the correct date, but I have to manually change the time zone from UTC to pacific for both start and end times which is a pain in the neck.

I am in the Pacific -8 time zone. The event appears on my calendar on the correct date, but I have to manually change the time zone from UTC to pacific for both start and end times which is a pain in the neck.

Hi, can you please tell me what time does it appear at? As the event is saved in a UTC timezone, when importing this event into eM Client the time should adjust automatically to 1pm if I’m correct.

Thank you,
Paul.

When the .ics file is opened, the appointment file start and end times display as 9pm UTC.

Hi again, can you please download this release of eM Client and install the update on your computer?
http://www.emclient.com/dist/v6.0.21032/setup.msi

Go to Tools > Settings > Advanced and turn on “CalDav” logging for your problematic account,

  1. Save the settings
  2. Restart the application
  3. Replicate the issue (upload it to your calendar)
    After you do so, please try to run a repair on your calendar folder where this (these) events are located in, right click the folder and select Properties > Repair and click on the Repair button.
    If the issue persist, please go back to the advanced settings window and click on “Send logs” and send the logs to my email address mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul.

I downloaded and installed the version of eM Client as instructed. I do not any any option to enable CalDAV logging however, please see the screenshot I just emailed.

Hi, if the list below your accounts does not have a “CalDav” or some other options (except IMAP and SMTP), this means you don’t have a calendar service setup in eM Client, and you’re possibly using the local calendar. Can you please right click the event in your calendar and select “Show as iCalendar”, copy the content of the source code displayed and send it to my email?

Thank you,
Paul.

I am still having this issue. After accepting a .ics file request. I’ve even done this on my mobile phone and still show’s the wrong time zone. I"m in Pacific (-8) and the meeting request was in same time zone. When checked meeting it says Chihuahua (-7). a hour difference then my time zone. 

Note: When mouse over meeting in calendar meeting shows correct time, but when opened up, it displays wrong time/time zone.
 
I have the latest version of eM Client