CaldDav support for GMX calendar not working

Hello,
I am trying to find a email solution which can handle a GMX email address with mail, carddav and calddav. CardDav and IMAP support for GMX is already working but i can’t set up caldav support for GMX. 

The debug log looks like this:

21:01:08.989|02B|   C: OptionsCommand https://caldav.gmx.net/begenda/
21:01:09.037|02B|   S: OPTIONS https://caldav.gmx.net/begenda/
21:01:09.037|02B|   OK OK
21:01:09.037|02B|   C: PropfindCommand https://caldav.gmx.net/begenda/
21:01:09.067|02B|   <?xml version="1.0" encoding="utf-8"?>
21:01:09.094|02B|   S: PROPFIND https://caldav.gmx.net/begenda/
21:01:09.095|02B|   MethodNotAllowed Method Not Allowed
21:01:09.095|02B|   Response, stream length:
-1, 234
21:01:09.095|02B|   Content:

405 Method Not Allowed

Method Not Allowed

The requested method PROPFIND is not allowed for the URL /begenda/.

21:01:09.095|02B|   C: PrincipalMatchCommand https://caldav.gmx.net/begenda/
21:01:09.123|02B|   <?xml version="1.0" encoding="utf-8"?>http://icewarp.com/ns/"; />
21:01:09.151|02B| S: REPORT https://caldav.gmx.net/begenda/
21:01:09.151|02B| MethodNotAllowed Method Not Allowed
21:01:09.151|02B| Response, stream length:
-1, 232
21:01:09.151|02B| Content:


405 Method Not Allowed


Method Not Allowed



The requested method REPORT is not allowed for the URL /begenda/.




21:01:09.151|02B| C: OptionsCommand https://caldav.gmx.net/begenda/
21:01:09.195|02B| S: OPTIONS https://caldav.gmx.net/begenda/
21:01:09.195|02B| OK OK
21:01:09.195|02B| SynchronizeFoldersCommand executing on ( /01496fc4-9351-4840-b776-5905ef7c9830)
21:01:09.195|02B| C: PropfindCommand https://caldav.gmx.net/begenda/
21:01:09.224|02B| <?xml version="1.0" encoding="utf-8"?>http://apple.com/ns/ical/"; />
21:01:09.252|02B| S: PROPFIND https://caldav.gmx.net/begenda/
21:01:09.252|02B| MethodNotAllowed Method Not Allowed
21:01:09.252|02B| Response, stream length:
-1, 234
21:01:09.252|02B| Content:


405 Method Not Allowed


Method Not Allowed



The requested method PROPFIND is not allowed for the URL /begenda/.






I am using eM Client 7.0.27943.0.
I would appreciate a short feedback. Thanks in advance.

This can help there is something you must give your email adress at the link
https://hilfe.gmx.net/kalender/synchr…
https://hilfe.gmx.net/kalender/synchr…

Hope this help

Hello Lieven,

the article is in German and it seems that it only applies to Thunderbird or the MAC OS addressbook.

Can somebody please help me :-)?

Hey,
The article applies caldav , you askt caldav.
German you can use google translate.
Caldav = calendar, my experience that caldav at most situations are the same i had thunderbird before to.
Hope it works out for you i dont have gmx account

Hello Lieven,

sure I can use Google Translate and when I tried like they explained it on their website it didn’t work with this software.

I hope someone from the emM Client can look into it? I could provide furhter info if needed.

Hello Peter,
I guess you attempted to create the Calendar account in Menu>Tools>Accounts - New Account>Calendar>CalDAV?
Does the account get created or is there any error message? Can you copy the error message?

Hello Olivia Rust,
thanks for the Reply. Yes, I created the calendar account like you asked. The account gets created but didn’t work. I now created the account again and used the following URL:

https://kalender.gmx.net/begenda/dav/your-mailaddress@gmx.de/calendar

Looks like I had a mistake in the URL before. Now I don’t get any erros if I connect but I can’t see any appointments.

This is an excerpt of the log (I can see my appointments in the XML file):

23:14:13.255|022|   C: OptionsCommand https://kalender.gmx.net/begenda/dav/your-mailaddress@gmx.de/calendar/
23:14:13.480|022|   S: OPTIONS https://kalender.gmx.net/begenda/dav/your-mailaddress@gmx.de/calendar/
23:14:13.480|022|   OK OK
23:14:13.481|022|   C: PropfindCommand https://kalender.gmx.net/begenda/dav/your-mailaddress@gmx.de/calendar/
23:14:13.511|022|   <?xml version="1.0" encoding="utf-8"?>






23:14:13.609|022|   S: PROPFIND https://kalender.gmx.net/begenda/dav/your-mailaddress@gmx.de/calendar/
23:14:13.610|022|   207 Multi-Status
23:14:13.610|022|   Response, stream length:
-1, 492
23:14:13.611|022|   Content:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>



/begenda/dav/556cfec8-4417-4fb1-b589-925f1bfe8c6a/calendar/




HTTP/1.1 404 Not Found








HTTP/1.1 200 OK



23:14:13.611|022|   C: PrincipalMatchCommand https://kalender.gmx.net/begenda/dav/your-mailaddress@gmx.de/calendar/
23:14:13.639|022|   <?xml version="1.0" encoding="utf-8"?>









http://icewarp.com/ns/"; />
http://icewarp.com/ns/"; />
http://icewarp.com/ns/"; />




23:14:17.673|022|   S: REPORT https://kalender.gmx.net/begenda/dav/your-mailaddress@gmx.de/calendar/
23:14:17.673|022|   207 Multi-Status
23:14:17.689|022|   Response, stream length:
-1, 135308
23:14:17.702|022|   Content:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>



/begenda/dav/556cfec8-4417-4fb1-b589-925f1bfe8c6a/calendar/begenda-1d82f61415b5f6873d31469b3fab5dcda1528b57.ics


" rel=“nofollow” target="_blank">http://icewarp.com/ns/"/>;



" rel=“nofollow” target="_blank">http://icewarp.com/ns/"/>;


" rel=“nofollow” target="_blank">http://icewarp.com/ns/"/>;

HTTP/1.1 404 Not Found



Birthday Christof

HTTP/1.1 200 OK




I would appreciate a short feedback. Thanks in advance.

Hello Peter,
could you send the full CalDAV log to rust@emclient.com?
Please include the link to this forum thread so I can locale your issue and get back here when we resolve the issue.

Hey Olivia,
thanks for your fast reply. I already send you the requested mail. I will wait for your answer in this thread.

Hello there,
dozens of GMX users are waiting for a solution to CalDAV problem.

Hello Olivia,
it is now 3 months since I send the mail with the requested information. Can you please give me an update on the status?

I would really appreciate a short feedback. Thanks in advance

see gmx

https://sourceforge.net/p/outlookcald…

the awnser is on site from gmx to find to

Same settings for em to i think
https://support.gmx.com/organizer/mob…

was this solved? Have the same prob now with version 7.1

I added my  CalDav gmx account in the  eM Client Version 7.1.30794.0 (free - as I wanted to test it).
The link  I used in the configuration is the same I used in Thuinderbird where it is working. 
It has the format:  https://kalender.gmx.net/begenda/dav/myemaill@gmx.at/calendar/

The wizard accepts everything without an error.

Unfortunately  the gmx calendar to be  synced does not appear. I assume there should be appearing a new one and not the local  Calendar is used for syncing, shouldn’t it?

Here how the accounts setting look like (email is working fine btw)

According to the CalDAV.log it looks to me that the syncing is working!

16:53:48.720|013|   C: OptionsCommand https://kalender.gmx.net/begenda/dav/firstname.lastname@gmx.at/calendar/
16:53:49.133|013|   S: OPTIONS https://kalender.gmx.net/begenda/dav/firstname.lastname@gmx.at/calendar/
16:53:49.133|013|   OK OK
16:53:49.133|013|   DAV: 1, 3, access-control, calendar-access, calendar-schedule, calendar-auto-schedule, ticket
16:53:49.134|013|   Allow: OPTIONS, GET, HEAD, TRACE, PROPFIND, PROPPATCH, PUT, COPY, DELETE, MOVE, MKTICKET, DELTICKET, REPORT
16:53:49.173|013|   C: PropfindCommand https://kalender.gmx.net/begenda/dav/firstname.lastname@gmx.at/calendar/
16:53:49.173|013|   <?xml version="1.0" encoding="utf-8"?>
16:53:49.347|013|   S: PROPFIND https://kalender.gmx.net/begenda/dav/firstname.lastname@gmx.at/calendar/
16:53:49.347|013|   207 Multi-Status
16:53:49.347|013|   Response, stream length: 
492, 492
16:53:49.347|013|   Content: 

<?xml version="1.0" encoding="UTF-8" standalone="no"?>/begenda/dav/f89e3df9-ac02-4734-96fb-8cddcefa3c31/calendar/HTTP/1.1 404 Not FoundHTTP/1.1 200 OK

16:53:49.348|013|   C: PrincipalMatchCommand https://kalender.gmx.net/begenda/dav/firstname.lastname@gmx.at/calendar/
16:53:49.348|013|   <?xml version="1.0" encoding="utf-8"?>http://icewarp.com/ns/"; />http://icewarp.com/ns/"; />http://icewarp.com/ns/"; />
16:53:51.038|013|   S: REPORT https://kalender.gmx.net/begenda/dav/firstname.lastname@gmx.at/calendar/
16:53:51.038|013|   207 Multi-Status
16:53:51.163|013|   Response, stream length: 
71025, 71025
16:53:51.171|013|   Content: 

<?xml version="1.0" encoding="UTF-8" standalone="no"?>...

16:53:53.014|013|   SynchronizeFoldersCommand finished on ( /608f779d-de97-4951-8382-566f8e7b928c)

It just not shown in any calendar!

What I am doing wrong? Or is this a bug??

Is there a solution on that?

I know it was 8 months back but the first link does not work, and the second is for iOS.

Any ideas Lieven?

Peter, in your original post you said CardDAV is working. Can you please supply the account address url you used?

I bought a license of em Client in the meantime. I consulted support and was told to use the different format of the  CalDav address like depicted below.

Change the format:  https://kalender.gmx.net/begenda/dav/myemaill@gmx.at/calendar/
to the different format (obfuscated from my own with random characters):
https://kalender.gmx.net/begenda/dav/a32b7ff4-ac02-4357-43ef-5efbc4fa7c48/

(Unfortunately I do not know how to convert from first to latter.)

At least doing so the calender now is shown in em Client!!

Thanks for that. I also have a ticket in on this issue, so hopefully I will have some solution soon.

OK, the SourceForge link came back online. It is for an Outlook add-on. The text dealing with GMX is of no use.

Any other ideas?