CalDAV and CardDAV icloud Server suddenly says "Unauthorized" after working just fine for years

I only use icloud for Calendar and Contacts and it has worked for many years.  Yesterday, on both my laptop and PC I am now getting “Server says ‘Unauthorized’” errors and they will not sync with icloud.  I investigated both the Community Help here and Apples Forums and nothing works.  

Here is what I tried:
-ensure all settings are correct including icloud login and password
-I do NOT have two factor authentication on so I cannot make an Apple app-specific password
-I do have a very old @me account so I tried using the @icloud address and that did not work so switched back the original
-There are no errors in the message log
-In the Log, it has no mention at all of CalDAV or CardDAV–only syncing email messages which is not icloud
-I check emclient for Updates–none available

So none of the stuff that worked for others is working for me.  Everyone always blames Apple but they never help me or even admit they have a problem, so any help here is appreciated.  Anyone have any other suggestions to try?


even if you did not enable 2-factor authentication you now need an App password to access eM Client. Apple increased security for ALL users, so all users need to use App passwords for 3rd party programs.
This is a quote from Apple support’s newsletter:

Beginning on June 15, app-specific passwords will be required to access your iCloud data using third‐party apps such as Microsoft Outlook, Mozilla Thunderbird, or other mail, contacts, and calendar services not provided by Apple.  

If you are already signed in to a third‐party app using your primary Apple ID password, you will be signed out automatically when this change takes effect. You will need to generate an app-specific password and sign in again.  

To generate an app-specific password, turn on two-factor authentication for your Apple ID and then follow the instructions below:  

• Sign in to your Apple ID account page (
• Go to App-Specific Passwords under Security
• Click Generate Password  

For more information, read Using App-Specific Passwords. If you need additional help, visit Apple Support.  

Apple Support

Never mind–I just found out stupid Big Brother Apple has made Two-Factor Authentication mandatory for third party apps as of–Ta Da–yesterday June 15, 2017 when my problem started.
So it looks like I either have to turn 2FA on and get the app-specific password or stop using emclient.  There are times when I hate Apple. :frowning:

Thanks.  While you were sending that, I found a blog that talked about the 2FA requirement now and posted below.  I bet you are getting a hailstorm of complaints and I am so sorry Apple has done this to you–I love emclient.

Got it: Go to your Apple-ID at and turn on 2-FACTOR-AUTH (via your iPhone). Then, back to Apple-ID on PC, and SECURITY => EDIT => GENERATE-PASSWORD. It gives you a 19-character PW to use in EM Client. Works perfect! Thanks, OLIVIA RUST!!

HOW DO I SIGN IN TO MY ACCOUNT USING AN APP THAT DOESN’T SUPPORT ENTERING TWO-STEP VERIFICATION CODES? You can generate an app-specific password from your Apple ID account page and enter it into the password field of the app that you want to sign in to. This allows you to sign in securely even if the app you’re using doesn’t support entering verification codes. For example, you might use an app-specific password to sign in to iCloud using a third-party email, address book, or calendar app. If you want to generate an app-specific password, sign in to your Apple ID account page. In the SECURITY section, click EDIT > GENERATE PASSWORD.

Also See:

I’m using eM v6 and do not see a request for nor opportunity to use 2FA. Nothing’s changed for me. I just logged into iCloud with my single p/w, no problem. Or is this only a v7 thing?

2 wks ago I did start seeing the pesky “server says unauthorized” msg with email, but I can still send and receive once I dismiss the popup box and calendar and contacts continue to sync with iCloud. I started seeing this 6-7 yrs ago with Outlook so switched to eM to get rid of it but it’s returned intermittently only to disappear on its own after a few days.

What am I doing wrong that I don’t see this Apple 2FA thing?

See below for what I’m talking about. Is this the symptom of the 2FA problem? This comes up every 1-2 min but I’ve been seeing it intermittently for many years. This time it started after I created then deleted a temp experimental email acct (eMv6)and then went back to my primary one after deleting it. You will get this if your email password is wrong in accounts set-up; mine is not since I can still read/send email. I use ATT.  Occasionally I’ve fixed it by changing my ATT email p/w but have not done that yet since that p/w is used in many places so it’s a lot of work.

OK, I just read the link above about creating 2FA with Apple. What I don’t get is this:

eM never prompts me for a password. Where would I enter this?  In CARDAV/CALDAV accounts set-up there’s only one place for a password and for that, I enter my appleID for calendar/contacts and it works fine. What am I missing?

For the IMAP email account, I enter my ATT email password.

ejp, You seem to have the same setup as me–mail by att (which works fine) but Calendar/Contacts syncing via icloud (different login-pw from mail).   But as of yesterday, MY icloud does require the new 2FA CardDAV/CalDAV password and prompts me every time I try to sync the Calendar or Contacts, although I can look at the old updated ones.  Emclient does NOT prompt you for Apple’s 2FA–you have to get a new password from Apple to input.  If you are still syncing with icloud, my only thought is that they are rolling out the requirement over several days, and if you are syncing now you may not be tomorrow.  I personally would wait until it becomes a problem (if it ain’t broke, don’t fix it!).  If and when it does need a new icloud password, you get it from Apple per the instructions above then either enter it into the prompt or you can access it in Emclient under Menu->Tools->Accounts->select iCloud->then I am not sure if you have to enter the new pw under General, CardDAV or CalDAV or all three.  I have not has time to set it up yet, but I hope it will be easy to figure out at the time.

Maybe I’m seeing this problem after all. turns out I am NOT still syncing iCloud stuff. Only mail works, BUT every few seconds I get that non-authentication popup I showed in the earlier email. BUT, I disabled the iCloud or cardav/caldav account in eMC and still get the popup, so I assumed it was from an ATT email disconnect.  I’ve had on my to-do list a full new account creation with rename of the current eMC folder, as I also have a whacky email issue with my IMAP folders replicated over and over, local and otherwise. it’s a mess and I can not do a cleanup either within eMC or Yahoo webmail. Whatever I delete, it just comes back. I need to call ATT and see if they have a “superuser” mode where they can clean up my server folders for me, unless someone out there has a better idea???. Problem is every call to ATT kills a good 45-60min with lots of wheel spinning and little to no progress.

BTW, since you have ATT too, what servers are you using? I can not get att to work, so I’m still using:

Even though the ATT site says replace yahoo with “att”.

Thanks for the feedback!

I cannot comment about getting the popup if icloud is disconnected, but here are two screenshots of my att mail setup.  It works fine most of the time, although sometimes it will not delete right away–but if I wait a few minutes it works again.  I have not had a problem with mass duplication though so cannot comment on that.

Okay, I did successfully turn on two factor authentication from my iphone, got an app-specific password, and put it into emclient, and it is syncing again!  Yay!  The glitch I encountered was that my icloud is SO OLD, I have an old *** domain name for iCloud, BUT a different AppleID for the itunes Store.  I had to call Apple to straighten it out --for 2FA, log in at with the ICLOUD ID and password to get the Emclient password, NOT at the store ID.  They are completely separate and Apple says it will never be possible to merge them (Thanks Apple for making my life even more difficult).  

Margthecar, very helpful posts, thank you.  I’ve resisted two-factor authentication for a number of cloud apps, because I’ve known SMS messages from elsewhere to Australia take literally DAYS to arrive.  This may well be the fault of our dominant carrier, Telstra, which is notorious for clunky systems and making soothing noises without tackling the root cause.

Sigh. Guess I’ll have to try 2FA on my Apple account.  But now I’m wondering if the cost of switching to a more open ecosystem (hello, Google) could be worth it.  I got into iPhones because I like them.  So that meant I got into keeping contacts on Apple’s servers.  Also I love my iPad for work and leisure on the move.  I switched my diary and appointments to Apple also because Outlook kept screwing up time zones and daylight saving.  I could book a call with someone two timezones away, and the time could shift by an hour either way when I wasn’t looking.  Thank you Microsoft.  My basic office apps, like all my clients’, are the MS Office products.  So then I sought and found EM Client because it is one of the very few Windows email apps that syncs with the Apple cloud for contacts and diary.  Essential by this stage, you’ll appreciate.  And I like EM Client, despite the name.

I need a new email app for my iPhone anyway, because Apple’s builtin just won’t talk to my domain and hosting service.  So now I wonder: do I take the moment to just shift all that data to some more open cloud service, with a stable API, easily accessible by third-party apps on my Windows and iOS devices?  So long Apple and thanks for all the fish, lockin is too high a price to pay for your admittedly charming UX?  Hello Google, Zapier and the open systems world?

Anyone else thinking this?

Hah, Iain, I think about dumping Apple every year or so when they do something really arrogant like blackmailing users into 2FA, or absolutely denying a bug exists then fix it quietly while admitting no wrongdoing, or not really supporting products they build for Microsoft such as iCloud Control Panel (for PC) which goes long periods of time not working and their solution is “Buy a Mac”, or simply “not playing nice with MS” by making sure photos and videos taken on an iphone but downloaded to a PC are upside down and do not autorotate the way they do on Apple devices so I have to manually rotate each one, or how there is no batch download of photos from iCloud.    Long list of complaint right?  

Sigh… but what keeps me with my iphone and ipad are that for me I find them to be much better mobile devices than Android phones and tablets.  I have used a friend’s Android phone and found it clunky and I actually have an Android tablet and find it clunkier still.  BUT, at least on the Android tablet, it functions more like a computer–drag and drop files whereas with ipad, you still have to use the awful iTunes to load any media on it.  For some people however, the clunkiness might not be bothersome.  I suggest finding a friend who has a nice Android phone and/or tablet and giving it a test drive and ask them what they like/dislike about it.  Then think about what you are giving up with iphone (we have great iphone family connectivity for example) versus what you are getting with Android (e.g. no more 2FA headaches).  

Just a comment on your text messaging woes and Apple 2FA.  You can specify a landline to get a robocall that reads the authentication code, but not sure if that will work for you.  Once I have logged in once with a code to a device, or  the icloud webpage, it has not asked me again for a code, except for logging into, which asks me for it every time, probably because of the financial information there.  

Thanks, very helpful. I see my settings are the same except I use smtp, not outbound. Will try that, but as you will see below, that error is gone for now suggesting it is associated with Apple and not ATT email.

I’m still not clear on where/how I enter the new 2FA password since my eMC v6 does not prompt for a password. I have that disabled, don’t need/don’t want it. it’s just me at home in my office and when I leave I put the PC to sleep… Is this a v7 thing, or once Apple gives me the 2FA 2nd password will eMC v6 automatically know I have it and prompt for it? Seems improbable.

I disabled my caldav/cardav account (again) and now have not seen that authentication error for 10 min. Unheard of in the last 3 days!  I’m in the middle of an INBOX export, so can’t fiddle with it further to experiment.  My plan was to rename the eMC master folder and create a new account from scratch (start over) to try to fix that error popup and also my messed up folder structure.

Stay tuned. 

I’m trying to set up 2FA on my  iPhone but I can’t proceed till I create a “passcode” for the phone. What is that? Is that the login PIN to be able to access the phone? I DO NOT WANT ONE! Don’t care and it slows me down on getting to the phone. I have no secret stuff anyway. Is this a catch-22? with no passcode I can’t sync emClient?

Also, if I proceed, where in eMclient do I provide the app specific password. I’ve never seen such a prompt or field to enter this in v6.xxxx (most current), just my normal AppleID password.

Thanks for any help.

OK, I have 2FA now and entered the verification code texted to me in password field below. Is that where it goes? I used to put my AppleIDt here and it worked till a few days ago.  Still get authentication error and calendar/contacts not synced with iCloud.

Do I have the right info in the server address field? Unlike in screen shot below, I do have the “use these credentials” checked.

ejp,  I do not know why your way is not working, but on my emclient account I have TWO separate accounts–one only set up only for ATT mail, and a second one set up for icloud contacts and calendar.  I think if you click on New Account on your screen, you can go in and and add an account for icloud contact and calendar only then input your AppleID and special password there.  It works for me in emclient v7.  On v7 I have attached screenshots of my two accounts showing how the ATT mail account only has the mail servers checked, and the icloud account has only the contacts and calendars checked.

ejp, just reread your post–you do NOT enter the texted 6 digit verification code into the icloud emclient password.  Look at the top of this thread and follow Olivia Rust’s instructionos how to Generate Password, an app-specific password, at to use in emclient.  That might be the problem and you do not have to create a separate account at all.  Then again, I like to keep them separate because it is easier to manage the two different systems–your choice.

Ok, thanks, Margthecar!

The way you describe is exactly what I have in my older, temporarily disabled accounts (renamed master emc folder) which worked fine for years (iPhone syncing, etc) . Just for play, I created a new acct to experiment with. I’m about to go back as I don’t trust what I have for the server names for caldav/cardav. 

I’ll try again later today/tomorrow after Father’s day festivities settle down.

Thanks for the reply!

Thanks, Margthecar.  I’ve followed the instructions and got 2FA and a 3rd party password that allows em Client to sync my contacts and calendar.  So the immediate problem has gone away.  It was still a nuisance (you have to do it from a “device” which somehow disqualifies my Windows laptop (looks like a device to me)), but we got there.

I agree, I still like iPhones way better than Android phones.  I have a Microsoft Surface that goes with one of my roles, and it really is a sweet little machine, but still not quite as sweet as an iPad to my mind.

But I seem to be a bit less tightly in the grip of Apple’s One Party State than you.  For example, I use the Dropbox “camera uploads” option on my iPhone to get photos and videos from the camera roll automatically put in a Dropbox folder.  They appear on my PC for further work, no trouble at all.  Right way up and everything, just like a store-bought one.

I just tried connecting my iPhone with a Google account for calendar and contacts, with some test data.  Works, ridiculously easy.  And as I said I need a third-party mail app for my iPhone anyway…

And Zapier, that I use for integrating stuff like MailChimp and my CRM, doesn’t work with Apple.anything (wonder whose fault that is?)…

Apple, you are losing me.  I can feel the magic draining away.

BTW, I don’t have a landline, but thanks for the tip anyway.

Thank you for the helpful info and exchange of views, and the best of success to you.