CalDAV and CardDAV icloud Server suddenly says "Unauthorized" after working just fine for years

ok, thanks, will go back and do that. I enabled 2FA on my iPhone4 (9.3.5) and once I did it kept sending me new/different verification codes. I did not go to appleID.com. Now I can’t get the phone to send me a new verif code, nor can I find the “Password & Security” option in Settings. It appears to be replaced with “Passcode”.  I thought the idea with 2FA was for each login try you needed to get a new verification ric code first?

I believe PassCODE is the 4 or 6 digit PIN you set yourself on the phone.  I believe it plays some role in this, so you must enter the PIN you set yourself to get into your phone.  I think then you can get at Security option in Settings on your phone.  Try it.

VERIFICATION code is the 6 digit number that is texted to your phone if you log into a new device, browser or your at appleid.com.  To get the app specific password for emclient, log into appleid.com (NOT icloud.com) and follow Olivia’s instructions above.  I believe you will be sent a texted verification code to log into appleid.com (after you have unlocked your phone with your Passcode above).  See if this works.

Margthecar, ok, I now have my 3rd party app password. What field in eMC do I enter it into? Apple’s instructions are not clear, saying just enter it into the app’s password field. With eMC there are many.

You say  DO NOT enter it in the password fields below, so where does it go? I know of no other password fields in eMC. Entering it in the General one below still yields the “Server says unauthorized…” error. I’ve always put my ATT email password in the one just below.

You can see I use the method you use but with v6 so the box contents are different.

I know I know.  So many different and confusing passwords and codes.  What I said was do not enter the texted 6-digit verifcation code into the password space.  But now that you have the longer (12 digit?) app-specific password–you enter THAT into the password space.  In v7, just to be safe, I entered it all 3 places:  General, Calendar AND CardDAV and checked Use these credentials.  Then it worked but I do not know which of 3 was actually needed.  Also the app-specific password is long and nonsense, so to make sure I did not mistype it, I copied it to the clipboard and pasted it in the 3 places

Well good luck cutting the cord.  There are days I wish I could.  I will check out that Dropbox sync for photos.  Never thought of that before.  That might be helpful to me.  Thanks for the idea.

Ah-ha!!!  let me try. I remember now the earlier admonition related to the verification code.  I finally have that 12 digit code where I can cut-paste. Took some doing as they won’t let you “cut” if from the Apple site. “Paranoia runs deep”

stand by…

Yes!!!  it’s working! a name added to eMC contacts is on the phone and a calendar entry from the phone is in eMC, i.e.   bidirectional works! Halalulia!

Thank you Margthecar!!! Beers all around on me!

I put it in all 3 places as you did and will now leave well enough alone. I’m not going to tally up the hours spent on this over the past 4-5 days as it’s an insane number.  I’d have gone back to Yahoo webmail in a heartbeat if it would sync with the iCloud. I love the seamless way eMC lets you move between mail-contacts-calendar and I also create large group contacts lists which is easy with eMC.

Now my only remaining problem is multiple nested “sticky” Trash folders I can’t get rid of like a hot wad of bubble gum on your shoe. Somehow I ended up with my entire email acct (folder structure) being nested 4 deep. Between operating offline and from Yahoo webmail I managed to get the acct struct cleaned up on the ATT IMAP server with redundant stuff gone, but now it’s all in my TRASH folder and won’t get lost. It’s all grayed out and when I empty trash, the folders disappear one by one till I’m down to 1, but before I can congratulate myself, one by one they each pop back. It’s like the server just won’t let them go  (hot bubble gum syndrome).  This is probably an ATT issue. If they have a “superuser” admin mode they should be able to go in and do a force delete like with the Windows built-in admin account that lets you delete anything.

How’d this folder nesting thing happen in the first place? I think it’s a result of months ago reinstalling eMC over and over in an attempt to fix another problem which has been reported on this forum: intermittenly eMC will not run because there’s already an eMC subprocess running (can’t run 2 copies of same process at same time). You have to off that first, then open eMC and then quickly cancel the database cleanup process that wants to run, as I think it buggers things up. Anytime I let it run to completion, the whole process repeats with the need to kill the process with Task Manager. Other’s have seen this.

Number of hours spent conforming to the Apple Nanny state:  Insane indeed!

Well, glad you got it to work because I was in the same boat a couple days ago–emclient is the only app I found that works well with att mail and icloud contacts/calendar.  

Hey, on your Nested Trash problem.  I do not have that exact problem in emclient BUT…wait for it…I noticed for awhile o on my iphone that I had about a dozen nested Trash folders there and have no idea how they got there and was annoyed by it. I assume your ATT mail is synced via IMAP to your phone?  So a couple weeks ago I figured out how to delete them on my iphone.  I simply cannot recall if they were syncing to my emclient Trash but if so,  Apple might be the source of your excess trash folders, not (for once) ATT.  

Try this–on your iphone Mail app, click Mailboxes in the upper left corner, then Hit Edit in the upper right corner, scroll down to the Trash section and see if you have a bunch of subfolders.  I think the only one that should be there is Bulk Mail, which I think is what Apple calls the spam folder.  Touch each folder you want to get rid of, and hit Delete Mailbox. Repeat as necessary.

Hit Done, then Select Inbox to return to the normal Mail screen.  See if this cleans up your Trash folders.  

Well…yes and no.  On Trash, I only see this under MAILBOXES

(and all grayed out)

Drafts
Sent
Junk
Trash
Archive 
HOWEVER, next in bold not grayed out are my folders I created by me  in eMC years ago. Including  the full nested struct I had earlier in eMC before my major delete-athon where “I think” it’s cleared up except for those stuck in Trash. I’ll try deleting some of these on the phone and see what, if anything, disappears eMC.

Margthecar, do you know when Apple requires the 3rd party app password to be regenerated or renewed? A new one that is. I"m no longer in sync, but I did the folloowing as a science experiment to fix the undeletable nested folder situation.

I turned off my main IMAP and cal/cardav accounts (2) and created a new POP account thinking it would let me pull all server email down locally (after setting “don’t leave on server”), do my housekeeping, then send it back and go back to the IMAP server. It did not do as I expected, so now I’m back with my normal IMAP and former cal/cardav accounts.

So now, no syncing, however no authentication errors either, which I’d expect to see. Puzzling. 

I do not know for sure if the 3rd party app pws expire, but I did have this experience with helping my husband get his Outlook syncing (which was a whole other brand of digital torture–if you use Icloud Control Panel for PC, which syncs icloud contacts and calendars with Outlook,  turns out Apple does NOT require the 3rd party pw, despite saying on their website Outlook WILL require a 3rd party pw; went round and round in circles for hours).  In the middle of the Outlook mess, we had generated a 3rd party pw for Outlook, then lost it somewhere, so I logged back into the appleid to copy it again and I could not find any way to get at it again.  I could delete the pw, but not recopy it.    It appeared to me you had to generate a new 3rd party pw each time you need one and cannot reuse an old one.  Since it turns out we did not need it anyway, I did not check making a new one, but it makes sense to me from a security perspective that these are one-time-use passwords and you need to generate a new one each time you “reset” your system in a way that requires you to input your password. A pain in the neck?  Sure.  If you don’t like it, Buy a Mac :slight_smile:

As for your nested folders in Trash, I am sorry the deleting Trash folders on the iphone thing did not work.  I really thought that was it because that was what worked for me.  I follow your logic about the POP/IMAP thing and it sounds to me like that should have worked.  Bummer that it didn’t.  I don’t have any other ideas on this front.  Sounds like you need to nag at ATT to see if someone there has an answer.  Good luck.

Thank you for the thoughtful reply. When I did the POP cleanup experiment all indications were it might work as things looked spiffy-clean from that vantage point. But on returning to the main IMAP account, it was business as usual. In Trash, there are now 8 grayed-out seemingly deleted folders just will not go away with an “empty the trash”. It seems with every new attempt one particular set of folders is replicated one more time. Bizarre.

Not sure if I said this earlier in the thread, but while I can be a bit anal and OCD, the reason I’m trying to do this cleanup is not just cosmetic. In the beginning, I think a month ago or so downloading new email became very slow. The headers appear immediately, but then there are little dashed lines floating across the top of the page sometimes for 2-3 minutes per email and not just emails with large attachments. First I thought I have too many total emails in the INBOX but after browsing various forums, I find I’m  in the minor leagues in that regard, so maybe it’s total folder count?. When I take a look in Operations I see evidence of attempted syncing going on in long ignored folders covered in dust and cobwebs and nested 2-3 deep. First, why is it even trying to sync these inactive folders, and secondly, they don’t even belong there, being duplicates of stuff already in Local Folders. Thus my cleanup attempts. Next step is a call to ATT which I’m dreading. Every time I call I say “never again!” as it’s 45 minutes of futility that could have been more fruitfully spent staring out the window.

Hmmm, interesting.  While I do NOT have the ghost folders like you do, and under Operations emclient is only syncing active folders, about twice a week I do experience the 2-3 minute lag in “Downloading message” where the header appears but it takes a good long time for the body of a message to show up.  Also every other day or so, I try to Delete a message and it disappears, almost to instantly reappear not deleted.  This only happens in emclient and not in ATT Webmail or on my iphone.  I have always assumed it was something like a lag in communication between emclient and ATT (really in my head blaming ATT since they never seem to know what is going on).  But after 2-3 minutes it all goes back to normal, with emails loading and deleting fine, so I just leave my PC and go do something else for a few minutes, then come back to emclient when the “lag” has subsided.  If you find out anything different from ATT, I would very interested to know if there is a setting or action I could take to prevent the Lag.

It seems many eMC complaints overlap, and it’s somewhat comforting to hear you see this lag too. Maybe it’s just the cost of doing business.  Many complain of something sorta like what I’ve seen in one regard but with a twist I have never seen. Many (lucky for me) have industrial grade applications with issues I’ve never seen since my use is very simple-one computer, one user. The most exotic thing I do is create long distribution lists from existing contacts, and that always works fine. I’ll keep you posted on developments. Thanks again!

ejp out…

Hi, I have a similiar problem. After synching caldav and carddav in seperate accounts for months (using 2-factor-authentification) with apple and a third-party-password, the synch of caldav does not work anymore and I get the message:

00:19:58 aXXX@XXXX.de [CalDAV]  MailClient.Accounts.ConnectionException: Der Remotename konnte nicht aufgelöst werden: ‘pXX-caldav.icloud.com’ —> System.Net.WebException: Der Remotename konnte nicht aufgelöst werden: ‘pXX-caldav.icloud.com

(The remote name could not be resolved).

What i tried:

  • login to apple ID and revoke all third-party-passwords. However, contacts still sync!?!?
  • create new thirdparty passwords and tried to create a new apple caldav-account in emClient. The error still persists.
  • add caldav to the functioning carddav account (same problem)

Any ideas? Thanks a lot!

To be honest this sounds like I have a separate apple-ID with which I need to create (and once created) a third-party-password. Any idea where I could get this? I only now remember my one apple-ID, and this works fine everywhere. I also see my calender login in to icloud.com with this ID.

Never mind. I haven’t changed anything, except of going to bed yesterday and after I just turned on my PC everything works fine again today.

Hello Lynx,

Thank you for posting it. It was probably a temporary server issue and it was resolved on the server side in the meantime.

Russel

If you are still stuck with this problem using iCloud accounts, use this link to get an “App-Specific password.”

I has nothing to do with eMClient - it’s just the way the service providers work.

2 Likes