Authentication Failing with known Good Creds

Hi
I recently (a couple 3 months ago?) found you guys and I have to say I LOVE your program. I had many clients still trying to hold on to Windows Live Mail and this has been a gift to be able to offer them a way better replacement. I especially love the “You have a POP account would you like to change it to IMAP?” (not verbatim). Importing contacts is normally so easy too compared to outlook (which used to be easy but it seems they’ve done everything they can to make it more difficult).

I used to think Outlook was the cream of the crop but eM Client is so much easier; at least until today. I have a friend at church that does our prayer chain so she may send to 70+ recipients. She is on Comcast and uses their webmail and the messages are received as multiple pages of extraneous code that sometimes it is like a puzzle for those who receive it to even find what she sent within the mess. She’s like most of us and doesn’t like change but I was finally able to talk her into going to eM Client. I usually plug in the email address and then the password and then talk about how easy the setup was compared to fighting with Outlook failing repeatedly.

For some reason today eM Client on this Win10 PC is doing an Outlook re-enactment. Pretty certain I used a copy of em client v8.0.3385 if this is pertinent (tried 8.1 later; no change)

I know the email address and password are correct; I can access the Comcast page with the same credentials. After failing many times she says, “Why don’t you just change the password?”
Logged back into the Comcast account and changed the password. Still had access to the account with new password. eM Client STILL fails to authenticate. I have never had this on eM Client before. Do you have any guidance or suggestions for me?

I attempted the short way first then the long way where I get to specify the server names and it failing to authenticate a valid password is completely unusual. The actual error says “An email server was detected, however your credentials were rejected” Credentials are correct in spite of the rejection.

Thanks

I have the exact same problem coming over from Thunderbird, EM Client will not connect to the server (Yahoo) with the same message you are getting. Did you ever find a solution?

For the Yahoo issue, see if this is any help:

I had same results with 8.0.3385 and 8.1.979 but so far have not tried going backwards to 7.2.50008

To clarify, this issue on Comcast persists with automatic or with manual creds entry. Seems really strange that it fails authentication with known good user/pass… Other users on Comcast work fine in the midst of this one failing…

This can be affected by incorrect settings, specifically the wrong security policy for the port you are using.

These are the pairs to use:

SMTP
Port 587 = Force usage of SSL/TLS
Port 25 = Use SSL/TLS if available
Port 465 = Use SSL/TLS on special port (legacy)

IMAP
Port 993 = Use SSL/TLS on special port (legacy)
Port 143 = Use SSL/TLS if available

POP3
Port 995 = Use SSL/TLS on special port (legacy)
Port 110 = Use SSL/TLS if available

I have the same issue. I’m currently testing em client thinking about switching over from thunderbird. So far I really like it, but I ran into the same authentication issue.
I imported 17 email addresses from thunderbird (where they were running just fine). Now 3 of them give me that authentication error.
The strange thing is. It’s 3 emails where there is at least one same domain email that works seamlessly. Example:
hello@mydomain. com works, the hi@mydomain. com gives me an authentication error
​abc@mydomain2. com works, the xyz@mydomain2. com gives me an authentication error​
dog@mydomain3. com works, the cat@mydomain3. com gives me an authentication error

All domains are from the same provider. So basically most emails are working, 3 of them don’t. I already tried all the given security policy combinations. Credentials are 100% right, because I can log in to webmail.

I’m out of ideas… Any suggestions?

Instead of importing the account settings, why not add the account yourself to eM Client?

Go to Menu > Accounts and add a new account. Enter the email address in the Automatic Setup and that’s about it.

This has the advantage of getting the current best security settings from the server, not what was used in the previous application years ago, as well as adding any other services like calendar, contacts and chat, that the server may offer.

Incorrect settings can also be a cause of authentication failure.

Hi Gary,
thanks for the suggestion. Unfortunately this doesn’t make a difference. Removed it completely and added it manually afterwards. Same problem. Authentication failed.
To keep it simple I will only talk about one address that is not working, although there are 3 of them. What I don’t get is the fact that I added 3 other emails of that particular domain and they all work. I compared all settings, adn the only difference I see is in the IMAP tab. For the three addresses that are working I see:

  • Server
  • Authentication
  • Sync options
  • Tags
  • Special Folders

For the one not working I don’t see Tags.
But other than that everything is identical. Diagnostics always tell me the same. The Repairing action woll always end by telling me that credentials are wrong and if I want to try again using other credentials. But they are 100% right, so I’m stuck here.

Any suggestions on how to proceed?

I “fixed” it. My guess, it is special chars inside my passwords. Are there any known characters that won’t work with em client?

Couldn’t narrow it down to a single character from the passwords I was using, but what could possibly not work are the chars ! / @ * :

I have the same problem with my Comcast account. I’ve been using eM Client for years with no problems. NOW I know my settings are correct and my password is right. I can even get my emails on my iPad, but NOT on my HP laptop running Windows 10. Can you help me? I keep running diagnostics and get the message that there is a server but it doesn’t recognize my password and do I want to change it? No, I do not. Can you help me fix this, please?

Hi Diane
I know the frustration you are experiencing and I understand that you may not want to change your password but it seems to be pretty well supported that certain characters don’t play well with eMClient… scroll up through the list and dbl check the earlier posts (from petzi) for a list of characters to consider going without. Its fairly simple to go to comcast and change your password and its a good idea to do that on occasion anyways.

I have had some positive results with letting eM Client scan and try to fix the connection via the various diagnostics it offers. Sometimes this will work then in short order fail again…

Many clients have no issues others seem to have this problem.

Hoping this goes well for you

Check with Comcast if you need to use an app password. If you do, you will need to use that, and not the account password.