"[Auth] Username and password not accepted"

Since the last update, I keep getting this pop-up. It’s not every check, but it’s more than enough.

Image2

I deleted my GMail account and set the whole thing up again (including the Auth stuff in the Google security settings.)

If I hit “Ok” it’ll work perfectly. I change absolutely nothing.

It’s kinda irritating.

Did you have a POP account manual setup, or default IMAP automatic wizard account setup ?

Both the previous and the new one are POP3

Google have been for sometime no longer wanting users to use POP accounts due to security reasons with legacy user name and passwords. So you should now add your Gmail account via the automatic email wizard IMAP setup which uses a secure OAuth token. Then drag / move all your old POP mail and exiting folders / labels to your Gmail IMAP account.

Once you are confident all your POP mail has been moved to your Gmail IMAP folders / labels, then remove your POP account in eM Client.

Note: Backup eM Client via “Menu / Backup” before doing anything incase you have any problems. You can see when the backup is completed via “Menu / Operations”.

See the following eM Client support page on this.

However if you do want to continue to use POP with Gmail see the following thread below where you can still currently setup an “App password with 2Step (2FA) verification” to allow it to work.

Note:- I would suggest though you change to IMAP as it’s unknown as to how long Gmail will continue supporting POP accounts via app passwords. They could cut it off anytime.

That doesn’t really explain why it was working previous to the latest update from EmClient, but I’ll see if downgrading fixes it. It still works fine in Thunderbird.

… or why hitting the “Ok” on the dialogue box makes it work instead of it just working automatically.

That doesn’t really explain why it was working previous to the latest update from EmClient, but I’ll see if downgrading fixes it.

Upgrading eM Client versions is “no difference in the Gmail POP setup”. It just has alot more features and options etc in the later / newer eM Client versions. As I said the only way to now get it to work under Google’s security policy is with the app password and two factor authentication.

Note: It could have been that your Google account may not have been updated to the new Google policy / rules so still worked the old way. Google gradually changed all Gmail accounts from around March 2022 which affected POP authentication.

It still works fine in Thunderbird.

I’m amazed it’s still working in Thunderbird “if you are still using the old legacy pop username and password” login (without using the Google app password and two factor authentication). That normally fails as per Google disabled that.

Ah, now i see our miscommunication… as said in the first post, i have the app password, etc, set up with Gmail.

If that were not so, it would have stopped working a long time before the last patch.

domingo 27 noviembre 2022 :: 0855hrs (UTC +01:00)

Hey @Lorna_Appleby1

If you prefer to use POP3 read this

Personally I do NOT use Gmail/Google for anything, however, my two daughters insist on nothing else and I have set up POP3 for them

At the moment I can confirm that the following procedure works with eMC v9.1.2109 & v9.2.1222 on Win 10 Pro 22H2 & Win 11 Pro 22H2

Here you can see on Youtube how to use setup - watch a few times to understand what you need to do.
The example is for Outlook but the principle is the same for eMC, I have just checked again.

First you have to make a password for your Gmail account
Save the password to use in eMC later.

Next you must setup eMC as follows
It is easy to do to start:
Menu ->Accounts ->Add account ->DO NOT USE AUTOMATIC ->Click Mail ->Next (Below)
Enter Email ->Next ->Select POP3
Incoming server enter: pop.gmail.com
User name: your email address
Password: what you got from Gmail and saved before ->Next
Outgoing server: smtp.gmail.com
eMC tests what you enter - be patient while it checks
Then Continue WITHOUT encryption
Finally…
On the last screen you can choose to either “Create a separate folder tree for messages” or “Store messages in local folders”. Do NOT forget to choose before clicking finish or you will need to delete and start again. (probably “Folder tree” is best)
Continue to the end following instructions.

Also here is the eMC 9.x new account support setup link for the automatic or manual email account

https://www.emclient.com/webdocumentation/en/9.0/eMClient/Default.htm#Accounts/Create%20New%20Account.htm#kanchor8

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Thank you … but the problem isn’t that the account isn’t working. The problem is EmClient keeps popping up the “It didn’t work” box and all i have to do is click “Ok” to get it to work. I’d rather not have to keep going back and clicking “Ok” every day often.

This is a new problem since the last update of EmClient.

Gmail no longer accept username/password logins, so you will not be able to use it that way.

Please see our announcement here, which @cyberzork also gave above. It describes how to use Gmail with oAuth.

1 Like

I appreciate the help but y’all are making the same mistaken assumption despite correction. :frowning:

  1. The account works. It is set up with Auth0. It downloads email. It sends email.

  2. Every so often it pops up the error message i posted in the first post and all i have to do is hit “Ok.” and it downloads my emails. I change nothing, I just push the button.

  3. When tried in Thunderbird, it downloads my emails automatically without me having to hit any pop-ups. There are no error messages.

  4. This started after the latest update.

My Gmail account is set up properly. I promise.

If the account is setup as POP3, it is not using oAuth.

Do you maybe have the account setup twice, once as IMAP and once as POP3? If so remove the POP3 account after copying the messages to the new IMAP folders.

1 Like

Error Message that pops up occasionally: Image2

The blurred out account is inactive, it’s just so I can set my sent from address. (There’s probably a better way to do that.)

General Settings :


POP3 Settings:

SMTP Settings: (Not that I think it matters)

Operations Log showing it successfully connecting and downloading email.

I didn’t manage to catch the pop-up, but once it errors, it doesn’t try to connect again. (Which is what’s actually irritating me.) This worked without the pop-up previous to the update.

But here’s it working: https://shadowydreamer.com/Email.mp4

I expect this is just an undocumented feature/quirk, and I’ll have to learn to live with it :smile:

Maybe I’m misunderstanding what y’all are saying, but the message I receive from the above thread is POP3 doesn’t work with GMail, and obviously it does.

Anyway! Thanks for all the labour/work. I’ll try a reinstall and see if that helps!

@Lorna_Appleby1

As @Gary advised normally if you are clicking ok it generally means you have “either multiple accounts setup”, or “have the account setup wrong” in some way, or “have some problem with the mailbox authorisation on the server end”.

@skybat advised POP options you can try in that video example (or that POP thread at the top), but “no guarantee that will continue to work” as per Google changes. You would also normally need to remove and re-add your POP account if you try that option in the video or thread.

Also if you do remove your POP account and re-add it to try, create a folder (first) down in “Local folders” at the bottom left called eg: Old Mail and then drag all your exiting POP mail under that. Then once you are confident you have all your email down in Local folders, you can then remove your old POP account. You can then re-add your new account and then drag all your old email & folders to the new account. Good luck.

eM Client as a company also does not support that now with Google Gmail workspace accounts.

As @Gary and I advised "as per eM Client announcement earlier in the year with Google’s changes, you are now meant to be changing to IMAP via the “automatic email setup” with the OAuth token, and dragging / moving all your POP emails to Gmail IMAP account folders.

Thank you.

As said previously, it’s not a consistent problem. I DID set it up per Google changes. (as mentioned several times)

I already removed the account and readied it, as mentioned. I still get the pop-up, seemingly randomly.

This is a problem that popped up AT THE LAST UPDATE,OF EMCLIENT A FEW DAYS AGO. This is not something that is a change with Google.

I appreciate all the attempts to help, but you guys are trying to fix a problem that isn’t the problem. Thank you for the attempts, but I think I’ll just live with the quirk.

If you use the automatic setup, you will not get POP3.

If you use the automatic setup, the account will be setup using IMAP and oAuth. If it is setup like that, you won’t get a password popup in eM Client because oAuth does not use a password in the application.

Please setup the account again following the instructions in the link I sent you. When that is done, move any message from the old POP3 folders to the new folders and finally remove the POP3 account.

1 Like