Attachments received are corrupt only in eM Client

Couldn’t find anything on this topic so, here goes:

Since this morning, I have two separate senders who sent me attachments by email. In both cases, their attachments were corrupt upon saving or previewing. Only when I used my web host’s webmail inbox was I able to open them/view them with no issues.

On eM Client I am noticing attachment.bin in the attachments, whereas they are not there when using web mail.

Anyone else having this issue? A possible explanation or solution? Quite frustrating to have to use another email software to open attachments.

@pulpandpixel What attachment extension format are you opening that is being corrupted in EM Client ? eg: .pdf

Ps .bin files are usually just part of the real attachments created by the senders (mail program). EM Client is just interpreting the senders email and showing you the breakdown of the attachment. Ignore the .bin files.

In one email it was a PNG (other attachments worked)
In another it was PDF, AI (all attachments in that email did not work)

In both cases, when I went to my webmail, they worked fine.

Ok. I don’t have have any issue opening .pdf or .png files etc in (Non Encrypted / Signed emails) in Em V8 for Windows. Check that you have the latest version of EM Client for your OS.

EM Version History (Win / Mac).

I only know there was an issue with corrupted .pdf files in V8 Beta (signed with an SMIME certificate). I believe that fix is in the next update. See thread below on this topic.

I am using the most recent version 8.0.2958 (0a62265)
On Mac OS Catalina 10.15.7 (19H2)

@pulpandpixel There is a later update version 8.0.3494.0 of Emclient for Mac which has alot of fixes. Try that new updated in the release history for Mac.


Tuesday, October 13, 2020

Thank you! When scanning for updates within the program it said I was up to do, so this is helpful I will install now.


Currently running version 8.0.3494 and still getting these errors.

Again, no issue when opening through webmail. Only through eM Client.

jueves 15 octubre 2020 :: 2148hrs (UTC +01:00)

Hi @pulpandpixel

I don’t know if this will help…

I ran some tests on this and was eventually able to open PDF files, however, an issue was as with Catalina you will need to use at least Adobe Acrobat Pro DC 19.021.20061 for macOS

Worked perfectly all the time with local installation of Nuance Power PDF for macOS

No problems with any graphic files

Of course I don’t know if you have an internet ISP issue as receiving a .BIN is only part of the attachment and often indicative of a poor internet connection and cloud link.

The whole thing is strange as I have no problems at all using Windows.

¡Saludos desde la soleada España!



As mentioned previously, this is not isolated to PDF. I also had issues with another email with PNG. And when I check emails using webmail or my mobile, on the same internet connection, there is no issue, no bin file etc. Seems to only happen in eM Client on my desktop.

@pulpandpixel Is the sender of the attachments using Apple Mail ?

Also if you open those emails & attachments in Apple Mail on your Mac will they open ok ?

Hi pulpandpixel,
this is wel known issue with signed e-mails. I can see the smime.p7s file in attachment, so it looks like the e-mail is signed by certificate.
Look for topics related to corrupted attachments in this forum.
Someone has written here that it would be fixed in next version.

Ok thank you, good to know. I did search but could not find what I was looking for. I will stand by for the next version…