Alias name: not just an address as identifier

I have a couple alias addresses I use with my primary gMail account. If I send or respond from any of the aliases directly via gMail online it will let me select any of my aliases AND assign the appropriate name to them, i.e. Bob Jones bjones@gmail.com.

However when I send or reply from one of these aliases via eM Client it only displays the actual address, i.e. bjones@gmail.com, no name as it should appear.

Is there a fix for this?

No one have any ideas?

You can put your name there, too, if you want, but there is a slight problem with accents. For instance, you could enter

My Name Is FJ <alternate@address.com>

into the Alias field and everything would be fine. You would see this in the From combobox instead of only the e-mail address and it would appear like this in the sent e-mail messages. However, should your name contain accented characters, you would need to copy the accented version with encoding being specified from a header of an older message you have sent. As an example, let’s suppose your name is José. :wink: Then you need to enter e.g.

=?UTF-8?Q?Jos=C3=A9?= <jose@server.com>

which looks terrible, but – as far as I have tested this – in mail clients of the recipients the messages will be shown as from ‘José <jose@server.com>’. The downside is that you will see it in the ‘encoded’ form in the From combobox and I vaguely rmember that also in the From field when browsing your sent mail.

Thanks for responding but it didn’t work. I followed your example (the 1st one, I don’t need to use accents) and it immediately returned an error and wouldn’t send.

I guess I’m out of luck.

That is strange, because it worked for me in eM Client v.5.0.17595.0 when I was testing it. It is possible though that I put the name into double quotes (I cannot remember now), because it contains spaces. Try entering something like

“My Name is FJ” <alternate@address.com>

We are currently working on the fix for this issue so you can expect it in one of the next updates.

Great, thanks for the update!

Hi! I still get no names shown when sending from one of my aliases using Version 6 beta 2.
Is this supposed to be one of the next updates mentioned 8 months ago?
If you cannot use the names assigned in gmail, perhaps just allow the user to enter a custom name for each alias? Or just use the standard name for all aliases?
This would still be better then showing no sender name at all.

Please fix this for the final version 6 (or even the next beta).
This is a show-stopper for me, without that feature I cannot switch to Em Client, although I like all the other features and considered buying a license.
Thanks!

Hi,

can you tell me what email account service provider do you use?

Jan

Yes, Gmail

But in Gmail it is working fine. Only em client uses no sender name at all for aliases.

This is still planned to be implemented.

Jan

Great! Thanks for the update! And all your hard work on EM Client!

you are welcome.

Jan

I see this was 8 months ago, any update?  I just downloaded another popular IMAP client and it works flawlessly with AliasName in the from field. Of course the downside is that it is hopelessly anemic in all the other areas that eM Client shines.  Still, this is a deal-breaker for me, I’ve got to reply from my name, not email address in the from field, and going to Gmail web-client to do so, defeats to purpose of having a full client on the desktop. 

Hi Eriel, Alias names are currently not a feature, while using aliases you can only use the account name (when replying from an alias the default account name will be used as identifier).
Maybe in future releases.

Thank you for understanding, hope you can manage to use the current settings,
Paul.

Wrong. As you were informed in this other thread it does NOT use the display name from the main account when sending from an alias address. It populates the From header with the alias email address only, with no display name. It’s broken. I’m seeing it right now in eM Client 6.0.21015.0 in Windows 7 Home Premium x64.

Paul, did you actually try it and it worked? And if it worked, what would your Official Rep George Wilson have been talking about in April 2013 when he said you were working on the fix?

Hi again, you’re right the display name setup in Google’s preferences is being ignored when sending a message using the Alias, we’re currently working on this feature for future releases.

Thank you for reporting this,
Paul.

Hi Paul,
I recently bought a lifetime upgrade for eM Client, because in general I am very satisfied with the program.
However, it has been more than two years now since users were asking for this!
Please fix this ASAP now! This is really a joke!
Thanks,
Ruediger

Hi Rüdiger, sorry for the ongoing issue, I’ve reported the issue to the developers and we’re working on a fix for future releases of eM Client.

Thank you for understanding,
Paul