2nd time in three weeks can't receive emails

For the second time in three weeks, my eM Client app (8.2.1473 (04b618f) will send, but won’t receive emails. I get the red triangle with the !, indicating connection failed. The first time this happened, it “corrected” itself the next day. The second time, which occurred yesterday morning, is still present. FYI, my wife’s eM Client (same computer, different user account) hasn’t experienced this. FWIW, my account uses POP3 to receive, SMTP to send, while her account uses IMAP to receive, SMTP to send. My POP3 is a remnant of early eM Client use.

Here’s the log dump:

8:31:20 AM Online state: changed to online due to NetworkAvailability
8:31:20 AM jheyen1@comcast.net POP3 Connecting: To jheyen1@comcast.net
8:31:21 AM jheyen1@comcast.net POP3 Connected: To jheyen1@comcast.net
8:31:21 AM jheyen1@comcast.net POP3 Listing messages: From jheyen1@comcast.net
8:31:21 AM jheyen1@comcast.net [POP3] System.ArgumentException: An item with the same key has already been added. Key: d17a7d23af3a4761b869000051bf9b44
at System.Collections.Generic.Dictionary2.TryInsert(TKey key, TValue value, InsertionBehavior behavior) at MailClient.Protocols.Pop3.Pop3Account.CheckUids(IEnumerable1 uidsList)
at MailClient.Protocols.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
at MailClient.Commands.Command.Process(WorkerStatus status)
EnqueuedStackTrace =
at MailClient.Protocols.Pop3.Pop3Account.<>c__DisplayClass7_0.b__0()
at MailClient.Protocols.Common.AccountBase.RunIfOnline(Action actionIfOnline, Action actionIfOffline)
at MailClient.Protocols.Pop3.Pop3Account.ReceiveAsync(Action1 receivedItem, Action1 completed, CancellationToken cancellationToken)
at MailClient.Accounts.BindingAccountBase.Receive()
at MailClient.Accounts.AccountManager.ReceiveAllInternal()
at MailClient.Accounts.AccountManager.SendAndReceiveAll()
at MailClient.Program.<>c.b__229_0()
at MailClient.Accounts.AccountManager.<>c__DisplayClass82_0.b__0(Object )
at System.Threading.QueueUserWorkItemCallback.<>c.<.cctor>b__6_0(QueueUserWorkItemCallback quwi)
at System.Threading.ExecutionContext.RunForThreadPoolUnsafe[TState](ExecutionContext executionContext, Action`1 callback, TState& state)
at System.Threading.QueueUserWorkItemCallback.Execute()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()
GUIStatus_Exception_Reported = True

If I delete my account, will that automatically delete my wife’s account, under her Windows 10 user account? My account is administrator, her’s is user.

I’m about ready to give up on eM Client, and switch to a Gmail account, unless we can figure out why this receive issue has cropped up.

TIA,

Jeff

I have the same problem, using IMAP to recieve mails. I don’t receive any mails any more, although I can see them on my phone using outlook.
eM client worked perefectly for years, is it possible that something changed following an update?
Lode

Who is your mail host?
Have you tried disabling A/V, VPN?
Contacted your email host to see if they are having any issues?
What version of eMC are you using?
Using Windows 10?
Tried removing email account and re-adding email account?

Sorry for my ignorance, but how can I find out who is my email host?
My email address is lode.schuerman@outlook.com, so is it outlook.com?
I tried disabling VNP, but it didn’t help. What is “A/V”?
I can read my mail online at outlook.com, so I assume the problem isn’t with the host, or am I wrong?
I indeed use Windows 10. The verison of eMC is “8.2.1473 (04b618f)”

I didn’t try removing and re-adding my email account yet.
I was just replying to a mail online (via www.outlook.com) with eMC open in the background. Then I got an error message from eMC that needed to close. It re-opened automatically and the synchronisation immediately started to work. So the problem seems to be solved, although at least one e-mail that I saw online is lost !!! Very annoying that I can’t trust that I am receiving all emails.

I just started getting the same problem this morning - I have two outlook accounts and both are not receiving messages through EM 8.2.1478. This occurred after Apple’s latest security update to MacOS Catalina which was installed last night. I tried receiving outlook messages through MS Outlook client and works fine. It appears there is an issue specific to EM. I tried removing and then adding the email accounts but did not resolve. My Gmail accounts work well with EM.

3 posts were merged into an existing topic: Not receiving Outlook emails

I think Outlook.com is offline. Can you check with them?

One thing to note is that Microsoft treats all non-MS applications differently to their own. So the Mail app is irrelevant in a test. So is MS Outlook.

Is you phone using IMAP, and of so what app are you using?

3 posts were merged into an existing topic: Not receiving Outlook emails