"your message exceeded Google's message size limits"

I continue getting the error message “Your message exceeded Google’s message size limits” even after deleting all sent messages. The error message repeatedly appears. I have been unable to find a way to stop it from re-appearing. I had thought it occurred originally due to having attached a file that was too large. However, nothing I have tried has stopped the message from re-appearing. It is so annoying that I’ve considered returning to Thunderbird. Can anyone suggest a resolution?

David McConnell (davidmc41@gmail.com)

Hello David, if you tried to submit a message with a large attachment please make sure to remove the message from your Outbox by using Shift + Delete, or if you’ve already tried to remove it from the Outbox, check your Trash folder on Gmail and again, remove it by using Shift+Delete to remove the message without moving it to Trash.

If you’ve removed the message using regular delete option, the item is still being uploaded to a server folder, which is not possible due to the large attachment.

Hope this helps,