Yandex IMAP Issue

Hello everyone,

I’m a pro user and I cant get any help -or even replies- from the VIP support area thus I’m asking the community.

I’ve been using eMClient with Yandex email using the IMAP protocol. It was working fine until ~2 months ago. Mail stopped syncing. New mails started not to arrive and client kept working only for 10 mins after restart.

I rolled back to 7x version to check if the problem persists there with a clean install and It was there. 7x version did not work as well. I tried with 8.0.3385 and 8.1.876 and still the same problem. I’ve sent many messages thru the VIP section yet they did not get a response as well.

I also have Outlook and it works flawlessly. No issues what so ever thus I think this is not a server but a client issue.

Any guidance is appreciated.

Best,

Go to Menu > Operations and look for an IMAP error in the Log tab. It may not be useful to anyone on this forum, but there may be some hint as to why it is not working.

Something else you can check is that you have the correct settings for your account. Go to Menu > Accounts and click on the IMAP tab. The port should be 993 and the security policy Use SSL/TLS on special port (legacy).

Another thing you can try is to completely disable your anti-virus/firewall and VPN application and see if that makes any difference.

And of course, upgrading to the latest version available in the Release History as often there are fixes for such things.

Dear Gary,

Thank you for the reply. Here’s a simple debug log.

16:01:24.017|013| AccountBase.ChangeOnlineState : STATE CHANGE TO online due User
16:01:24.017|013| eM Client 8.1.979.0
16:01:24.034|013| >>> FolderActivated(folder: /Inbox [Inbox]): 
16:01:24.049|013| >>> Starting account synchronization
16:01:24.049|005| >>> GetItemStream(folder: /Inbox [Inbox], item: 28061, partName: TEXT, header: False): Start
16:01:24.059|018| >>> ListFoldersAsync(): Start
16:01:24.108|018| 01:   Connecting to imap.yandex.com.tr:993...
16:01:24.627|013| 01: * OK Yandex IMAP4rev1 at vla5-99fd0f3c77d8.qloud-c.yandex.net:993 ready to talk with ::ffff:178.233.57.168:63956, 2021-Jan-01 16:01:23, N1nYfP6S3Os1
16:01:24.648|010| 01: A1 CAPABILITY
16:01:24.750|013| 01: * CAPABILITY IMAP4rev1 CHILDREN UNSELECT LITERAL+ NAMESPACE XLIST BINARY UIDPLUS ENABLE ID AUTH=PLAIN AUTH=XOAUTH2 IDLE MOVE
16:01:24.898|013| 01: A1 OK CAPABILITY Completed.
16:01:24.926|016| 01: A2 AUTHENTICATE PLAIN
16:01:25.039|010| 01: + <Parameter removed for privacy reasons.>
16:01:25.048|010| 01: <Parameter removed for privacy reasons.>
16:01:25.266|013| 01: * CAPABILITY IMAP4rev1 CHILDREN UNSELECT LITERAL+ NAMESPACE XLIST BINARY UIDPLUS ENABLE ID IDLE MOVE
16:01:25.267|013| 01: A2 OK AUTHENTICATE Completed.
16:01:25.287|013| 01: A3 ID ("name" "eM Client" "version" "8.1.979.0" "GUID" "EMCLIENT_V1" "vendor" "eM Client" "contact" "support@emclient.com")
16:01:25.388|016| 01: * ID ("name" "Yandex Mail" "vendor" "Yandex" "support-url" "http://feedback.yandex.ru/?from=mail")
16:01:25.538|016| 01: A3 OK ID Completed.
16:01:25.540|010| 01: A4 NAMESPACE
16:01:25.649|016| 01: * NAMESPACE (("" "|")) NIL NIL
16:01:25.802|013| 01: A4 OK NAMESPACE Completed.
16:01:25.806|013| 01:   Detected server type: Yandex
16:01:25.814|013| 01: A5 XLIST "" "*"
16:01:25.922|010| 01: * XLIST (\HasNoChildren \Unmarked) "|" Archive
16:01:25.922|010| 01: * XLIST (\HasNoChildren \Unmarked \Drafts \Drafts) "|" Drafts
16:01:25.922|010| 01: * XLIST (\HasNoChildren \Unmarked \NoInferiors \Inbox) "|" INBOX

As you can see; I have no connectivity issues with the server. It works as expected. However I’d like to point into a different direction

16:02:32.598|006| 02: A75 UID FETCH 15071 (BODY.PEEK[2]<0.65536>)
16:02:33.155|016| 02: * 14439 FETCH (UID 15071 BODY[2]<0> {65536}
16:02:33.265|010| 02: )
16:02:33.265|010| 02: A75 OK UID FETCH Completed.
16:02:33.275|006| 02: A76 UID FETCH 15071 (BODY.PEEK[2]<65536.65536>)
16:02:33.447|010| 02: * 14439 FETCH (UID 15071 BODY[2]<65536> {65536}
16:02:33.558|004| 02: )
16:02:33.558|004| 02: A76 OK UID FETCH Completed.
16:02:33.558|004| 02: A77 UID FETCH 15071 (BODY.PEEK[2]<131072.65536>)
16:02:33.725|010| 02: * 14439 FETCH (UID 15071 BODY[2]<131072> {65536}
16:02:33.834|004| 02: )
....
16:08:46.269|014| 02: A1208 OK UID FETCH Completed.
16:08:46.269|030| 02: A1209 UID FETCH 15071 (BODY.PEEK[2]<15094395.65536>)
16:08:46.459|014| 02: * 14439 FETCH (UID 15071 BODY[2]<15094395> {1}
16:08:46.459|014| 02: )
16:08:46.611|030| 02: A1209 OK UID FETCH Completed.
16:08:46.611|014| 02: A1210 UID FETCH 15071 (BODY.PEEK[2]<15094396.65536>)
16:08:46.800|024| 02: * 14439 FETCH (UID 15071 BODY[2]<15094396> {1}
16:08:46.800|024| 02: )
16:08:46.955|014| 02: A1210 OK UID FETCH Completed.
16:08:46.955|02A| 02: A1211 UID FETCH 15071 (BODY.PEEK[2]<15094397.65536>)
16:08:47.145|024| 02: * 14439 FETCH (UID 15071 BODY[2]<15094397> {1}

As you can see from the logs; emClient is constantly trying to fetch the body of email UID 15071. I’m not sure what 15094397.65536 means but it looks like it is trying to get bit by bit in an endless loop. As you can see; It tries to fetch 1 email for the past 6 minutes.

My conclusion is as follows;

  1. Yandex is deliberately throttling emClient (or any other client different than Outlook. Haven’t tested it yet)

16:01:25.287|013| 01: A3 ID ("name" "eM Client" "version" "8.1.979.0" "GUID" "EMCLIENT_V1" "vendor" "eM Client" "contact" "support@emclient.com")

Here you are explicity stating that you are a client other than Outlook.

  1. emClient gets into a some sort of debug and tries to fetch a long email bit by bit.

Meanwhile; operations tab does not show anything at all. It just says “there are no operations”. Error tab is also empty. Log tabs says that it is syncronizing Archieve folder.

Any reply to fix this problem is appreciated. I can share the full diagnose log if you want.

Maybe Yandex is biased, I really don’t know, but if you search this forum, issues with Yandex are not something new.

The reason why I said that errors from the log might not be useful to anyone on this forum is that we are all just fellow users here. I certainly don’t have any idea of what the debug log means. Your best bet is to wait for Support to get back to you, or login to the ticket system and increase the priority of your ticket. Support should be back at work from Monday, so wait and see what happens.

Yandex funguje správne napr. v thuderbird, thebat!, outlook! V emclient nefunguje správne vôbec. :joy:

From my own experience of testing Yandex mail servers with eM Client was frustration at the time even with the recommended Yandex settings, connecting / authenticating ok rarely, but even then the mail wouldn’t receive and timed out etc.

Other times I got connectivity port errors & couldn’t connect at all.

I figured the Yandex servers are just “finicky” about what clients connect with as have (no issues) connecting to any other local IMAP ISP mail servers and Global Gmail & Outlook mail servers via eM Client 7/8 or 9Beta.

As @Gary says need logs troubleshooted by eM Client Pro support to determine the issues with Yandex.