yahoo IMAP login failure overnight

I am using the eM client to retrieve emails from Yahoo.  It has been working fine for awhile, in fact it looks as though it was pulling messages up until about 6 am.  Now every time it tries to sync, it gives me a password failure message:


And the log contents:

9:25:04 AM ayavner@yahoo.com [IMAP]  MailClient.Accounts.ConnectionException: 
9:25:04 AM ()
9:25:04 AM    at MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken)
9:25:04 AM    at MailClient.Protocols.Imap.ConnectionPoolEntry.Connect(CancellationToken cancellationToken)
9:25:04 AM    at MailClient.Protocols.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle, Boolean forStore)
9:25:04 AM    at MailClient.Protocols.Imap.ConnectionContext…ctor(ImapAccount account, Folder folder, Boolean forStore)
9:25:04 AM    at MailClient.Protocols.Imap.Synchronizer.SynchronizeFlagsCommand.ExecuteInternal(WorkerStatus status)
9:25:04 AM    at MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
9:25:04 AM    at MailClient.Commands.Command.Process(WorkerStatus status)
9:29:18 AM ayavner@yahoo.com [IMAP]  Synchronizing subfolders: For folder ayavner@yahoo.com/
9:40:32 AM ayavner@yahoo.com [IMAP]  MailClient.Accounts.ConnectionException: 

…and so on.  I have not changed my password (certainly not while I was sleeping) and my known good password works when logging into the browser client (Chrome, latest, if that matters).  I verified the account settings which yahoo requires for downloading into mail clients, that hasn’t changed (allow less-secure something or other, escapes me now but I can go back and look).

I know Yahoo is pretty flaky anyway, and I absolutely loathe it.  Unfortunately I’ve had this account since mid 90s (or whenever yahoo started) so it is impractical to move to another service.

Hard to tell from the message above which entity is refusing the connection - is it even making it to yahoo?

Hoping its not just me, any tips?  thanks!

Adam

I am experiencing the same thing. Tried everything…no change.

Exactly the same for me.
I can login to Yahoo Mail through the browser so it’s not the login to Yahoo causing the problem. 

This has happened to me many times in past but seems to go away on its own. Cannot find a reason. Even reboot does not solve issue. I even resorted to uninstall/reinstall.Either eMClient responds with solution or I will be moving to a different handler.

Yeah same here - i’ll give it a few days.  Knowing Yahoo, probably on their end - they seem to enjoy changing things that no one asked for and making it worse each time.  Was actually not half bad back in the day…  they seem to be pushing this new turd of an “updated mailbox” really hard, which I’ve resisted thusfar…

Maybe there is something wrong over at Yahoo. Did anyone think to contact support?

Not yet, given historically they have never solved nor even responded intelligibly to a single issue… 20+ years with them.  But yeah like i said, probably at yahoo - mainly wanted to make sure it isn’t just me.

I did do a quick wireshark trace, and I can see the handshake attempt, but not seeing what happens beyond that.  Been too long since I messed with that stuff :slight_smile:

Not contacted support.
Seen the problem a few times in the past - usually sorts itself out after a while.
Have tried a couple of reboots to no avail.
Can get by for a while using Yahoo in the browser or on my phone.

I stand corrected - this on the yahoo support community:

https://forums.yahoo.net/t5/Known-issues-and-updates/Unable-to-access-emails-on-Mail-apps/td-p/45645…

Well spotted Adam.

Sound good - thanks for the update.

I have the same problem and I have to go into Yahoo account on the web and update the 3rd party password so Yahoo will allow EMC to access. I wonder if Yahoo has a time limit on how long that app password can be used before you have to keep changing it.

I think this time it’s on them.  That issue appears to still be open, they ought to mark it as “Solved” when its back up.  For now just not going to worry about it, its the weekend anyway!  :slight_smile:

Looks like its back up and running!

Thanks for the update - I’ll try it in a few minutes.

Yep back up and running again - cheers for letting us know.