Yahoo Drafts Folder - Unable to Delete or Synchronise Content

Hi, 

Since the update from v6 to v7, I have been unable to resolve my Yahoo drafts folder - see image. 

After the update a random email appeared in the Drafts folder. 
The email is not on the Yahoo server side and had been deleted years ago.
I’ve logged into the Yahoo site directly many times before and since.

‘Repair’ folder removes the email for a second then it reappears.

I cannot delete it. When opened it has no content. I cannot perform any other operation except opening it. 

I am using v7.0.27943.0 on a Win10 PC, latest build with all patches applied. 

I access Yahoo via IMAP. Other email access is by POP and the folder is seen to be empty. 

After the most recent update, eMclient now shows three different statuses for the same folder.
This is a bug. I was trying to ignore it but not being able to reconcile content causes me concern, especially with several thousand emails in personal folders. 

Anyone have any ideas how I might resolve this…?

Thanks in advance, Brian

Hello Brian,

We’re sorry for the inconvenience. If you remove the problematic IMAP account and set it up again, it should get rid of this problem.

Regards,
Maurice

Hi Maurice, 

Thanks for the reply. 

I deleted the Yahoo account from accounts.
Restarted the client and PC.
Added the ‘new’ Yahoo account. 
The result was marginally better in terms of folder status but the ghost email is still there. 
(I’ve tried these steps in the past.)

I then removed the Yahoo IMAP server details which made the accounts dialogue lock me out with an error message. This forced me to stop the client with Task Manager.

Restarted the client which triggered the database checker.
9 problems were reported to be automatically repaired.

Final result - see image below. 

I have also installed another client with IMAP access. There is nothing shown in the Yahoo Drafts folder within that independent email client. 

rgds, Brian

Hello Brian,

It is indeed strange that the ghost e-mail is still there after removing and adding the IMAP account. Getting error messages after removing the IMAP server details is however designed behavior, since it prevents the program from connecting to the server.
Could you please also try starting with a completely new database? Even though that will unfortunately require setting the accounts up again. You can restart the database by going to C:\Users\username\AppData\Roaming and deleting the eM Client folder. That will force the program to create a database from scratch. Please let us know how it went.

Thank you,
Maurice

I renamed the eM Client folder with Old as prefix to avoid disturbing a Gb of mail in the personal folders. 

Restarted. Added Yahoo account to eM Client - Email still in Drafts - Folder properties shows 0 emails. Tried repair folder - the email disappears and reappeared as before.

Completely uninstalled the client, deleted the (new) eM Client folder. Restarted.
Downloaded the client. Installed. Added Yahoo. 

Email still in Drafts folder - Folder properties shows 0 emails. 
So deleted the (new, new) eM Client folder. Renamed the Old folder back to normal. Opened client. All back to square one. Email still in drafts as expected.

All indications pointed to something wrong on Yahoo server side. I invoked the Yahoo Email Scanner and that came back clean with no findings.

For some reason eMclient is the only client that can see this email, wherever it is.

rgds, Brian

Hello Brian,

Thank you for the detailed description. That indeed sounds like something’s wrong on the server. If you’d like to verify that, we can check the logs from your IMAP to make sure. Please go to Menu -> Tools -> Settings ->Advanced -> Logging and turn on logging for IMAP forthe yahoo account with this draft e-mail. Please try deleting it again and possibly moving it to a different folder. Afterwards go again to Logging, click on Send Longs andsend them to hester@emclient.com with a link to this thread.

Regards,
Maurice

Hi Maurice,

I am crossing fingers but I think this may have been resolved. I unchecked the option for ‘automatically detect special folder names’ and erased the entry for drafts in the accounts dialogue.

The drafts folder disappeared and a folder called draft appeared (not drafts) as the last folder in the account list. This one I had the option to delete. So I deleted it. Then did a refresh.  

I then rechecked the option for automatic detection. Refreshed. All good. Back to normal and no ghost email.  

One possible conclusion is that there is perhaps some field/naming mismatch, or at least some restrictions on deleting/configuring/moving the Yahoo special folder DRAFTS, which does not apply to the non-special folder DRAFT. 

I hope this is useful for anyone else that’s had the same issue or if you should ever need to recreate it to update the code. 

I’m just happy it all tallies now and that ghost email has gone. 
Thanks for your assistance.

Kind regards, Brian

Hello Brian,

We’re happy to hear that you found a solution, thank you for sharing it with everybody.

Regards,
Maurice