wrong senter email

hi I have an outlook.com main email [email protected]
this is an account on email client and displays the email [email protected] in the create email window.
I also have an alias [email protected] that is linked to the [email protected] account.
when ever I send an email it is showing the sender as [email protected].
if you could assist with how to resolve this I would be appreciative.
cheers, Mark

Hi Mark,
do you have the X among the aliases in the alias window as well? The first email in that list will be usually used first, but you can always manually choose a different sender in the drop-down menu before sending an email.


Or is there a problem even when you set the sender to the first address?

Best regards,
Olivia

hi Olivia thanks for your reply,
I only have the free version of Em Client; the first email added is a gmail account and the second is an outlook one.
the alias that is showing as the sender is not even an account in Em Client.
where is the top window - new email address aliases?
the main outlook account does not even appear to be the sender on emails sent
cheers,
Mark

Hi Mark,
having a free license shouldn’t limit the alias feature at all.
As you can see in the screenshots I have only 2 accounts set up too, but one of them has 3 aliases.
The Aliases window can be opened in Tools > Accounts under the General tab of your account.

Hi. unfortunately i did find these settings earlier and have all the email address aliases set up with the main account. but when i send an email from any of the listed email addresses it still sends from the one of the alias emails (third alias). even when i remove the third alias account from the Em Client settings it is still sending from this account. any further ideas would be appreciated

Hi Mark,
that is really strange. Could you export one of the sent emails into an eml file and send it to me to [email protected]?

Best regards,
Olivia

thanks Olivia, how do i do this? 

also i can go into the sent mail and see that the email has ‘sent’ from the main email address but then when I look at the actual email it shows the sender as being the alias

Hi Mark,
I looked at the eml files and while the one you’re sending is correct even in its data, the received one has lots of clutter added.
It marks that one alias as your main account instead - but I believe this is actually something you must have set up on the server and which overwrites the sender when the email passes through the outlook servers.
Can you try going to outlook.com and in ‘Options > Your email accounts’ check what your default From address is?

Best regards,
Olivia

thanks for this. I went in and checked on the Outlook page and I believe [email protected] is the primary account. Please refer to the two attached screenshots and let me know what you think. thanks

hi Olivia,
I went into these settings again just to double check and noticed something I did not see earlier.
when you scroll down on the ‘your email account’ screen it has the default from address setting.
sorry i can not recall changing this but it explains why mvrussi alias was the sender despite which email was selected.
thanks for your assistance resolving this issue!
Mark

but one other thing, although i have changed the primary email to use in outlook.com, it uses this email regardless of which alias i select? is it meant to change the sender to the alias selected in Em Client?

Hi Mark,
maybe the change didn’t register in the cache? Try removing the account from eM Client and after making sure your default From address is correct, add the account back in?

Best regards,
Olivia

hi Olivia,
i removed both aliases and re-added them, but the sender email is still the main account - russi@outlook,com.au
is this something Em Client should be able to do, send from aliases in the free version?

Hi Mark,
yes, the FREE version should be able to send from aliases. I just tested the outlook alias myself and it works. So there must be some problem.
I’ll need to ask you to go to Tools >Settings > Advanced and turn on AirSync logging for your Outlook account.
Restart eM Client.
Try sending an email from an alias again and when it arrives as a wrong email again, go to the Advanced settings and click Send logs. Change the recipient of the email to me ([email protected]) and add link to this forum topic in the body of the message.

Best regards,
Olivia

Thank you for the logs Mark, but unfortunately we still can’t find the solution to this issue. I see that you mentioned you removed the aliases, have you tried removing and re-adding your whole account again? Other than that, I’m afraid I have no more suggestions for the time being.
Thank you for your patience.

Best wishes,
Olivia

hi Olivia,
yes I have removed and re-added the the whole account and well as the the aliases. this is quite strange but if you think of anything else it could be let me know. thanks 

Hi Mark,
I’m afraid I found the root of this problem, but it is not very satisfactory.
Outlook.com’s aliases can’t be used by any other mobile client or email application, and will be changed to the default ‘From’ address upon passing the outgoing SMTP server, they only work from the Outlook’s own web interface.
I thought my aliases were working because I always chose the most current one which was set as default for some reason.

Sources:
http://winsupersite.com/windows-live/…
https://support.mozilla.org/en-US/que…

Unfortunately this is not something we can fix.

Best wishes,
Olivia

Hi Olivia,
Thanks for this further investigation and identification of the problem.
It is good to know that there is not a problem or a setting and that the issue is from simply not using outlook.com. Perhaps aliases would work using Microsoft Outlook through Microsoft Exchange.
Many thanks for the time and effort you have put into this issue. Hopefully this thread will provide the answer for anyone else facing this issue.
Cheers,
Mark