Wrong sender when replying to a forwarded mail

Greetings,
I’m testing eM Client currently and have got a few questions. One of them is related to the following use case:

E-mails to a public address like info@domain.com are always forwarded to a personal e-mail like bob@domain.com. When Bob wants to reply to such an e-mail from his account, eM Client suggests info@domain. com as the sender, not bob@domain. com. Bob has to change his e-mail address manually everytime.

How can I change the behavior, so that the correct e-mail address is being used by default, based on the account it is being sent from?

If the message was forwarded by the server from info@ to bob@, the address the message was sent to doesn’t change. The message is essentially just moved to another Inbox, so it is still addressed to info@.

When you receive the message in eM Client, and you have an account or alias setup for info@, replying will use that same address. If the message was sent to bob@, then that address will be used.

If you want to reply from a different address, then you will need to manually select that each time from the option in the compose window.

Thank you for your reply.
While it may be correct technicaly, it doesn’t make sense in practice in my opinion.

If Bob wants to reply with/from info@ he can go to that account and send the mail from there.
If he is sending from his account, the sender should be bob@

Thunderbird and Outlook do it that way, so for my own comparison that’s one more point on the “contra” side of eM Client.