windows 7 default em client


Could someone advise me please on how to set em client as my default e-mail programme in windows 7.
In windows 7 under default programmes - set programme access - custom - clicked em client but after closing and then opening again em client is unticked again.



can you go to Tools - settings - general - general and scroll down and tell me if “Make default” button is clickable or not?

with regards

Thank you for your help.
“Make default” button is not highlighted -

then please click on it, it should make eM Client default email program.

with regards

Clicking on it does not do anything - assume it’s something to do with not being highlighted -

Thanks again

yes, my fault - I was confused and forgot what “not being highlited” means…

then please go to Control Panel\Programs\Default Programs\Set Default Programs and tell me if eM Client is marked as “this program all its defaults”

with regards

I have Windows 7 but in Control Panel - All control panel items - Default Programmes - Set default Programmes - eM Client is top of the list and no ther e-mail programme is mentioned -


position of eM client in the list does not determine if it is default or not. Instructions I have sent you are for Windows 7 as I myself run on them.

click on eM Client, on right side there should be big window and under it information “This program has all its defaults”

if not click on set this program as default. Then it should be solved.

In my version the Em Client doesn’t show up in this list.
I’m using W7 64b Pro (Dutch)

Due to this the mailto is not working.

Hi, try to uninstall eM Client completely and then check if any other email client has been assigned as default email client for mailto:

Then try to install eM Client from fresh installer again and write me results.


Hi Jan,

I think reinstalling the software with the risk of losing all settings and maybe even e-mail is a bad idea in my opinion. But I solved the problem myself.
In the registry key “HKEY_CLASSES_ROOT\mailto\shell\open\command” was the default setting “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” – “%1”

I’ve changed it to “C:\Program Files (x86)\eM Client\MailClient.exe” /mailurl “%1” and now it works correctly.

I think this setting can be overruled by the key “HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\shell\open\command”, but I’m not sure about that.


Uninstalling eM Client should not delete your database it is supposed to be done manually, of course I presume that users are keeping regular backup.

Anyway thank you for this investigation, this is actually very valuable information.


You’re welcome :slight_smile:

eM Client is great! However, I’m having similar issues as above, and I can’t get it to work, trying everything you mentioned above. The “set as default” button even lets me press it, but still nothing. Note: I just upgraded from ie 9 to ie 11. Can’t remember if it worked with ie 9.

When I try to e-mail to an address in a document, it grinds for a few seconds, then gives me the Windows error box that says “Cannot perform operation because the default email client is not properly installed”. Now here’s a weird result: I close this box, and the screen starts flickering and it tries opening ALOT (like 80) Internet Explorer windows. I have to restart the computer, forcing termination of all processes. It re-boots just fine. eM Client works fine by itself. I have the program on C:\ (an SSD) with my files on E:\ (large cap. HDD).