Windows 10 will not let me run the setup file

Windows 10 will not let me run the setup.msi file, “contact vendor to check if valid Windows installer Package”, is this a security issue?

Hello Mike,
this is a Windows issue that can happen with any installation file and can have different causes. Some of those include:
Corrupted or damaged file when it was downloaded. - Try downloading the installation file again and see if it work this time.
No Administrator rights in the computer account. - Try running the installation as an administrator (right-clicking on the file should give you this optiion).
Anti Virus blocking the installation. - The installation file can be incorrectly seen as a harmful software. Try disabling your antivirus during installation or add the file into its exceptions.
Windows Installer problem. - Is your Windows installer up to date?

Try these solutions and see if any of this help. Otherwise I’d suggest contacting Microsoft support.


Thanks for your reply. So far not having any luck with this problem.
I have tried downloading file again a couple of times.
Administrator rights - option not shown when right-clicking, I changed the ownership to administrator but no success.
I downloaded the file again with my antiVirus and firewall switched-off but I still get the same problem.
I do not know where to find the Windows Installer to open the wizard and check on version.
At the moment it looks like I will have to abandon upgrading to 7 unless there is a way of getting a .exe file instead of .msi ?

In the box, where Windows tells you not to install em Client, is there a “link” saying  <>?. Click on that and you will find another button .

yes done that but does not install and comes up with the message contact vendor etc. Looks like the MSI is not working, am checking around for solutions liked the regedit one. Sometimes Windows is a real pain …

Strange. i am on W10pro 64bit, all updates installed, Norton Security running. i downloaded the installer “setup.msi”, Norton confirmed that the file was clean and Windows installed it without a hitch.

This is to let you know that I have finally been able to upgrade. I changed browser and used Microsoft Edge instead of Chrome for downloading and running the file from Edge worked fine. So the problem might have been connected to Chrome browser ? Anyhow all ok after much frustration. Thanks all for your responses.

Hello Mike,
thank you very much for letting us know about your solution. Seems the issue must have been with the Chrome downloader.


Mysterious! i never used anything else but chrome to download installer files.