Windows 10 eM Client set as Default Mail, but does not work

I have 2 PCs new setup with Windows 10 Prof and Office 2016 (without Outlook)

eM Client is set as Default in the windows settings and also for the mailto: protocol.
Mailto: works.

If I right click a document to send it as mail it states there is no default app configured:

To execute the desired action there is no email application associated. Install a email programm or create an assosciation in the control panel under ‘Default Applications’ if the applicationis already installed

If I try to send as mail from Word or Excel it states that the MAPI session has been closed:

This error can occure if you try to send a word document as email attachement and the mapi session has been closed so that word cannot connect the mapi session anymore. This error could also occure if there is a problem with the fax configuration.

This is how to correct the error: Restart the mapi email application (f.i. Outlook) or save and close the document and restart Word after your’ve restarted the mapi email client. Word will then recreate a new mapi session with which the document can be sent.

Correct the corresponding error in the fax configuration by checking the settings in the configuration of the fax software and performing the needed corrections.

There is no fax installed… The same problem appears with the built in Windows Mail client

I’ve tried to install Windows Live Mail: With that installed everything works, but only in that client. Allthough I’ve set eM as Default Mail application it creates the new message in Windows Live Mail.

Any help appreciated! Thank you in advance.

Windows 10 u must confirm the PC settings and check if emclient is set as default.
Are you using office 365?

It’s a “Office 2016 Standard” installation and emClient is being displayed as Default Mail Client.

look at this:
I had the same problem, so it works then.


What Knobloch posted indeed works, so I suggest you try his approach.


THANK YOU!!! I’ve already tried the “set default values per app” but the main ingredient was to enable .net framenetwork 2&3
Now it works!

None of the above worked on my pc, or notebook.

Please install. NET 3.5, this should fix it.

Hi Phil
.Net Framework 3.5, Windows Communication Foundation HTTP Activation and Non-HTTP Activation are already installed., as are .Net Framework 4.6 Advanced Services, ASP.Net 4.6 and all WCF Services.  eM Client is working perfectly, it just refuses to state that it’s the default mail client, despite Windows saying it is.