Why is the mail on the server deleted when I delete a message in eM Client?

I noticed that emails keep disappearing from the server and I didn’t delete them.  I finally saw the connection today.  When I delete an email from eM Client, it also deletes it from the server.  The  same thing happens in reverse.  If I delete an email from the server, it is also deleted from eM Client. How can I change this?  I want to keep copies on my server.

Hello Mary,

Please make sure that you don’t use the mail account in eM Client with POP3 protocol.
If you do, you can change the settings in Menu > Tools > Accounts > your account > POP3 to keep copies of emails on the server.

However, I’d recommend setting the account with IMAP protocol.


I’m sort of in the dark about things like this but it doesn’t appear as if I’m using  POP3.  I think I am using the IMAP protocol. Actually, I didn’t set up anything, it was all automatic when I installed it. I took a snapshot of the Accounts screen and I couldn’t find POP3 mentioned anywhere.                      

Hello Mary,

According to your screenshot, your account is configured with IMAP protocol.
Then your emails shouldn’t disappear from the server if you don’t manually delete them. (IMAP protocol reflects the changes you make on the server and on the desktop)

Just make sure that your account isn’t set as POP3 elsewhere.

Thanks for the help - it kept pushing me to find out what was happening.  I contacted my server provider and they said they cannot help because eM is not their program.  She said to look through the options and told me what to look for. 

So, I did that and found it in a matter of seconds!  The problem was because I was synchronizing my email.  Hopefully, this might help someone else who is having the
same problem.  

Your account is set up as IMAP.  This protocol is intended to synchronize the server with your local client (eM Client).  Therefore, if you delete an email in eM Client it will also delete it on the server and vice-versa.  It appears your IMAP set up is working as intended.

If you don’t want the synchronization to occur, you must set up the account using the POP3 protocol.  This way deletions on the client will not delete the email on the server and vice versa.  Unfortunately, you cannot change the account type within eM Client.  You will need to set up a new account as POP3 and then delete the IMAP account.

Wneh you go to add the POP3 account, DO NOT use the automatic setup, but click on “Mail” and then “Other”.  You will have to get the server settings from your email providor.

Also, make sure you check the option to “Leave a Copy on the Server”, otherwise the email will be deleted on the server when you downlad it to eM Client.

Thanks for your input, Jay.  However, the problem was solved by simply unchecking the Synchronization options in eM Client.  I do not have the know-how to set it up myself using POP3 and I sure don’t want to lose all the customization that I have done to get it exactly the way I want it.

I know this is working now because I check every few times I delete something and it’s still there on the server, just the way I want it to be. This is a very nice option to have.

This is a probably not a good long-term solution.  Although by checking those boxes, the synchronization does not occur periodically and at start-up, should you hit the “Refresh” button, it will still synchronize and all of your eM Client deleted messages will disappear from the server as well.

I don’t think I understand that.  If I have synchronization turned off, why would it turn on of I hit the refresh button?

You turned off _ automatic   _synchronization (on start-up, time intervals).  It still will force a sync if you hit refresh (I have tested this).  Really, what you want is POP3.  I still suggest you change.

I really hate the thought of re-installing the program. That means, I have to start all over again.  I’ll give it some thought though. Thanks for your input.  Now it makes sense.  Maybe I should never hit refresh. :slight_smile: