Why is the date hidden when viewing emails?

If the “From” address is super long, it pushes the Date to the right side of the email, into an “out of window” area where it’s often not visible if the email column is set to a standard width of around 80 characters.

Is there any way to fix this? In my mind, the emails should display in the standard format like this:

From:
To:
Date:
Subject:

I think the width of your message preview is exceptionally narrow. Can you give a screenshot please?

I had to remove personal info, but the width is set such that the text wraps at about 80-90 characters of plain text which is fairly standard.

It really only happens when there’s a long From address, such as From “Timothy Patrick Jones - Senior Project Manager, ACME Company” <timothy.jones@acme.zzz>

Seems like in that case, the Date should wrap to the next line.

No, it is not the width, it is the font. You have chosen a very large font so there just isn’t enough space.

By default, the font of the time on the right should be the same size as the time on the left. Then there is enough space for the sender and the time. On my display with about the same width, and default settings it looks like this:

I asked this in another thread, but how did you get the Subject line “Test” to be so big? Mine shows smaller than the toolbar text above it.

Where do I change just the font of the From area? I looked all through the Settings and can’t find it. I have no problem changing the text in the Message Body area, the Message Preview area, and the Folder List area (which I can do either in Settings, or by holding CTRL and scrolling my mouse when hovering over that area – but the From, Date, To etc in the Message Body area does not change no matter where I point my cursor and CTRL-scroll).