Why don't the rules for e-mails work for me?

I’ve created two rules for SPAMs: one of them to eliminate certain e-mails and the other one to send some e-mails to the trash can. I’ve followed all the correct steps to set up the rules, but I still receive the e-mails I put in the “black list”. In Outlook Express these rules worked wonderfully, but in eM Client, in my case, they’ve been a big fail. Can someone help me?

Hi Carlos, what version of eM Client are you currently using on your computer, can you please check the exact version number in Help > About? What mail service are you using with eM Client?

eM Client’s rules can only sort newly received unread email if the message is received to the inbox. Or you can apply the rule manually by right clicking the folder in the left pane and selecting “Apply Rule…”

Thank you,
Paul

Hi, Paul.

The version I use is 6.0.21040.0.

I download e-mails from Yahoo and iG. eM rules almost never work, no matter if is an unread or a read message. Inclusively, seldom I read my e-mails in another way than in eM Client. Besides, the messages I’ve created rules for they are exclusively SPAMs and criminal e-mails, so I never read them, but eM Client always download them and maintain them in my inbox.

I don’t want to apply the rules mannualy, that’s silly. I want a rule that function automatically, as in Outlook Express, for example. If I have to apply “manually” a rule, I can simply delete the undesirable e-mails from the inbox. It’s easier and faster.

Hi Carlos, can you please export one of the messages that were not filtered into .eml file by drag and dropping it onto your desktop or new email, or by using the “forward as attachment” option in eM Client?

Please send the message to my email mcgregor@emclient.com with a reference link to this forum topic.

Also can you please screenshot the rule that should process this message?

Thank you,
Paul

Hi, Paul. 

I’ve just sent you the e-mail.

Happy New Year!

Hi again Carlos, thank you for the received data, could you please navigate to Tools > Settings > Advanced and enable Rules logging for eM Client?

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    when you notice the rules are again not being processed, please go back to the advanced settings window and submit the logs to my email mcgregor@emclient.com with a reference link to this forum topic by using the “Send logs” button.

Thank you,
Paul

Hi, Paul. 

I’ve just sent you the logs.

Thanks.

Hi, Paul. 

I’ve just sent you the logs.

Thanks.

Paul, what about my issue??!