Why does my Sent mail appear in my Inbox?

Why when I reply to an email or even send a new email, it appears in my Inbox? This is very confusing!

I’ve given up on eM and gone back to Mailbird. The lack of support is the main reason, but the quirks have just pushed me over the wall!

Does Mailbird provide better support?

The sent messages are not actually in your Inbox. Rather this is a feature in eM Client called Conversations. A conversation is a group of messages that have been received, replied to, or forwarded. So eM Client will search out the messages and group them making it easier for you to see them all at one time. Some other email clients offer a threaded view, but unfortunately that only includes the current folder. So you will see all the related messages you received in a thread, but not your replies. eM Client will group ALL messages that are part of that conversation NO MATTER what folder they are in. So Inbox, Sent, Drafts, or any folders you have created.

You can disable this in Menu > View > Conversations.

Well, gee…wish I’d been able to find this information in the online help! Calling an email message a “conversation” is hardly intuitive!! I have to admit that I really do like  most of eM, but these quirks are too much. It wouldn’t be so bad if there was a decent online help function. I used to write online help for telecom software so I do know it’s not rocket science, but it IS very helpful.

Yes, the online help (F1) is a little outdated but it does include most features including conversations. It is mentioned all over including Whats New, but mostly it is discussed in Email Features.  If you need help with any of these “quirks” just start a new thread on this forum. Some things are there but it is unclear what they are or where to find them.

BTW, a message is not a conversation. A group of messages with replies is. Just as in verbal communication, when two or more people are exchanging words, that is a conversation.

Hi Gary;

I facing the same issue, even in the view I already disable the conversation view but each of the email I send it will appear in the inbox and now the inbox is getting more and more, what can I do to resolve this issue?

If you login to your email account using the webmail interface for your provider, are the sent messages still in the Inbox?

Apart from removing conversation view and checking your webmail interface as @Gary already advised, duplicates in the Sent folder can also strangely enough also cause emails in the inbox to appear when the eg: email app or program saves a copy of sent email “and the server also saves a copy”. So try also (removing the tick) to “Save a copy of the sent messages” as per below and close and reopen eM Client.

Click “Menu / Settings / Mail / Send” in eM Client. Windows EMC example screenshot.

This is counter-intuitive, if not just plain wrong. If I am waiting for an urgent mail message I keep clicking on the entry FROM that company only to see my own outgoing message. This is wasting time and creating stress. I absolutely do not want my outgoing mail appearing in the inbox when the conversation is, after all, being stored in an appropriate folder.

A conversation includes both sides of the correspondence, so both sent and received messages.

Please disable conversations using Menu > View > Conversations > Disable Conversations.

1 Like

So conversations is not functioning properly. Got it.

No, this is exactly what conversations are meant to do.

If you have a message in your Inbox and you reply to it, the reply is part of the conversation, so will be displayed along with the original message in the Inbox.

Or, if you send someone a message and they reply to it, your original message will be displayed along with their reply in the Inbox. The messages are still in their respective folders, but are displayed together to form a conversation. If you don’t want to use them, disable them.

It may be working as designed, but it is bizaare and illogical to put outgoing mail messages in the inbox flagged as unread mail. I took your advice to disable conversations.

It may be working as designed, but it is bizaare and illogical to put outgoing mail messages in the inbox flagged as unread mail.

That is normal when you have conversation view. Unread messages whether in the inbox or sent box are all part of the same mailbox if you haven’t read them. All mailers are the same I’ve used untill you read those messages.

The only option is to disable conversations as @Gary advised which you have done. I also disable conversation view (though not for this reason), as just prefer personally not to have conversation view.

Hi, I still have this problem, even though I have disabled conversations and turned off ‘save a copy to sent folder’ Thanks for your help