Why can't I restore a backup I did less than an hour ago?

I had to change my Yahoo password, and evidently (based on the number of people asking about it in these forums) emClient doesn’t have a way to update a password. I saw a lot of people suggesting deleting the account and setting up a new one with the new password. I’m sure that’s fine for IMAP, but I don’t use that…so I lost all my old emails.
Of course I made a backup before I deleted everything, so I figured I’d just restore and see what other steps I could take.

System.IO.IOException: Access to the path ‘D:\MyDocuments\emClient’ is denied.
   at System.IO.Directory.InternalMove(String sourceDirName, String destDirName, Boolean checkHost)
   at DbBackup.FormBackup.Restore(String backupFile, CancellationToken cancellationToken)
   at DbBackup.FormBackup.Restore(CancellationToken cancellationToken)
   at DbBackup.FormBackup.<mainform_load>b__28_0(Object a, DoWorkEventArgs b)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

The file is there. I can see it in my file explorer.


I am amazingly mad…I just lost years worth of emails.


It is possible that something is blocking access to the directory. Restart your computer, disable any anti-virus application and try again.

Okay. I’m not sure why that worked considering emClient had just written that file, but I was able to restore.

But I still can’t update the password and access my Yahoo mail to send or receive new mail.
So I either need a way that works to update that password without deleting all my old emails, or a way to export what I have now to a file that I can import to a program that does let me change passwords, such as Outlook. I used Outlook for a long time but it had so many little issues that I wanted something different, which is why I started using emClient…but if emClient has the world-ending issue of not being able to update passwords without losing everything, it’s no good to me.

Can you help, or do I need to start a new topic for the password issue?


Go to Menu > Tools > Accounts and click on the General tab for your Yahoo! account.

In the Authentication section, type in the new password.

There is no “Authentication” section. Screenshot attached.

Yahoo uses OAuth, so when you first set up the account, it pops up a browser window and gets your authentication information. This is, based on the number of similar questions/complaints in the forums, a very well-known and frustrating issue.

OK, so if it is using OAuth, then there is no password. That is the function of OAuth; you can change your password on the server, and don’t need to change it in the email client.

With some other providers, you can revoke the eM Client OAuth permission in their web interface if it is not working. Then the next time you open eM Client, it will re-issue the token.

That’s how I understood it was supposed to work but since I changed my password, I haven’t been able to connect. 
I tried removing the authorization for eMClient on Yahoo and it’s not asking for a reauthorization when I try to connect.

If I ever figure anything out, I’ll pass it along to you in case someone else has a similar issue in the future.

Thanks for your help. At least I got back all the stuff I lost last night.