Which permissions for reading HTML mails

Which permissions in the Internet Explorer security settings do I need activated to display HTML email content? Usually I want to read my emails as plain text but today I received an email which required me to read it as HTML (because the plain text part was a dummy message instructing me to get a proper email client -.-).

My default IE settings are medium/high with selected exceptions (such as the clipboard permission). Which other permission do I need to add to read the HTML part? I didn’t see a “view as HTML” option…

I am on 6.0.20631.0 (same behaviour with the prior version).

Hi, do you have the latest available version of Internet Explorer installed on your computer?
viewing of HTML emails should be automatically enabled unless the address or domain has been blacklisted.

To change the formatting from plain text to HTML, just go to Tools > Format, and change the setting from Plain text to HTML, this option is only visible while composing new email as received emaisl have the formatting set.

Hope this helps,
Paul.

Yes I’m on the newest IE. How do I see that someone is blacklisted?

I wanted to *view* the message, not compose one. If I reply to the message it just pimps the plain text version to HTML. I still need to read the email source to get the actual message.

Since eM Client does not have any automatic spam filter you would have to be the one who blacklisted the email/domain, you can check the blacklisted addresses in Tools > Rules > Blacklist.

Not really sure if I follow on the plain text/html email issue.
If an email is composed as plain text and sent to you, there’s no option to display it as HTML as there’s really no HTML to show, the email will be automatically viewed as plain text, and you can only change the formatting when replying to this email, not while viewing.

Or if you’re having issues with displaying HTML emails can you make a screenshot of the issue?

Hope this helps,
Paul.

Tools > Rules is empty. So no blacklisting here.

I fear the particular email is lost. I try to detail this out. The received message was a multipart mime message with text/plain and text/html mime-types. Usually text/plain and text/html have equal messages so there is no difference which one you display.

But this message had a text/plain dummy instruction and the actual message in text/html. What was rendered by eM Client was the “dummy” text/plain part. There was no choice to display the text/html other than by Context > View Mail Source.

Unfortunately I don’t have the means to re-create the above message or artificial html-only test emails. I hope the details above help you enough to pin down the problem.

Hi, unfortunately this does not give me much information about the issue, but if you ever come across this issue again, can you export the message you had an issue with into .eml file and send it to my email mcgregor@emclient.com?

Thank you,
Paul.

Found it! The settings were on “Read all messages in plain text”

I guess it would be great to have the option “Display message in HTML if no plain text is available”.

Issue closed. Thanks

Hi, glad you’ve found a solution, I’ve discussed the issue with the developers and the reason why the html part isn’t displayed in multipart messages is because when a multipart message is received the plain text content and html content is considered to be equal so when replying eM Client only takes the plain text part to insert into the reply.

Hope this helps, let us know if you come across any other issues or questions, we’ll be happy to help,
Paul.