Where has Compact View gone?

I upgraded to the latest version today, and the layout has changed so that the From email is now displayed in its own column instead of above the message title. I want it to look as it does in the first video on this page:

This appears to be called Compact View, but I can’t find a way to enable it.

As a side-note, I don’t appreciate updates breaking my setup like this, furthermore I do not appreciate having to waste time searching for solutions.

Drag the right-hand edge of the message list frame to make it narrower. Once it is 600 pixels or less, it should revert to Compact View.

Or, you can change it in Menu > Settings > Mail > Read > Message list if you want to change the width specification.