week number

In the Netherlands and also in other parts of EU, we are used to use week numbers extensively.
This seems to be omitted in eM Client.
Is that correct?
Do I miss something?
Will there be addition with that respect in the near future?

Hello Rene,
this seems like a reasonable feature request. I have also forwarded your email to a colleague, who will evaluate your request and let you know.



thanks for the very quick action. Impressive that companies are able to have such quick turnaround time. However:

  • the implementation is not correct. See wikipedia for the ISO-approved week numbering standard.

  • week number is only shown when months overview is active. It would be good to have at at each week shown.

Kind regards,


Hi Rene,

could you be more specific about why the week numbers are incorrect?

Our implementation matches http://personal.ecu.edu/mccartyr/isow…, but differs from Outlook. For some reason Outlook has the weeks off-by-one for current year because it considers the first week to start on 28 December 2009. That sounds wrong to me because 4 days of the week are still in 2009.

The only bug that I was able to find was that week 53 was incorrectly reported in place of week 1 and we have that fixed already.

Best regards,
Filip Navara

pls see: http://en.wikipedia.org/wiki/ISO_week…

We’ve done sw development on this as well, and it is not as easy as it seems.
I know of a program that lets users set the following parameters in combo boxes:
First day of week: (Monday | Sunday) ((which may be irrelevant here))
First week of year: (Contains Jan 1 | First 4 day week | First full week)
So apparently there are 3 ways/“standards” to define the first week-o-y. This reflects the basis on what the calculations should be based upon and is also in accordance with the wikipage.

We are about to order 10 licenses. Before doing so, I’d like to see this feature implemented correctly.

As rene wrote: “week number is only shown when months overview is active. It would be good to have at at each week shown.”

Are there any plans of implementing this?

unfortunately this is not implemented yet. It is on our todo list and you can expect this feature in couple of months.


George WIlson
eM Client

Hello, the problem with the weeks - number is unfortunately still!
1.Ste January 2014 is a Wednesday, but the week will be shown with Nr 52 !!

Version 6.0.19714



Hi, I do see week numbers correctly, can you make screenshot of what you consider as an error and post it here?


We have bought about 20 licenses now.

The comment above cannot be reproduced by me. I see 1-JAN-14 on Tuesday in week 1.

As to no weeknumber, I don’t see why it seems to take almost 4 years to not only shows this:

in the monthly view, but also to show this:

in the weekly view.



we have now 20 or more licenses running at our offices.
It is remarkable that a simple this as a weeknumber in the weekly overview is still not implemented. Al we want is this:

To cope with this, our secretary needs to enter a new event each week on the Mondays that shows the weeknumber.

Btw, the error in the weeknumber calculation cannot be reproduced by me. I see Tuesday 1-JAN-14 in week 1.

Look this screen shoot

I see, eM Client takes it’s settings from Windows, but it looks like bugged (we tested it yesterday), if you would have set German locale in Windows’s it should retain it’s settings.

Anyway you can always repair this in Tools - Settings - Calendar - General, Look into “Work Week” and set first week of year to your desired.


Thank you for your reply. That seems to be the solution.

Regards Tyroler

you are welcome :slight_smile:


But still, when can I see the week number in week or day view??? There is plenty of room for that left…

currently you can see the week number in month view in your calendar, if you don’t see it you have to go to Tools > Settings > Calendar and check the show week number.
Unfortunately it’s not possible to show week number in the week view at the moment, it’s currently a feature request and it might be added in future releases.

Thank you,