Version 9.1 crashes when sending mails

Version 9.1 crashes when sending mails


since the update to 9.1 the emClient crashes when sending mail. The mail remains in the outbox.

The message “emClient has stopped working” appears.

With 9.0 everything works.

What can I do?


Same problem here.
Everything was ok with 9.0.x
Any solution support please ?
Thank you.

I found a solution.
It was a databe conversion problem.
Uninstalling all and installing again and now it’s ok.
I’m using IMAP protocol so i don’t loose my mails.
Possible to make or integrate a tool for database integrity correction ?


After restoring the backup I have the same error.

I then have to rebuild everything manually.

Actually, the manufacturer should fix the error.

Like i said it seems to be a database migration error. What i did :

  1. Exported settings of my eM Client (nameofmysetting.xml) including mail adresses, passwords not encrypted, etc, all things checked.
  2. Uninstall of my eM Client with removing database option (message during uninstall)
  3. Fresh install of las version of eM Client version 9.1.2109
  4. Open of eM Client and cancel of first steps and when it was opened and ok import of my exported settings. Wait few minutes durind importing and checking IMAP accounts and voilà !
    Hope it will help you.

Thank you very much!

I have understood the procedure.

Unfortunately my installation is very complex. With IMAP I get the mails of the last three months. The last 15 years are in the local archive.

I have been exporting my mails for 30 minutes. So far I have exported 40,000 out of 120,000.

Also, I want to test the process on my old secondary computer first.

I have tested it.
The result:
Export and import of settings works fine.

Exporting the mail database works, but takes a long time.

Import, on the other hand, is a problem. I seem to have to import each folder individually into the correct mailbox.

When I try to import a directory with folders, I get

The selected folder does not support the required item type.
Please select a compatible folder.”

I have two dozen mailboxes with 10 to 40 folders each. The same again for the archive. I have a few hundred individual import operations.

This is pretty poorly solved.

Completely forgotten:
Your solution works. I can send mails again.
Thank you!

1 Like

You’re welcome Thomas :wink:

It’s amazing to see that it’s the users who find solutions to the bugs they encounter. eM Client is a very good software but the support is not so good. I think there are more solutions here than on the pro support… In short, it would be nice if the creators of this software invested in support because the more it goes on, the more it’s a pain in the ass. Sorry for the vulgarity :wink:

I don’t know if you knew but there is software to read archived mails. I’ve seen this for Outlook .PSTs because one of my clients uses it. Otherwise why not use a Synology NAS with Mail Station?

I’ve seen this happen with Outlook .PSTs as one of my clients uses them. If not, why not use a Synology NAS with Mail Station?