version 7.1.33101.0 hangs when closing [clicking on X]

eM Client hangs for a few seconds before the window finally closes

This is known behavior. If you use Menu > File > Exit it closes immediately, which is proof that it can be done.

If you have a Pro License, maybe open a support ticket.

Thanks for follow-up.

Yes if I use Menu > File > Exit it closes immediately, which is proof that there is a problem that needs fixing.

Yep, I noticed this problem too since the upgrade.

A three-click workaround is not a solution to what should be a one-click operation.

And besides…it would take as long to do the work around.

Does anyone know the last good version to roll back to without this problem?

As I mentioned before, if you have a Pro License, please open a support ticket so that the developers can check your log files and hopefully fix this. If you have a Free License, then a second or two delay is not such a high price to pay for an otherwise exceptional application. :slight_smile:

Interestingly, I do not see this behavior.

Hi Jay. When I click on the X to close eM Client, there is a delay of maybe a second before anything happens. This does not happen with Menu > File > Exit.

Gary, for me (and yes, I did upgrade to 33101), it takes approx.1/4 of a sec-- too short to really measure.  However, I do note that menu/file/exit is immediate-- no discernable delay.

The Devs see these posts…they know what’s going on and will eventually address it.

For me it’s 5-8 second delay.  If it was a second or less I wouldn’t worry about it and would wait it out till the next version.

Again I ask if anyone used the latest version before this one without this issue…which version#?


As a temporary workaround, right click on the title bar and click on close or choose Alt-F4. It reduced my closing time from 5-8 seconds to around 3 seconds.

I think if the delay you are experiencing is so long, it is not the same phenomenon I am observing.

It is not guaranteed that eM Client staff will read these posts nor that they will pass them on to the developers. Your best bet if you have a Pro License, is to open a support ticket. By looking at your log files, which you can’t post here, they will be able to determine where the problem is and if it needs fixing, get working on that.

Out of interest what type of hard disk is the database stored on? Is it a mechanical disk or an SSD?

I remember a few months ago, when emClient closed immediately, some people experienced corrupt databases, that had to be rebuild at the next start-up, esp. if they shut down Windows right after closing emClient (before the database was written back to HD).
I will happily wait the few seconds, if that means that this allows the database to remain clean and pure.

Yes, I think it was probably after 7.1.30794 that they started working on the incorrect shutdown issue.

Fitness, maybe you can try that version and see if it is any better for you. But as pefunk says, there were issues with corrupt databases. If you are happy to wait minutes while a database check is performed on each startup, you can close eM Client 5-8 seconds quicker. :slight_smile:

Oh, and part of the workaround on those versions to avoid corrupt databases was to close eM Client and wait a few minutes before shutdown of Windows. Shutting down Windows with eM Client running regularly caused a database check on restart.

The current version is still the best option

Thanks for the follow-up!  I’ve tried a couple of previous versions but had the same issue. I’ll see about installing the older version that worked well before I installed this one. It is necessary to uninstall first.

Yes going backwards you need to uninstall first, but fortunately your data will not be affected. It is not possible to use the same database if you go back as far as version 6 though.

Would be interesting to hear which version works for. :slight_smile:

Will get back once I’ve rolled back.

Quick thought–

Have you tried closing your AV software and see if the delay persists?  Just a guess, but maybe delay is eM Client closing the database if being held open by another app.

No I haven’t, probably won’t bother since many others have the same issue…I’ll wait for a fix.