vCard encoding

Hi.

I testing your eM Client and I have first problem.

E-mail from Outlook 2010 with vCard (as .vcf attachment) - email body is in 8859-2 encoding, but vCard is in Win-1250. eM ignore it … show vCard in email enconding. It’s IMO wrong.

eM is last version 6.0.20498.

Thanks.

MIME-Version: 1.0Content-Type: multipart/mixed;
boundary="----=_NextPart_000_000F_01CF983D.51D36830"
X-Mailer: Microsoft Outlook 14.0

------=_NextPart_000_000F_01CF983D.51D36830Content-Type: text/plain;
charset=“iso-8859-2”
Content-Transfer-Encoding: quoted-printable

Nazda=F8 +=EC=B9=E8=F8=BE=FD=E1=ED=E9

------=_NextPart_000_000F_01CF983D.51D36830
Content-Type: text/x-vcard;
name=“Svoboda Martin.vcf”
Content-Transfer-Encoding: quoted-printable
Content-Disposition: attachment;
filename=“Svoboda Martin.vcf”

BEGIN:VCARD
VERSION:2.1
X-MS-SIGNATURE:YES
N;LANGUAGE=3Dcs:Svoboda;Martin
FN:Svoboda Martin
ORG:KHnet.info, o.s.
TITLE;CHARSET=3Dwindows-1250:radn=ED
ADR;HOME;PREF;CHARSET=3Dwindows-1250:;;Mas 666;Kutn=E1 hora;;28401;=
=C8esk=E1 republika
LABEL;HOME;PREF;CHARSET=3Dwindows-1250;ENCODING=3DQUOTED-PRINTABLE:Mas=
666=3D0D=3D0A=3D
28401 Kutn=3DE1 hora
X-MS-OL-DEFAULT-POSTAL-ADDRESS:1
URL;WORK:www.khnet.info
EMAIL;PREF;INTERNET:email@somewhere.info
REV:20111127T132306Z
END:VCARD

------=_NextPart_000_000F_01CF983D.51D36830–

Hi Martin, do you think you could send me the email with the .vcf attachment exported into .eml/.msg format to mcgregor@emclient.com?

Thank you,
Paul.

Hi again, thank you for the exported message, however if I import the vcard attached to the message, I see the correct encoding (Windows-1250).
Actually now looking again on the posted vCard data, the vCard is encoded in windows1250 as well.

What exactly are you referring to?

Thank you,
Paul.

Hi again Martin, I’ve consulted the issue with the developers and it’s indeed as you say, the encoding is really imported from the messages’ encoding.
But it’s only an issue with an old standard for vCards, we will consider improving this for future releases…

Thank you for reporting this, hope you can manage to use the current settings in the meantime,
Paul.