V9 immediately auto syncing

V9 sending mail immediately even though settings/mail/send “send mail immediately” is unchecked and settings/general/synchronize after is X minutes is unchecked.
If this is unresolved quickly it will force me back to V8

Can you uncheck the option to Enable undo send as well, and see if there is any difference?

Unchecking the undo send fixed the problem.
Thank you so much… I look forward to using the new V9 features