User Adjustable Connection Timeout Threshold

Greetings. I see in the thread archive that as recently as three years ago some eM Client users experienced premature time-out related errors when retrieving messages from their provider’s server. However, I have not seen a post more recent than Sep 2017 addressing this issue so I can not determine if the posts and their responses still hold true to the present version of eM Client (8.0.2685)

Is there a way for me to set some kind of timeout threshold in eMClient as this issue does still occur (see log below)? I was not able to recognize such a setting in the menu -> settings options. Or is there some viable workaround you can recommend? This happens about 50% of the time using an account on this one particular server.

Here is the Operations Log showing what I experience. Note that in the log pasted below for security purposes I replaced my true email address with a generic “” an had to use the literal AT instead of “@” and DOT instead of “.” so as to not exceed this forum’s “new user link limit of 2” in a given post.

7/13/2020 8:33:26 AM POP3 Connecting: To
7/13/2020 8:33:45 AM POP3 Connected: To
7/13/2020 8:33:45 AM POP3 Listing messages: From
7/13/2020 8:33:45 AM POP3 Downloading messages: From
7/13/2020 8:34:17 AM MailClient.Accounts.SocketException: Error when receiving from account : Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond…
7/13/2020 8:34:17 AM at MailClient.Protocols.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
7/13/2020 8:34:17 AM at MailClient.Commands.Command.Process(WorkerStatus status)|

I suffer from connection timeouts too.
Longer or user adjustable timeout should be very appreciated.

I’m one of the users that requested this. It is abominable that we’re now at version 8 and they haven’t yet exposed this feature. Instead, we get frilly gimmicks like customizable account avatars. I have a severe love/hate relationship with emClient.

1 Like

COX cable is having upload speed issues at my house and any e-mails with 1MB atachements are timing out using emClient, but work with GMail’s web interface. I’m seeing the same timeout issues in the log and am amazed they don’t open that setting