URGENT HELP REQUIRED

I recently did the reccomended update and after which the program would freeze whenever i hit reply. I then reinstalled em client with the latest update from the website. This is the message i now get when i open up EM Client:

After uninstalling and then reinstalling this is the message i get

System.Data.SQLite.SQLiteException: File opened that is not a database file
file is encrypted or is not a database
at System.Data.SQLite.SQLite3.Prepare(SQLiteConnection cnn, String strSql, SQLiteStatement previous, UInt32 timeoutMS, String& strRemain)
at System.Data.SQLite.SQLiteCommand.BuildNextCommand()
at System.Data.SQLite.SQLiteCommand.GetStatement(Int32 index)
at System.Data.SQLite.SQLiteDataReader.NextResult()
at System.Data.SQLite.SQLiteDataReader…ctor(SQLiteCommand cmd, CommandBehavior behave)
at System.Data.SQLite.SQLiteCommand.ExecuteReader(CommandBehavior behavior)
at System.Data.SQLite.SQLiteCommand.ExecuteNonQuery()
at System.Data.SQLite.SQLiteConnection.Open()
at DbRepair.DbTools.OpenConnection(String fileName)
at DbRepair.Form1.CheckConsistency(Int32& affectedRows, String& consistencyError)
at DbRepair.Form1.Check(Object state)

PLEASE HELP

reinstalled once again and all is now working

I have the same problem, after the update today, EM Client freezes whenever I click reply to an email and unfortunately re-installing EM Client doesn’t seem to work.

Such a shame, I moved to EM Client as an outlook replacement and I really don’t want to move back, it was shaping up to being a really good program too.

Can you please try to disable spellchecker?

@ Michal Burger - That works, many thanks for that, although I would like to use the spell-checker at some time in the future I think I can survive for a bit on my own!

Ok, good news we have a root cause. Can you please send us an email (please save it as .EML file and send it as attachment) on which reply freezes eM Client to support@emclient.com? We will analyze it and hopefully fix it immediately.

Many thanks Michal that’s now sent.

Thank you for the mail. Was it the one with New reply: “URGENT HELP REQUIRED” as subject? It it was it didn’t help us in diagnosing the problem :-(. We have no problem with replying on that message, even with enabled spellchecker. Can you please make sure it is related with spellchecker? You can do that be reenabling spellchecker and trying to reply on that message. At the moment we are baffled.

Thanks Michal, that was the email.

I didn’t realise it only happened with certain emails. I have enabled the spell checker and am sending an email which still freezes (presumably because there are spelling errors in it?) with the same subject heading as above.

Although now that I try replying to that particular email again, it seems to freeze emClient with or without spellcheck enabled. Which is odd as it worked yesterday with it disabled.

Rgds

Rupert

I see, so it seems spellcheck is not the problem :-(.
There is another potential cause (new function in v. 2.7).
Can you please try to uncheck option Tools -> Settings -> Read -> Replace text smileys with emoticons?

Thanks that works. That’s great. I can now reply to those emails whether spellcheck is enabled or not.

Great news that my advice helped. On the other hand we need to really fix it :-). Can I ask you for your OS version (Vista, 7) and Internet Explorer version? It seems it probably depends on IE version, so this information would probably help us.

Sure, I’m running windows 7.

Once again, thanks for your help!

How do you fix this if you can’t even get into eM Client? I get a similar error message on startup of eM Client. This started also after the update. I, too, am running Windows 7 64-bit with IE 8. I also use Firefox 3.6.10 (though I had 3.6.9 until earlier today).

Here is the text from the error box:

System.Data.SQLite.SQLiteException: File opened that is not a database file
file is encrypted or is not a database
at System.Data.SQLite.SQLite3.Prepare(SQLiteConnection cnn, String strSql, SQLiteStatement previous, UInt32 timeoutMS, String& strRemain)
at System.Data.SQLite.SQLiteCommand.BuildNextCommand()
at System.Data.SQLite.SQLiteDataReader.NextResult()
at System.Data.SQLite.SQLiteDataReader…ctor(SQLiteCommand cmd, CommandBehavior behave)
at System.Data.SQLite.SQLiteCommand.ExecuteReader(CommandBehavior behavior)
at System.Data.SQLite.SQLiteCommand.ExecuteNonQuery()
at System.Data.SQLite.SQLiteConnection.Open()
at DbRepair.DbTools.OpenConnection(String fileName)
at DbRepair.Form1.CheckCorruption()
at DbRepair.Form1.Check(Object state)

Thanks in advance!
Beth

I have had the same problem, spell checker wasn’t enabled but I’ve disabled the smiley thing & mine is working now apart from the fact that when replying to emails in my personal email address it defaults to my work one…only since the update!

Nevermind…I fixed my problem. I completely uninstalled the program, data files and all (after backing them up, of course); reinstalled the program, and replaced the generic dat files with my backed-up dat files. And now it works.