Upgraded to faulty Version 7.2.

I upgraded to Version 7.2 and it keeps trying to go to google and wheel turns, nothing happens.

Uninstalled and tried to go back to Version 7.1 but it won’t start because the database has been updated for the new version. Seems now I am stuck with no email

upgraded but won’t connect with gmail…says something went wrong

Same here…

I had that happen too.  And then I discovered that there was a dialog “behind” the application screen, asking me to enter my gmail password.  Which I did, and then everything was fine.

For me, it goes to google gmail and asks for account confirmation, which I do, then goes to a dialogue box saying it is doing something, the wheel turns for ever. I never get a prompt or place to enter password. I have been using Version 7.1 for ages, and never had this problem. This is a fault of some kind with this version.

Indeed, after installing 7.2 on Windows 7 and starting eM Client, the Gmail account confirmation is started. Logging into Gmail (through a browser) is successful; after approving the permissions eM Client is asking for, a new screen is opened. It says however: “Something has gone wrong”. There is a “Next” button but it does not respond. In the mean time, eM Client is waiting for this process to complete… which it never does ofcourse.

Could this be resolved a.s.a.p. please?

same here

Exact same thing for me.  I did the upgrade last night and still can’t get my gmail loaded into em client.

Finally got it to work: Internet Explorer reports “Something has gone wrong”, but Firefox handles it correctly!
So it’s not an error on eM Client’s side after all…

Sorry I don’t agree. If your email client requires firefox to log in to gmail before it will run, then it is an emclient error. I have used emclient for a long time, and it never needed this. Plus I was using Chrome. Don’t know anyone who uses IE. I changed my default browser to firefox, but emclient still fails.

I tried changing my default browser to Chrome (from IE) and it worked!  Thanks Muziekcommissie De Ark!  It may not make sense or seem “right”, but I’m back in business.  Thanks again.

FIXED FOR ME.
Posted earlier that after updating I couldn’t add GMAIL. Got the same error “something   went wrong” message. Just tried adding it again but it pulled up my default IE browser. (I don’t use it, use Chrome, but Windows 7’s desktop icons don’t like it when IE’s not default)

ANYWAY… I went back to the page just before “something went wrong” and copied the “IE”
 browser link and pasted it into Chrome. POW…it took me to next page and there was an agree box to add em etc. and it’s back working in em again.

HOPE this work around helps. Did for me.

I had a support guy from emClient contact me in reply to my emails to them. (Filip). He assured me that the browser prompt only has to happen once, and that it was possible for some software/browser/antivirus or computer setting to stop the authentication. Through trial and error we found that it was my Avast Browser which was my default browser. I changed my default browser to Chrome, then logged into emClient and the authentication worked. I was then able to change my default Browser back to Avast. If you prefer IE or any other browser, after you have done the authentication process using Chrome, you can then change your default back, and emClient will continue to work.

This confirms the experience that some found with IE to Chrome in this discussion.

I have been working for 2 days working with a client of mine who cannot get past the OAuth process (The bit where it launches your browser and authenticates your Google account) I can successfully log into the Gmail account, and it asks for permission for the usual list of rights like accessing contact, email, etc. I grant permission and Gmail happily completes the process in the browser but the EMClient app still has an open dialog telling me it may take a while. We gave it quite a while and it never completes so we cancel and remove the Gmail account so he can work using his other email and use Gmail from the web interface. EMClient has released numerous dot releases over the past couple of days and I have tried each, to no avail. I am the owner of an IT support company and have used EMClient for years and refer it to my clients constantly. I like the system and have never seen this kind of thing happen before, but stuff happens. Sympathies aside, we need a resolution to this ASAP. The latest dot release I tried is 7.2.33939.0 and it didn’t work. He’s on a Windows 7 Ultimate, 64 bit OS. I tried reverting to an earlier release but the update made changes to the database so it won’t let the 7.1 version run and he accidentally unplugged his backup months ago so we can’t go back to an older database.

Hi Tom, This was the frustration I was feeling as well, and the reason I bombarded emclient with emails. With mine, it was my default browser. Any one of the various protection mechanisms to prevent popups etc, are able to prevent this authentication process.

You need to get to the point that a popup opens with a prompt that asks if you want to Open eM Client even though you already have it open, click to open. That does the authentication. After that, you can change the browser setup or whatever back, as the authentication only needed to happen once.

Chrome should work ok.

Since it appears to not be playing nicely with Googles OAuth I switched default browsers from IE to Chrome and disabling the pop-up blocker is SOP with things like this. I’m getting the OAuth dialog asking permission to access Google info and Chrome says it has successfully completed it but I’m still stuck with the whirling cursor and a dialog that says this may take a while. By “take a while” does it mean minutes or days? Enabling less secure apps doesn’t help and I even logged chrome out of the Gmail account just to force the login prompt. No joy. Chrome prompted for the password but then I still get the same behavior. I’ve uninstalled and reinstalled EMClient with each dot release they have put out without any change. I deleted and recreated the Gmail account, still no luck. It may just be a coincidence but I’ve had a wave of problems connecting Gmail in Outlook 2016. The behavior is different and Outlook doesn’t use OAuth but the end result is the same. It can’t complete the Gmail setup. With Outlook the trigger is not an update, but a change to the password and it WILL NOT save the updated password without deleting the Gmail account and recreating it. Microsoft even released a patch for this but it didn’t work so even if you are getting frustrated with this issue in EMClient, don’t tempt yourself to switch to Outlook for this and a thousand other reasons. Google’s a big target. I wonder if they’ve tightened up security in some subtle way that is creating issues for the email clients out there. Something as simple as a misplaced comma or space in the data sent to the Google security connector could be problematic. That’s something the EMClient development team would have to sort out, but it’s a pattern that merits investigation. 

Hi Tom, note that you only need to disable popup blocker etc once, then you can put everything back. emClient only needs to do this once. The attached is the popup you need to get to. Once you see and click open on this, everything will come right.
Check your antivirus isn’t blocking it as well. 
If you are still stuck, I can give you the email address of the emClient support guy who helped me. He was going to go away and check why my avast browser didn’t allow the popup above. 
Regards
Grant

We are working on an update, but so far we have identified only some of the causes, all of them relating to Windows 7 and specific software versions/combinations. We’re still in process of gathering more data and testing more browsers and system versions.

If Internet Explorer is set as the default browser in Windows 7 it fails to complete the authentication process. This seems to be a bug in Internet Explorer 8 (and possibly some newer versions) in handling of long adresses, where it silent fails or displays a cryptic warning. Workaround is to set another browser as the default browser in the system, at least for the duration of the authentication. A proper fix is currently being tested.

If the problem persists even with Google Chrome feel free to contact me directly at navara@emclient.com. I can arrange a remote session through TeamViewer to investigate and resolve the issue.

We are partly at mercy of Google’s policy of forcing us to use external browsers (https://developers.googleblog.com/2016/08/modernizing-oauth-interactions-in-native-apps.html), which seems notoriously easy to break. For unrelated reasons Google forces reauthentication in version 7.2, so all users need to go through the process and it caused the recent surge of the reports. We have already pinpointed couple of issues and we are going to release update to address them, but it still seems that there are problems with Google Chrome, or other Chrome-based browsers, that we didn’t manage to pin down.

Thanks!