Updated to eM Client 8 and now it won't connect to my Gmail Account

UPDATED Today 14/Sep/2020: Hi all, thanks for the replies and help, I’ve decided to rollback to version 7 and that works just fine. So as far as I’m concerned, it’s not me it’s them :slight_smile: Consider this closed.

UPDATED: Redacted email address from screenshot and log. Cheers to those who pointed out that I should redact sensitive info. I also used the eMC automatic method of creating the account but, I’ve checked the settings after the fact and they’re correct.

Hi I’ve just updated to version 8.0.3318 (1a4785e) from a previous version (I don’t remember the version probably 7.something) and now it won’t connect to my gmail account. My father has this problem as well. It was his issue that caused me to update my version of eM Client as my settings were no different to his and I couldn’t figure it out. Now it seems its the application and not the settings thats the issue.

I’ve deleted my Account from eM Client and added it again. I got the authentication window and when I go back to eM Client I got the same error:

6:43:21 PM [MY EMAIL ADDRESS] [IMAP] MailClient.Accounts.ConnectionException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host…

I’ve attached a screenshot, I’m not sure how to upload the Log file with the stacktrace so I put it up on Mega.co.nz.

CLICK HERE TO DOWNLOAD LOG TXT

Please help.

Screenshot:

Probably the first thing to do is redact the personal info from the image - just for your security on a public forum.
Then take a look here to check if your Imap/SMTP server settings are
correct.
https://support.google.com/mail/answer/7126229?hl=en-GB
Did you create the Gmail account using eMC’s automatic process or manually?
Try pinging your server:
e.g. Command prompt: ping imap.gmail.com

1 Like

domingo 13 septiembre 2020 :: 1119hrs (UTC +01:00)

Hi CountZer0…

I agree about the redaction, I have also sent you an email to see if you can receive,
with a number of observations.
You can get back to me on that if you like.

¡Saludos desde la soleada España!

Russ

skybat@gmail.com

2 Likes

Hello,
I have the same problem.
It is my first installation of EM (email installed automatically) and I don’t have access to my email.
I’ve check the parameters regarding gmail site, it is ok.

Curiously the calendar works fine.

Curiouser and curiouser Alice! :stuck_out_tongue_winking_eye:

Are you able to ping the server from a command prompt - as above?

I would suggest that you upgrade to the latest eMC vesion, 8.0.3385.0 AND temporarily turn off your anti-virus application… see if that has any effect on your problem.

Several of us on this forum are having the exact same problem as you - v7 works great and when we update to v8 gmail cannot connect. Most of us have reinstalled v7 as a band-aid fix and are waiting for the developers to patch the gmail issue with v8.

1 Like

yes rjubin.
I’ve prompt the imap.gmail as written below.
22s for an answer !

Can you copy/ screen-shot the results of Ping please?

domingo 13 septiembre 2020 :: 1816hrs (UTC +01:00)

Hi Count Zer0…

This the email I sent to see if you can receive emails, the content is
self explanatory.

¡Saludos desde la soleada España!

Russ

skybat@gmail.com

+++++ +++++ Pasted from email sent +++++ +++++

domingo 13 septiembre 2020 :: 1119hrs (UTC +01:0

Hi Matthew…

I saw your post on eM Client Forum and clicked on your email there.

The issue is almost certainly being caused by the Gmail authentication routine.

I assume you checked and double checked your user name/password and set up and all is correct, also it is far better, in my opinion, to set up accounts manually rather than use the EMC routine, though this should have been carried forward with the upgrade.

I periodically have the same issue if I’m connected via my VPN when the GMAIL servers have a fit and send alert messages to my backup email address registered with them - all I do to overcome the problem is to directly log into my GMAIL account via a BROWSER, either IE11 or Edge Chromium and that solves the problem until next time.

The problem is probably the fact that GMAIL is blocking the connection even though I have OAUTH enabled, because it doesn’t immediately recognise the connection, it sees it as suspicious - I guess this is your problem too as you say you updated from…? and I assume things were previously working correctly.

I only use my Gmail account for specific non business contact because I find Google far too intrusive (eM Client Forum for instance) plus it’s convenient and I’ve had the Gmail account for longer than I can remember, way before all recent authentication issues, together with Alphabet shares that I’ve been lucky enough to hold since 2004 so I feel it’s in my own interests to support them.

If you don’t already know you can check out AUTH here and go forward to set it up.
https://developers.google.com/gmail/api/auth/about-auth

Hope this helps.

¡Saludos desde la soleada España!

Russ

I can’t ping domain names from my pc, I’ll need to check my router settings and see if it lets me ping things.

Yup I saw it thanks.

I just used Fing on my iPad (both my pc and iPad are in the same wireless network) and got 127ms average. Must something to do with the firewall on my pc preventing me from pinging and trace routing. I’ll look into that. That shouldn’t stop eMC from working though, it was working fine previously, like 2 days ago before I updated to v8

Alice - I suggest you open another post on this forum. This one has become a bit messy.

Also give:

OS and version of the PC you have installed eMC
Version of eMC installed

@AliceD, I would suggest that you upgrade to the latest eMC vesion, 8.0.3385.0 AND temporarily turn off your anti-virus application… see if that has any effect on your problem.

jueves 15 septiembre 2020 :: 2113hrs (UTC +01:00)

Hi Alice…

A fairly common problem with all 3rd party email clients with Gmail,
And a complete mystery why it is not a consistent issue.
Anyway…

You will need to add trusted 3rd party app to your Gmail account, do this:

Sign into the Gmail account using a web browser at:

https://mail.google.com

Then go to:
Settings -> Accounts and Import -> Other Google Account settings ->
Under Security, scroll down and enable access for less secure apps.
This setting is required to enable SMTP, POP or IMAP access.

¡Saludos desde la soleada España!

Russ

skybat@gmail.com

Same problem here.

On the positive note, when looking for a solution, I stumbled upon Mailbird and installed it to see if this is a Gmail-related problem. I was completely blown away by how clean and fully featured it is, so switching today.

Bye bye Emclient.