Update Contact details Error

I normally do all Contact changes in GMail & eM Client uploads them up without problems. However, 4 times recently I have tried to do changes in eM Client & each time I get an error message - [Google Contacts]Uploading item(s) to folder ‘Neil McDonald (GMail)/Contacts’ failed due to the following error: Cannot add contacts to deprecated system contact group resource name “contactGroups/family”.].
Each time, I have had to delete & re-add my eM Client account to get rid of the error. Once re-added eM Client works fine until I do another Contact change.
I have read previous posts on the cause of this error, but believe the problem is something more than that. Why can’t I use eM Client for Contact changes?

Suggestion: Delete the Gmail account and add it back.

As I said in my post, that is what I have had to do - 4 times recently - delete the Gmail account and add it back.
I shouldn’t need to do that every time a make a change to a Contact in eM Client!!!
There’s something wrong with eM Client Contact change process.

Must have missed that…
Perhaps someone else has some suggestions or you can subscribe to Support and open a support ticket.

If you remove and re-add the account, but then again try to use the deprecated family group, of course you will get the same error.

Please remove and re-add the account, then DON’T use the deprecated group.

Thanks for that advice.
In Gmail I removed all contacts from my “Family” group label (a label I had created in GMail), then deleted the label.
In eM Client I deleted my GMail account then re-added it. It loaded everything from GMail, including an empty “Family” group label. I tried to change & delete that label in eM Client, but got an error message “…Cannot modify a system group”. So, although “Family” is not a GMail system label, it would appear to be one in eMClient.
In GMail, I then created a new “Family” label & added some contacts back into it, then tried to edit them in eM Client, but got the same “deprecated group” error message.
You say “DON’T use the deprecated group”. Won’t deleting it from GMail (then re-adding it) solve the problem?
Any further suggestions?

I have created a new “Relations” group label to use instead of the problematic “Family” label.
Problem is fixed, for now!!??