unread emails in smart folders shows GMAIL archive

I have read all the hints on unread e-mails, yet despite all my tweaking the appropriate smart forlder shows “unread” in the “Gmail” “all mail” folder. Have I missed something important?

I am sorry but we cannot change it at the moment. Unread folder in Smart folders displays ALL unread messages so it includes All mail folder on Gmail too. The only solution is to disable showing of All mail folder in IMAP in Gmail settings.

OK but of course, I need the “all mail” folder for when I accidentally archive something. I’ll go for plan “B” and hide the “all unread”…

Seems to me like the only thing you’d have to do is exclude ‘All Mail’ from the count? ‘Unread’ is pretty much unusable right now.

Hi, if you have the same issue, and you have unread emails from the all mail folder in the unread smart folder, you can hide the “All Mail” folder from IMAP, but that’s the only way how to display only new unread email in that smart folder. Or you can create a search folder for unread email in selected folders.

Sorry if this is an issue for you, I hope you can manage to use the current settings.

Thank you,

Now what do we do since we can no longer hide the “All Mail” Folder.  I am going crazy trying to find the unread message here.   I highlighter all the emails in the “All Mail” Folder and made sure they are all marked as read.  But I am still seeing fictitious unread counts.  When I click on the Unread Smart Folder it says “There are no messages to show in this view”


Hi Barbara,
there is no point of reviving this old thread when the current problem with version 7 BETA is unrelated.
The message counter is broken, that is a known issue that we’re working on fixing now.
If you reverted back to Version 6, you can disable the All Mail folder again, seeing as it is needed for the new functionality of the version 7 BETA.