Unauthorized caldev and carddev errors after eMClient 8

I just upgraded to eM Client 8.0.2951 (e2fe9f0) and now I get error messages every 5 minutes:
[CalDAV] Sync of xxxxxxxxxxxxxxx/Home failed due to the following error: xxxxxxxxxxxxx (Unauthorized)
Another message says the same for CardDAV.

I assumed that the problem was the iCloud password but generating and using a new app-specific iCloud password did not resolve the problem. Do I need to change the caldav and carddav server url address? Is there something else I’m missing?

I have the exact same problem. I haven’t found a solution yet.


Thank you for posting about the issue.
We’re aware of it and it has a sinple fix - just remove the account and reconfigure it in Menu > Accounts > Add account. This should fix it.


No it doesn´t! I try several times!
But everytime the same!
So found a solution it makes me crazy!
Best regards

Same problem here and I agree with the others that reconfiguring the account does not fix it.
I have regressed to Version 7 and will await a fix.

Calendar works for me for the first 60 minutes, then CalDEV errors after that. I’m using the Yahoo calendar link. Tried removing and reinstalling the Yahoo account, problem persists. I had a similar problem with Yahoo on my Android phone, using maildroid. It finally got resolved by installing Yahoo mail app on the phone and setting up my account. Then maildroid worked. Then I uninstalled the Yahoo mail app. Maildroid continues to work. I think it has something to do with verification. Something needs to be confirmed within 60 minutes.

SOLUTION: It appears that some services require the use of an “app password” to login. You create the app password using a web session with your service provider. It will require that you login and then choose from a list of apps (usually eMClient is not there, but you can add it) and the 16 lower-case character password will be generated. It may be shown with spaces for readability. Copy or write down this password.

In eM Client, choose Menu>Accounts, pick the account that matches your service provider, then select the CalDAV tab. In the Authentication section, select “Use these credentials”. The User name is your service provider login name (generally the part before @service.com,) the Password is the app password you obtained earlier, entered without spaces. Finally, Save & Close.

Where you find the app password generation for your provider will vary. In the case of Yahoo, it is the following:


I left the CardDAV tab in the default state, Use identity credentials, and it worked too. But that might not always work. You might need to set User name and Password there also.

THis cought not be the best way for a program i spend money!
It shout work without this way!

That is how Version 7 worked too of course.

In other words, those of us using Caldav and Carddav with providers requiring app passwords already had (had to have) those credentials set up.

For some reason they no longer work with Version 8, even when the account(s) are deleted and reentered.

I’m not personally willing to retry the upgrade to Version 8 until I understand why my existing credentials no longer work. That and the slew of other bug reports I see here.

1 Like

I apologize for not replying sooner. I was able to get this error to go away a day or two after I first posted this issue. I can’t remember exactly what I did but I think I did delete the Calendar and Contacts accounts from eMClient (not the Mail account), and then re-added them. I most definitely did not change the app-specific password again.

Again, I’m not sure if the servers changed because of this but I think at least one of them did. Here are the servers that are working for me:
CardDAV - https://contacts.icloud.com/
CalDAV - https://caldav.icloud.com/.well-known/caldav

I hope this helps you all.