Unable to send email - SMTP failure

I have started a new thread for this as I am not sure if my other comment will get lost in the other post now that it appears to be solved.

I have a customer who cannot send email, with the error “Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond…” reported in the log.

Thunderbird does however work on the PC. He thought it was around the time that emClient was updated that the problem occurred, so we installed several older versions but still no joy.

I have tested various different ports with different SSL options, and non SSL along with different server addresses as provided by TSO Hosts support, but they say as it works with Thunderbird, it is not their issue. The support guy said it must be emClient as he had never heard of it! They allegedly haven’t changed anything on their server. I’ve tried multiple combinations of the above along with setting up the account from scratch several times.

I’m not sure I follow what @butty was saying about releasing dedicated IP on server etc, and not sure why emClient would have an issue with the server when Thunderbird does not.

Thanks for any help.

lunes 05 diciembre 2022 :: 1403hrs (UTC +01:00)

Hey

I am as well confused by the above, it does not make sense.

I am sorry I cannot help you with your issue, all I can say is that I have never had any SMTP issue with the latest and previous version of eMC. I currently have v9.2,1222 on Win 11 Pro and Win 10 Pro, and it also does not make any difference with or without VPN at numerous locations when running tests.

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

@Neil_Young

Yes agree with @skybat that assigning a new Remote Domain WebServer IP & updating the DNS records shouldn’t normally make any difference to the local SMTP connection / Timeout issue in eM Client.

The only thing normally that can happen (apart from optional software installed interfering like VPNs & Firewalls etc) is if your eg: dynamically assigned ISP IP address goes "“Stale” and only partially works and getting the new IP address from your server (with turning your modem / router off for say a minute or so) normally fixes that.

So could have been just a stale or problematic old (locally ISP assigned address) problem & pure coincidence that updating the remote web servers IP address & DNS records made it work for that other user.

Updating DNS server records also normally shouldn’t have anything that do with sending mail problems. They are normally only for resolving websites with DNS table issues etc.

If your computer is on a eg: Lan and not connected directly to your modem / router, try also “releasing and renewing your IP address on the Lan computer” (after powering off and on your modem / router) via the command prompt or rebooting your computer. Also check that you are getting a valid Modem-Router IP / DNS / Gateway address to your Lan PC via the command line or Network icon properties.

Next make sure you can “Ping” your SMTP mail server via the command prompt.

If you can Ping to your SMTP mail server ok and have valid DNS Servers & Gateway address’s, then you should normally be able to send mail through it, unless you have an actual smtp isp mail server problem, but that’s unlikely. Most isp’s smtp mail servers are very reliable.

Now If “you cannot ping it”, then that’s usually a good indication your dynamically assigned ISP IP address is not working correctly, or there is either possibly some “other locally installed software on the computer” blocking access to the smtp mail server and getting connection timeouts etc, or there could be a “local computer network icon configuration problem” somewhere on the computer causing it.

Good luck & hope you get it fixed.

Thanks for the suggestions, I will try this with them tomorrow. I have however had the PC here in my office today to try various things, and the problem still exists. As my network and ISP are different, I would have thought this would remove the problematic IP from the equation?

ironically, when setting the account up from scratch, emClient puts a green tick when testing the SMTP server. I assume this means it has successfully connected and authenticated with the server … He just cannot send anything.

I will also try setting up his email temporarily on a copy of emClient on one of my test PC’s to further isolate the problem and report back.

No luck and no change. I set up his email on a test PC in my office and have the same result …