Unable to search (search results may be incomplete...)

Been using em client for years now all of a sudden it doesn’t allow me to search for emails anymore, basically nothing comes up when I search. The message I get is:
“Incomplete search results
Search results may be incomplete because some messages haven’t been fully downloaded. Select an option you would like to perform”
Options

  1. Always download complete messages
  2. Download complete messages now

Have tried selecting both options, waiting, etc…
Still no help, the search doesn’t show a single result not matter what I search.

Any solutions to this problem?


Screenshot attached

Suggest you then try setting that automatically in your accounts and see if that works rather than having to manually choose that all the time when searching.

You can change via “Menu / Accounts” an option under an eg: IMAP account to “Download messages for offline use” and also “Include attachments” for searching in message bodies as per the below example Gmail screenshot.

Tried this solution. Didn’t fix anything unfortunately.

Ok. Do you have a POP or IMAP, Exchange, Office 365 or iCloud type account ?

Also do you have any problems or errors even just reading messages when they arrive ?

Also where are you clicking in eM Client to start the search, and what do you type in to search.

Also are you using the advanced search or basic search, and do you search in specific folders etc.

So if you could maybe do example screenshots from the start to finish of how your searching.

Lastly what version of eM Client are you running and do you have Windows or Mac OS.

Thanks for the reply. I’m using a Gmail account if that helps.

I don’t have errors reading messages when they arrive.

I’ll attach a screenshot of where I’m searching, it’s just on the top right hand side in the search box. I always did it the same way but just recently it’s no longer showing any results. It’s the same regardless of what I search, whether I search the exact title of an email or keywords in the content.

I search the main inbox where I know where the email would be, but it’s also the same case if I search a specific folder.

It’s basically screenshot provided, and searching, then seeing “There are no messages to show in this view” as shown in the initial screenshot I provided earlier.

I’m using version 9.2.1222 (ca10485) - and running it on Windows.

Sounds like then possibly something to do with the Gmail “All Mail” folder in eM Client, where all the messages are stored for Gmail maybe (is not all read properly somewhere) causing no search results. Or you have some local eM Client cache problem that might need repairing, or failing that might need the Gmail acct removed & re-added.

So first for a test click on “All Mail” under your Gmail account in eM Client, and then click the search field at the top right again as you did. Then see if it will find anything in the search box by email address or name etc like you did previously.