Unable to download msgs from one Gmail account


so all my gmail accounts stopped working a few days ago due to the “less secure apps” policy enforced by Google. I’ve set them up again using the automatic setup and all seemed to be fine, but emClient can’t download mail from one of them.

I have 3 separate gmail accounts, 2 of them work fine, the one in question is able to send email, but not receive. The setup of all 3 is the same, I’m not usung firewall or additional antivirus, not on VPN, no other “security” related software. The only difference is that the problematic account is the default one for the eMClient.

I went thorugh a number of similar topics mentioned here, but found no working solution. Any ideas?

Win10, eMClient 7.2.37929.0. There is no error in the Error tab, just the red icon next to the name of the account in folder list. The log looks like this:

00:39:24 myaddressATgmail.com [IMAP] Uploading messages: To folder myaddresATgmail.com/[Gmail]/Wszystkie
00:39:26 myaddresATgmail.com [IMAP] Uploading messages: Done
00:39:26 myaddressATgmail.com [IMAP] Uploading messages: To folder myaddressATgmail.com/[Gmail]/Wszystkie
00:39:27 myaddressATgmail.com [IMAP] Uploading messages: Done
00:39:27 MailClient.Accounts.ConnectionException:
00:39:27 ()
00:39:27 at MailClient.Protocols.Imap.Synchronizer.ImapCommand.ThrowIfConnectionBroken(BasicResponse response)
00:39:27 at MailClient.Protocols.Imap.Synchronizer.AppendCommand.ExecuteInternal(WorkerStatus status)
00:39:27 at MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
00:39:27 at MailClient.Commands.Command.Process(WorkerStatus status)

If you can login ok online to the Gmail account that is not receiving in eM Client and see your inbox emails ok, I would suggest to remove and re-add that specific Gmail account via the automatic wizard again in eM Client & see if that fixes it.

Failing that, right click on the “All Mail” folder under that specific Gmail account and click “Properties” on the menu at the bottom. The click the “Repair” tab at the top & click Repair.

Note: before doing anything, backup eM Client via “Menu / Backup”. You can see when it’s completed the backup via “Menu / Operations”.

I tried the “Repair” option first, as it seemed easier. And the problem is solved:). Thank you very much!

1 Like