Unable to contact License Server

I recently installed eMClient and am having issues activating my pro license due to an error contacting the license server.    Some known background:

1: Yes, I am behind a proxy. I have added emClient as an exception to my Windows Firewall, but does not make any difference…  I have not found a way to add an exception to the proxy.


in the address bar type:


that does bring me to a location, prompting me for login credentials… (that I do not have etc., but  I am seemingly connected)?

So it seems, the browser is able to get to the licensing server, but not emClient? 

Any help is greatly appreciated. 

Hello, eM Client unfortunately does not support any proxy settings, please make sure to setup an exception for your proxy to Port 80 or http://licensing.emclient.com/

Thank you,

Can i put in a formal request to support proxy settings in the client? I have other apps on this computer that either are able to detect and work with the proxy or I have options to set up Proxy in the app. I can certainly talk to our IT department, but i suspect they will be less than thrilled or able to setup exceptions in my case. 

Thank you for the information.

Hello again, we are working on including this in future releases, however even though support for proxy is on our roadmap of features, it is not completely sure when exactly we’ll be able to implement the feature.

If you’re using windows credentials for authenticating with your proxy, you can insert this configuration file into your installation folder (http://www.emclient.com/tools/MailClient.exe.Proxy.zip) which will allow you to authenticate with your proxy server, no other options are currently available for proxy setup.

Hope this helps,

Thanks Paul, unfortunately that did not help. I placed the config as you described and still get the same error about unable to connect to License server, due to empty response…   Good to hear you are considering updating to support proxies. I will do more digging here to see what is possible. 

I did paw through the log file and the URL that is being connected to:


does work in the browser… not sure if there is any log infomation I could send that would be helpful? 



Are you using windows credentials for authentication? As I suggested, this option is only to allow authenticate using your windows credentials, so if you’re using different authentication method for use with your proxy, this workaround will not be much helpful.

This is otherwise not a directly supported option, we’re currently unable to resolve proxy setup issues since the application does not include any advanced proxy setup at the moment.

Yes, the credentials I use to log into our domain/my computer is the sames used by the proxy  (zScaler if it matters). There is no additional login for me when I logon, other than my initial logon screen… 

Can you please make a screenshot of the error you’re seeing (contacting license server failed) and submit it to us here on the forum?

Thank you,

Here is the message box that appears after I click “activate” and then copy in my key:

Can you please navigate to Tools > Settings > Advanced and enable Network Communication logging on your eM Client? Save the settings and replicate the issue, once the error reoccurs, please restart the application and submit the logging data using the “send logs” button to us for more information.

Please submit the data to my work mail, [email protected] and please include a reference link to this forum topic.

Thank you,


When we last spoke regarding this issue, there was mention of a potential update to emClient to help support these issues. My trial has expired so now I am left without the ability to use emClient behind this firewall. Is there any eta on an update? I do keep checking via emClient for an update and it states none is available still.



Hello, not quite sure what you’re referring to, we’re working on an upcoming release of eM Client, but unfortunately if you have a firewall enabled that blocks the connection to our licensing server, you won’t be able to use the application without making an exception in your firewall settings to allow the access…

eM Client 7 unfortunately will not include any options that would allow us to override the security, and I believe most users wouldn’t really like such feature either as it would potentially mean a security risk on your computer.

Make sure to allow access to http://licensing.emclient.com/ or Port 80 to allow eM Client to connect to our licensing if you’re experiencing activation issues.


Hello Paul,

I am referring to an email thread you and I had about a month ago where I had indicated exceptions to the firewall were not something I could easily do and you had given me a potential work around via a config modification, That did not work in my case and upon me sending you log files, you responded with the following comment:

Hello Andrew, unfortunately it seems that you’re being automatically redirected by a gateway, this is unfortunately not possible for us to resolve on spot, but we’re working on an update that should be able to resolve this kind of behavior. Please make sure to keep your application up to date to updated once the update is released.

That is the release etc I am referring to…  I can dig up our email thread if that would help. 

Hello Andrew, seems like we’re talking on two different things though, if your server is redirecting you, as I suggested, we’re working on an update that should allow you us to handle this properly, but if you’re using proxy in your network that requires authentication (which I believe is what I may have send you a workaround for) - we’re not currently supporting proxy authentication with a single exception of proxy that uses your windows credentials for authentication, in that case, the workaround is to replace the config file, which forces our application to use the system credentials when being redirected.


OK, thanks for clarifying… I guess best to wait for the update and see if I have any improvement… We do use Window’s credentials as part of our redirect, so hopefully the config combined with update will allow me to use emClient. In the meantime, my trial has expired, can I get that reset in any fashion? Trying to use the “free” version will not work as of course same license server issue I presume…

Unfortunately it is not possible for us to extend the trial remotely, I’m sorry for this inconvenience, but I’m afraid we’re unable to resolve this without forcing you to disable your security or decrease the security level for our servers.

Hope you understand,

What IP should I input in our firewall for the license server error

I am having the “unable to contact the licensing server” issue and see no solution on your website.

Hello Michael,

Please visit our post: https://forum.emclient.com/emclient/topics/windows-xp-no-longer-supported-issues-with-connecting-to-… where the situation with MS XP is explained.