Unable To Add A New Account In New Installation Of eM Client

Because Google is no longer supporting third-party apps today I installed eM Client v 8.1.1087 (d63975c). I’ve been using an old version of Thunderbird and have several Google email accounts, all of which imported beautifully during the install so I believe I may have found my substitute for Thunderbird.

I’d previously set up a new email account at Google and after installing eM Client thought to add this new Google mail account to eM Client today. I understand the way to do this is to go to Menu>Accounts and there to select to add a new account which I did.

I entered the new email account name.

In the next display it asked for details so I entered my own name above the email address that displayed there already filled in.

As I don’t want encrypted emails for now I opted out of encryption (continue without encryption) and selected Next.

I added an avatar, selected to have mail, chat, contacts, and calendar, selected Finish, and this is where I encounter the problem.

No matter how many times I click on Finish the process does not finish and I can’t add this new account. The finish toggle doesn’t change color, change size, animate in any way, or do anything to indicate it’s live or active. I can’t finish adding the account whether I do or don’t use an avatar, and whether I do or don’t use encryption.

I can go back or cancel without any problem. A new account simply will not be added.

I thought to attempt a work-around and added this new account in Thunderbird, after which I anticipated I’d be able to import it (Menu>File>Import) into eM Client just like the other accounts imported during eM Client’s installation. I get no error messages and every indication the import was successful but the account doesn’t show up there on the left hand side of the eM Client interface along with all the other email accounts. I’ve shut down eM Client and restarted it and that didn’t make any difference.

I am missing something but I don’t know what.

No matter how many times I click on Finish the process does not finish and I can’t add this new account

I suspect you just haven’t allowed eM Client access to your Google account.

First though I would suggest to uninstall your current eM Client v 8.1.1087 and then d/l the latest V9.0 for Windows or Mac from the version history page below and try to setup again. .


As you have Google (Gmail) accounts, when you go through the automatic email wizard via Menu / Accounts near the end of the wizard “a browser window” will normally open (sometimes in the background) where you have to click “Allow” so eM Client has access to your Google account before you can click finish which I suspect is the problem. So toggle around till you find the Allow button.

If you toggle around and don’t see a browser window with an allow button, then make sure you have a default browser setup or won’t appear.

I suspect you just haven’t allowed eM Client access to your Google account.

I’ve been receiving emails without any problem and without specifically fixing any setting to allow specific access to my Google accounts. However, after backing up my existing installation of eM Client I followed your suggestions

I uninstalled the existing version of eM Client. Although you hadn’t mentioned this I opted into keeping the database during the uninstall. I reinstalled the latest version downloaded from the link you provided. The email accounts that had been imported before with the old version of eM Client all restored and this restoration included the latest emails that had been downloaded just prior to the uninstallation of the previous version. During the installation of the new version I had all the eM Client screens pulled to one side of my display and was keeping an eye on the Desktop to see if any browser window opened in the background while I was attempting to add the new email account. No browser window opened in the background. I have had a default browser set up on this system for years and am sure a lack of a default browser is not the issue. The add new account process won’t finish and I don’t understand why some sort of an error message doesn’t display telling specifically what the problem is.

Notwithstanding all this I still can’t get my new account into eM Client. Isn’t there a setting somewhere where I could simply go to to allow this access?

Go to your Windows settings, and select a different browser as default and then try the account setup again.


I tried your suggestion and just like that the new account added successfully. Thank you.


I had a problem sending/receiving emails which resulted from changing my Google account password which then disabled my app-specific password and made it impossible to send/receive emails… Worked endless hours on it and couldn’t figure out how to make it work. Tried your suggestion of using a different browser, deleted eM Client, downloaded it again, and lo and behold, your suggestion worked and I can send/receive emails again. Thank you!!!

1 Like