Two translation bugs: 1) Sometimes it doesn't detect foreign language and 2) No way to revert back to original language

I see two translation bugs:

  1. eM often doesn’t detect that there’s a foreign language. Is there some way to force it to translate? It’s strange that it often can’t detect messages that are 100% Japanese. And sometimes I receive emails that are partly English and partly Japanese – it would be great to have a way to force it to translate the entire message into English.

  2. After I translate a message “now”, there’s often no way to go back to the original message (“Show original” does not appear) unless I restart eM Client. And often after restarting, eM no longer detects that the exact same message can be translated and shows no translation options at the top at all. No idea why it would detect a message in a foreign language properly once, then not detect the same message after a restart.

Ok, for the second half of #2, not detecting a message after a restart – it seems this was because I had clicked “never” a few minutes before (while trying to figure out what’s happening with #1 and #2) and this turned off Japanese translation for ALL messages. But this is confusing and irrational, because the text says:

“Japanese language detected. Do you want to translate message now or never.”

This does NOT imply that clicking never will turn off Japanese translation for the entire app. This option does not belong here. If I want to turn off translation for a particular language forever, that’s what the Settings panel is for.

No solution? I need translation to be reliable.

jueves 07 octubre 2021 :: 1230hrs (UTC +01:00)

Hi @armandhammer

I frequently move between Spanish, Portuguese, English & Russian and have not experienced any of the issues you have described; though I have noticed that some of the translation (Spanish, Portuguese, English - I am tri-lingual was brought up in Bolivia & Spain educated in Spain, UK & USA with British father and Portuguese mother) is a bit odd to say the least! (I just correct it myself)
I have to trust to luck with Russian though I haven’t had any adverse comments - maybe the Russians are just tolerant of email/web translation.
Maybe there is something that is specific to Japanese, I know that Chinese is also odd.

My computer OS is Spanish and I have eMC set to Spanish.

¡Saludos desde la soleada Valencia en España!
¡Mis mejores deseos y mantente a salvo!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.