Trouble sending on - "Password required for SMTP" already have port 465 on special legacy set up

Here is the error I get when I try to send.  Started getting this out of blue after I downloaded new version.  I have checked all my settings repeatedly, and they are all correct.  Sometimes, if I try to send it over and over again, it will all the sudden go through for no apparent reason.  Please help!

Hi Kyra, can you please make a screenshot of your account settings from Tools > Accounts > Your account > IMAP?
This seems to be an issue with verizon as several other users have reported this issue, but should be only an account setup issue.

Thank you,

Here you go - and just an FYI - now I cannot send email at all even if I try repeatedly.

Thank you for your time and help :slight_smile:

Hi again, I understand you’re not using an IMAP account, can you please check your login credentials in the “General” tab and make sure you’re using “identity credentials” for your SMTP and POP3 settings?

Thank you,

Thanks Paul - I just did this and my outgoing credentials are still being rejected.

Should I use an IMAP account?  I’m not sure of the difference…

Same problem here, I can receive but not send email (Verizon)

I too have been having problems SENDING email.  It takes about five attempts to get it to go.  I get several error messages. One being “eM Client can’t verify identity of -the host name doesn’t match the name specified in the certificate”  I tried to attach a screen shot but it isn’t a jpg, png or gif file.

I would like to also add that as of today I can’t send anything on multiple attempts.  The past two days if I tried continuously I would eventually get the email to send. Today I have not been able to send out one email.

Same issue.  Both my Hotmail and Verizon accounts can receive but cannot send.  Occasionally I can trick the program into sending it by exiting out and then opening it again.  I’ve checked and re-checked the settings and all is correct but it is still not working properly.

Yes, Brian, I did the same - opening and closing the program - it worked initially but today I haven’t been able to send one email.  This all started after an update, no?

I have been having the identical problem ever since the most recent Upgrade of eMClient.  I worked extensively with a Verizon agent who concluded the problem is with eM Client and not with my settings.

Thanks for posting that. The last thing I want to do is get on the phone with VZ troubleshooters. I had a feeling that VZ wouldn’t be able to fix this. Hopefully eMClient figures this out for us and there is a fix.

Same thing here with a VZ account  eM Client will receive, but not send since last night.  All settings correct.  I sometimes get the “Password Required” box, other times I get an error message saying it can’t verify VZ’s certificate and it may be a false one.

Hi again, I’ve discussed this issue with my colleagues, but unfortunately we believe this is a server issue, as several users of verizon reported the issue at the same time without changing any settings/or updating the application, please make sure you’re using the correct mail settings that should be available here:…

And if you’re please contact Verizon support in order to resolve this issue.

Thank you for understanding,